CYQ.Data

CYQ.Data API 帮助文档 For V5

CYQ.Data Namespace

Namespace hierarchy

Classes

Class | Description
AppConfig | 常用配置文件项[Web(App).Config]的[appSettings|connectionStrings]项和属性名一致。 除了可以从配置文件配置，也可以直接赋值。
AppConfig.Cache | 缓存相关的配置
AppConfig.DB | DataBase 相关的配置
AppConfig.Debug | 调试类AppDebug 相关的配置
AppConfig.Log | 日志类Log 相关的配置
AppConfig.UI |
AppConfig.XHtml | XHtml 相关的配置
AppDebug | this class can intercept sql 应用程序调试类,能截到应用程序所有执行的SQL
Log | Write Log to txt or database 日志静态类（可将日志输出到文本中）
LogType | LogType 日志类型
MAction | Manipulate：table / view / custom statement 操作：表/视图/自定义语句
MProc | Manipulate：sql / procedure 操作：SQL或存储过程
SysLogs | A class for you to Write log to database 日志记录到数据库（需要配置LogConn链接后方有效）

Enumerations

Enumeration | Description
DalType | 操作的数据库类型
InsertOp | MAction Insert Options MAction的Insert方法的返回值选项
ParaType | 特殊参数类型[MProc SetCustom方法所使用的参数]


AppConfig Class

常用配置文件项[Web(App).Config]的[appSettings|connectionStrings]项和属性名一致。 除了可以从配置文件配置，也可以直接赋值。

For a list of all members of this type, see AppConfig Members.

System.Object
AppConfig

public static class AppConfig

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

AppConfig Members | CYQ.Data Namespace


AppConfig Members

AppConfig overview

Public Static Properties

IsEnumToInt | 是否使用表字段枚举转Int方式（默认为false）。 设置为true时，可以加快一点性能，但生成的表字段枚举必须和数据库一致。
IsAspNetCore | 当前是否ASP.NET Core环境。
JsonEscape | 是否ToJson输出时自动转义特殊符号("\ \r \t等) 可配置项为（Default、Yes、No)
Aop | Aop 插件配置项 示例配置：[ 完整类名,程序集(dll)名称]<add key="Aop" value="Web.Aop.AopAction,Aop"/>
ThreadBreakPath | Tool.ThreadBreak 使用时，外置的文件配置相对路径（默认在环境变量Temp对应文件中）
EntitySuffix | 生成的实体类的后缀。
Version | 获取当前Dll的版本号
RunPath | 框架的运行路径(最外层的目录） Win项目：是dll和exe所在的目录； Asp.net项目：是指根目录； Asp.net core 项目：是指运行的路径（dll所在的路径，同Win项目）。
AssemblyPath | 框架的程序集所在的运行路径
EncryptKey | EncryptHelper加密的Key。
WebRootPath | Web根目录(ASP.NET Core 项目时，由于机制不同，指向的路径需要调整，所以该值可以修改)

Public Static Methods

GetApp | Overloaded. 获取Web.config或App.config的值。
GetAppBool | 获取Web.config或App.config的数字值（允许值不存在或为空时输出默认值）。
GetAppInt | 获取Web.config或App.config的数字值（允许值不存在或为空时输出默认值）。
GetConn | 获取Web.config或App.config的connectionStrings节点的值。
SetApp | 设置Web.config或App.config的值 value为null时移除缓存。
SetConn | 添加自定义链接（内存有效，并未写入config文件） value为null时移除缓存

See Also

AppConfig Class | CYQ.Data Namespace


AppConfig Properties

The properties of the AppConfig class are listed below. For a complete list of AppConfig class members, see the AppConfig Members topic.

Public Static Properties

IsEnumToInt | 是否使用表字段枚举转Int方式（默认为false）。 设置为true时，可以加快一点性能，但生成的表字段枚举必须和数据库一致。
IsAspNetCore | 当前是否ASP.NET Core环境。
JsonEscape | 是否ToJson输出时自动转义特殊符号("\ \r \t等) 可配置项为（Default、Yes、No)
Aop | Aop 插件配置项 示例配置：[ 完整类名,程序集(dll)名称]<add key="Aop" value="Web.Aop.AopAction,Aop"/>
ThreadBreakPath | Tool.ThreadBreak 使用时，外置的文件配置相对路径（默认在环境变量Temp对应文件中）
EntitySuffix | 生成的实体类的后缀。
Version | 获取当前Dll的版本号
RunPath | 框架的运行路径(最外层的目录） Win项目：是dll和exe所在的目录； Asp.net项目：是指根目录； Asp.net core 项目：是指运行的路径（dll所在的路径，同Win项目）。
AssemblyPath | 框架的程序集所在的运行路径
EncryptKey | EncryptHelper加密的Key。
WebRootPath | Web根目录(ASP.NET Core 项目时，由于机制不同，指向的路径需要调整，所以该值可以修改)

See Also

AppConfig Class | CYQ.Data Namespace


Aop Property

CYQ.Data API 帮助文档 For V5

AppConfig.Aop Property

Aop 插件配置项 示例配置：[ 完整类名,程序集(dll)名称]<add key="Aop" value="Web.Aop.AopAction,Aop"/>

public static Aop {get; set;}

See Also

AppConfig Class | CYQ.Data Namespace


AssemblyPath Property

CYQ.Data API 帮助文档 For V5

AppConfig.AssemblyPath Property

框架的程序集所在的运行路径

public static AssemblyPath {get;}

See Also

AppConfig Class | CYQ.Data Namespace


EncryptKey Property

CYQ.Data API 帮助文档 For V5

AppConfig.EncryptKey Property

EncryptHelper加密的Key。

public static EncryptKey {get; set;}

See Also

AppConfig Class | CYQ.Data Namespace


EntitySuffix Property

CYQ.Data API 帮助文档 For V5

AppConfig.EntitySuffix Property

生成的实体类的后缀。

public static EntitySuffix {get; set;}

See Also

AppConfig Class | CYQ.Data Namespace


IsAspNetCore Property

CYQ.Data API 帮助文档 For V5

AppConfig.IsAspNetCore Property

当前是否ASP.NET Core环境。

public static IsAspNetCore {get; set;}

See Also

AppConfig Class | CYQ.Data Namespace


IsEnumToInt Property

CYQ.Data API 帮助文档 For V5

AppConfig.IsEnumToInt Property

是否使用表字段枚举转Int方式（默认为false）。 设置为true时，可以加快一点性能，但生成的表字段枚举必须和数据库一致。

public static IsEnumToInt {get; set;}

See Also

AppConfig Class | CYQ.Data Namespace


JsonEscape Property

CYQ.Data API 帮助文档 For V5

AppConfig.JsonEscape Property

是否ToJson输出时自动转义特殊符号("\ \r \t等) 可配置项为（Default、Yes、No)

public static JsonEscape {get; set;}

See Also

AppConfig Class | CYQ.Data Namespace


RunPath Property

CYQ.Data API 帮助文档 For V5

AppConfig.RunPath Property

框架的运行路径(最外层的目录） Win项目：是dll和exe所在的目录； Asp.net项目：是指根目录； Asp.net core 项目：是指运行的路径（dll所在的路径，同Win项目）。

public static RunPath {get;}

See Also

AppConfig Class | CYQ.Data Namespace


ThreadBreakPath Property

CYQ.Data API 帮助文档 For V5

AppConfig.ThreadBreakPath Property

Tool.ThreadBreak 使用时，外置的文件配置相对路径（默认在环境变量Temp对应文件中）

public static ThreadBreakPath {get; set;}

See Also

AppConfig Class | CYQ.Data Namespace


Version Property

CYQ.Data API 帮助文档 For V5

AppConfig.Version Property

获取当前Dll的版本号

public static Version {get;}

See Also

AppConfig Class | CYQ.Data Namespace


WebRootPath Property

CYQ.Data API 帮助文档 For V5

AppConfig.WebRootPath Property

Web根目录(ASP.NET Core 项目时，由于机制不同，指向的路径需要调整，所以该值可以修改)

public static WebRootPath {get; set;}

See Also

AppConfig Class | CYQ.Data Namespace


AppConfig Methods

The methods of the AppConfig class are listed below. For a complete list of AppConfig class members, see the AppConfig Members topic.

Public Static Methods

GetApp | Overloaded. 获取Web.config或App.config的值。
GetAppBool | 获取Web.config或App.config的数字值（允许值不存在或为空时输出默认值）。
GetAppInt | 获取Web.config或App.config的数字值（允许值不存在或为空时输出默认值）。
GetConn | 获取Web.config或App.config的connectionStrings节点的值。
SetApp | 设置Web.config或App.config的值 value为null时移除缓存。
SetConn | 添加自定义链接（内存有效，并未写入config文件） value为null时移除缓存

See Also

AppConfig Class | CYQ.Data Namespace


GetApp Method

CYQ.Data API 帮助文档 For V5

AppConfig.GetApp Method

获取Web.config或App.config的值。

Overload List

获取Web.config或App.config的值。

public static string GetApp(String);

获取Web.config或App.config的值（允许值不存在或为空时输出默认值）。

public static string GetApp(String,String);

See Also

AppConfig Class | CYQ.Data Namespace


AppConfig.GetApp Method (String)

获取Web.config或App.config的值。

public static string GetApp(
String key
);

See Also

AppConfig Class | CYQ.Data Namespace | AppConfig.GetApp Overload List


AppConfig.GetApp Method (String, String)

获取Web.config或App.config的值（允许值不存在或为空时输出默认值）。

public static string GetApp(
String key,
String defaultValue
);

See Also

AppConfig Class | CYQ.Data Namespace | AppConfig.GetApp Overload List


AppConfig.GetAppBool Method

获取Web.config或App.config的数字值（允许值不存在或为空时输出默认值）。

public static bool GetAppBool(
String key,
Boolean defaultValue
);

See Also

AppConfig Class | CYQ.Data Namespace


AppConfig.GetAppInt Method

获取Web.config或App.config的数字值（允许值不存在或为空时输出默认值）。

public static int GetAppInt(
String key,
Int32 defaultValue
);

See Also

AppConfig Class | CYQ.Data Namespace


AppConfig.GetConn Method

获取Web.config或App.config的connectionStrings节点的值。

public static string GetConn(
String name
);

See Also

AppConfig Class | CYQ.Data Namespace


AppConfig.SetApp Method

设置Web.config或App.config的值 value为null时移除缓存。

public static bool SetApp(
String key,
String value
);

See Also

AppConfig Class | CYQ.Data Namespace


AppConfig.SetConn Method

添加自定义链接（内存有效，并未写入config文件） value为null时移除缓存

public static bool SetConn(
String name,
String connectionString
);

Parameters

String
名称
String
链接字符串

See Also

AppConfig Class | CYQ.Data Namespace


AppConfig.Cache Class

缓存相关的配置

For a list of all members of this type, see AppConfig.Cache Members.

System.Object
AppConfig.Cache

public static class AppConfig.Cache

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

AppConfig.Cache Members | CYQ.Data Namespace


AppConfig.Cache Members

AppConfig.Cache overview

Public Static Properties

IsAutoCache | 是否智能缓存数据（默认开启）
RedisUseDBCount | Redis 使用的DB数（默认1，使用db0）
RedisUseDBIndex | Redis 使用的DB 索引（默认0，若配置，则会忽略RedisUseDBCount）
DefaultCacheTime | Cache.CacheManage 默认缓存项的时间[分钟(默认60)]
AutoCacheTaskTime | 当AutoCacheConn开启后，定时扫描数据库的任务时间（毫秒）,默认1000
MemCacheServers | MemCache分布式缓存的服务器配置，多个用逗号（,）分隔
MemCacheServersBak | MemCache 备份服务器（当主服务器挂了后，请求会转向备用机）
RedisServers | Redis分布式缓存的服务器配置，多个用逗号（,）分隔 格式：ip:port - password
RedisServersBak | Redis 备份服务器（当主服务器挂了后，请求会转向备用机），多个用逗号（,）分隔 格式：ip:port - password
CacheTables | AutoCache开启时，可以设置仅需要缓存的Table，多个用逗号分隔（此项配置时，NoCacheTables配置则被无忽略）
NoCacheTables | AutoCache开启时，可以设置不缓存的Table，多个用逗号分隔
IngoreCacheColumns | AutoCache开启时，可以设置不受更新影响的列名，用Json格式。 {talbeName1:'column1,column2',talbeName2:'column1,column2'}
AutoCacheConn | CYQ.Data.Cache 自动缓存 - 数据库链接配置 在多个不同的应用项目里操作同一个数据库时（又不想使用分布式缓存MemCache或Redis），可以开启此项，达到缓存智能清除的效果。

See Also

AppConfig.Cache Class | CYQ.Data Namespace


AppConfig.Cache Properties

The properties of the AppConfig.Cache class are listed below. For a complete list of AppConfig.Cache class members, see the AppConfig.Cache Members topic.

Public Static Properties

IsAutoCache | 是否智能缓存数据（默认开启）
RedisUseDBCount | Redis 使用的DB数（默认1，使用db0）
RedisUseDBIndex | Redis 使用的DB 索引（默认0，若配置，则会忽略RedisUseDBCount）
DefaultCacheTime | Cache.CacheManage 默认缓存项的时间[分钟(默认60)]
AutoCacheTaskTime | 当AutoCacheConn开启后，定时扫描数据库的任务时间（毫秒）,默认1000
MemCacheServers | MemCache分布式缓存的服务器配置，多个用逗号（,）分隔
MemCacheServersBak | MemCache 备份服务器（当主服务器挂了后，请求会转向备用机）
RedisServers | Redis分布式缓存的服务器配置，多个用逗号（,）分隔 格式：ip:port - password
RedisServersBak | Redis 备份服务器（当主服务器挂了后，请求会转向备用机），多个用逗号（,）分隔 格式：ip:port - password
CacheTables | AutoCache开启时，可以设置仅需要缓存的Table，多个用逗号分隔（此项配置时，NoCacheTables配置则被无忽略）
NoCacheTables | AutoCache开启时，可以设置不缓存的Table，多个用逗号分隔
IngoreCacheColumns | AutoCache开启时，可以设置不受更新影响的列名，用Json格式。 {talbeName1:'column1,column2',talbeName2:'column1,column2'}
AutoCacheConn | CYQ.Data.Cache 自动缓存 - 数据库链接配置 在多个不同的应用项目里操作同一个数据库时（又不想使用分布式缓存MemCache或Redis），可以开启此项，达到缓存智能清除的效果。

See Also

AppConfig.Cache Class | CYQ.Data Namespace


AutoCacheConn Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.AutoCacheConn Property

CYQ.Data.Cache 自动缓存 - 数据库链接配置 在多个不同的应用项目里操作同一个数据库时（又不想使用分布式缓存MemCache或Redis），可以开启此项，达到缓存智能清除的效果。

public static AutoCacheConn {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


AutoCacheTaskTime Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.AutoCacheTaskTime Property

当AutoCacheConn开启后，定时扫描数据库的任务时间（毫秒）,默认1000

public static AutoCacheTaskTime {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


CacheTables Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.CacheTables Property

AutoCache开启时，可以设置仅需要缓存的Table，多个用逗号分隔（此项配置时，NoCacheTables配置则被无忽略）

public static CacheTables {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


DefaultCacheTime Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.DefaultCacheTime Property

Cache.CacheManage 默认缓存项的时间[分钟(默认60)]

public static DefaultCacheTime {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


IngoreCacheColumns Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.IngoreCacheColumns Property

AutoCache开启时，可以设置不受更新影响的列名，用Json格式。 {talbeName1:'column1,column2',talbeName2:'column1,column2'}

public static IngoreCacheColumns {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


IsAutoCache Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.IsAutoCache Property

是否智能缓存数据（默认开启）

public static IsAutoCache {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


MemCacheServers Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.MemCacheServers Property

MemCache分布式缓存的服务器配置，多个用逗号（,）分隔

public static MemCacheServers {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


MemCacheServersBak Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.MemCacheServersBak Property

MemCache 备份服务器（当主服务器挂了后，请求会转向备用机）

public static MemCacheServersBak {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


NoCacheTables Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.NoCacheTables Property

AutoCache开启时，可以设置不缓存的Table，多个用逗号分隔

public static NoCacheTables {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


RedisServers Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.RedisServers Property

Redis分布式缓存的服务器配置，多个用逗号（,）分隔 格式：ip:port - password

public static RedisServers {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


RedisServersBak Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.RedisServersBak Property

Redis 备份服务器（当主服务器挂了后，请求会转向备用机），多个用逗号（,）分隔 格式：ip:port - password

public static RedisServersBak {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


RedisUseDBCount Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.RedisUseDBCount Property

Redis 使用的DB数（默认1，使用db0）

public static RedisUseDBCount {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


RedisUseDBIndex Property

CYQ.Data API 帮助文档 For V5

AppConfig.Cache.RedisUseDBIndex Property

Redis 使用的DB 索引（默认0，若配置，则会忽略RedisUseDBCount）

public static RedisUseDBIndex {get; set;}

See Also

AppConfig.Cache Class | CYQ.Data Namespace


AppConfig.DB Class

DataBase 相关的配置

For a list of all members of this type, see AppConfig.DB Members.

System.Object
AppConfig.DB

public static class AppConfig.DB

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

AppConfig.DB Members | CYQ.Data Namespace


AppConfig.DB Members

AppConfig.DB overview

Public Static Properties

PagerBySelectBase | MSSQL是否启用分页存储过程SelectBase，默认false
DefaultDalType | 默认数据库类型（只读）
CommandTimeout | 全局的数据库命令默认超时设置，默认值120秒（单位：秒）
MasterSlaveTime | 读写分离时用户对主数据库操作持续时间，默认值10秒s（单位：秒s）
DefaultConn | 默认数据库链接（可赋完整链接语句或Web.config配置项名称） 如果不在配置文件(Web.Config）上配置Conn链接，可对此属性赋值进行配置。
DefaultDataBase | 默认数据库名称（只读）
FilterSqlInjection | MAction所有操作中的where条件，默认有超强的过滤单词，来过滤Sql注入关键字，如果语句包含指定的过滤词，则会返回错误信息，并记录日志。 如果需要自定义关键字，可配置此项，如：“delete;from,truncate，其它单词”，分号表词组，需要同时包含两个词； 多个过滤词组以","逗号分隔
AutoID | MAction 操作 Oracle 时自增加int类型ID所需要配置的序列ID，Guid为ID则不用。 如果需要为每个表都配置一个序列号，可以使用：SEQ_{0} 其中{0}会自动配对成表名，如果没有{0}，则为整个数据库共用一个序列。 默认参数值：SEQ_{0}
SchemaMapPath | MAction 可将表架构映射到外部指定相对路径[外部存储,可避开数据库读取]
DeleteField | 删除字段名称（若表存在此设置的字段名称时，MActon的删除操作将变更变为更新操作） 默认：IsDeleted
EditTimeFields | 更新时间字段名称（若表存在指定字段名称时，自动更新时间，多个用逗号分隔）
HiddenFields | 系统全局要隐藏的字段名称（默认值为："cyqrownum,rowguid,deletefield"）

See Also

AppConfig.DB Class | CYQ.Data Namespace


AppConfig.DB Properties

The properties of the AppConfig.DB class are listed below. For a complete list of AppConfig.DB class members, see the AppConfig.DB Members topic.

Public Static Properties

PagerBySelectBase | MSSQL是否启用分页存储过程SelectBase，默认false
DefaultDalType | 默认数据库类型（只读）
CommandTimeout | 全局的数据库命令默认超时设置，默认值120秒（单位：秒）
MasterSlaveTime | 读写分离时用户对主数据库操作持续时间，默认值10秒s（单位：秒s）
DefaultConn | 默认数据库链接（可赋完整链接语句或Web.config配置项名称） 如果不在配置文件(Web.Config）上配置Conn链接，可对此属性赋值进行配置。
DefaultDataBase | 默认数据库名称（只读）
FilterSqlInjection | MAction所有操作中的where条件，默认有超强的过滤单词，来过滤Sql注入关键字，如果语句包含指定的过滤词，则会返回错误信息，并记录日志。 如果需要自定义关键字，可配置此项，如：“delete;from,truncate，其它单词”，分号表词组，需要同时包含两个词； 多个过滤词组以","逗号分隔
AutoID | MAction 操作 Oracle 时自增加int类型ID所需要配置的序列ID，Guid为ID则不用。 如果需要为每个表都配置一个序列号，可以使用：SEQ_{0} 其中{0}会自动配对成表名，如果没有{0}，则为整个数据库共用一个序列。 默认参数值：SEQ_{0}
SchemaMapPath | MAction 可将表架构映射到外部指定相对路径[外部存储,可避开数据库读取]
DeleteField | 删除字段名称（若表存在此设置的字段名称时，MActon的删除操作将变更变为更新操作） 默认：IsDeleted
EditTimeFields | 更新时间字段名称（若表存在指定字段名称时，自动更新时间，多个用逗号分隔）
HiddenFields | 系统全局要隐藏的字段名称（默认值为："cyqrownum,rowguid,deletefield"）

See Also

AppConfig.DB Class | CYQ.Data Namespace


AutoID Property

CYQ.Data API 帮助文档 For V5

AppConfig.DB.AutoID Property

MAction 操作 Oracle 时自增加int类型ID所需要配置的序列ID，Guid为ID则不用。 如果需要为每个表都配置一个序列号，可以使用：SEQ_{0} 其中{0}会自动配对成表名，如果没有{0}，则为整个数据库共用一个序列。 默认参数值：SEQ_{0}

public static AutoID {get; set;}

See Also

AppConfig.DB Class | CYQ.Data Namespace


CommandTimeout Property

CYQ.Data API 帮助文档 For V5

AppConfig.DB.CommandTimeout Property

全局的数据库命令默认超时设置，默认值120秒（单位：秒）

public static CommandTimeout {get; set;}

See Also

AppConfig.DB Class | CYQ.Data Namespace


DefaultConn Property

CYQ.Data API 帮助文档 For V5

AppConfig.DB.DefaultConn Property

默认数据库链接（可赋完整链接语句或Web.config配置项名称） 如果不在配置文件(Web.Config）上配置Conn链接，可对此属性赋值进行配置。

public static DefaultConn {get; set;}

See Also

AppConfig.DB Class | CYQ.Data Namespace


DefaultDalType Property

CYQ.Data API 帮助文档 For V5

AppConfig.DB.DefaultDalType Property

默认数据库类型（只读）

public static DefaultDalType {get;}

See Also

AppConfig.DB Class | CYQ.Data Namespace


DefaultDataBase Property

CYQ.Data API 帮助文档 For V5

AppConfig.DB.DefaultDataBase Property

默认数据库名称（只读）

public static DefaultDataBase {get;}

See Also

AppConfig.DB Class | CYQ.Data Namespace


DeleteField Property

CYQ.Data API 帮助文档 For V5

AppConfig.DB.DeleteField Property

删除字段名称（若表存在此设置的字段名称时，MActon的删除操作将变更变为更新操作） 默认：IsDeleted

public static DeleteField {get; set;}

See Also

AppConfig.DB Class | CYQ.Data Namespace


EditTimeFields Property

CYQ.Data API 帮助文档 For V5

AppConfig.DB.EditTimeFields Property

更新时间字段名称（若表存在指定字段名称时，自动更新时间，多个用逗号分隔）

public static EditTimeFields {get; set;}

See Also

AppConfig.DB Class | CYQ.Data Namespace


FilterSqlInjection Property

CYQ.Data API 帮助文档 For V5

AppConfig.DB.FilterSqlInjection Property

MAction所有操作中的where条件，默认有超强的过滤单词，来过滤Sql注入关键字，如果语句包含指定的过滤词，则会返回错误信息，并记录日志。 如果需要自定义关键字，可配置此项，如：“delete;from,truncate，其它单词”，分号表词组，需要同时包含两个词； 多个过滤词组以","逗号分隔

public static FilterSqlInjection {get; set;}

See Also

AppConfig.DB Class | CYQ.Data Namespace


HiddenFields Property

CYQ.Data API 帮助文档 For V5

AppConfig.DB.HiddenFields Property

系统全局要隐藏的字段名称（默认值为："cyqrownum,rowguid,deletefield"）

public static HiddenFields {get; set;}

See Also

AppConfig.DB Class | CYQ.Data Namespace


MasterSlaveTime Property

CYQ.Data API 帮助文档 For V5

AppConfig.DB.MasterSlaveTime Property

读写分离时用户对主数据库操作持续时间，默认值10秒s（单位：秒s）

public static MasterSlaveTime {get; set;}

See Also

AppConfig.DB Class | CYQ.Data Namespace


PagerBySelectBase Property

CYQ.Data API 帮助文档 For V5

AppConfig.DB.PagerBySelectBase Property

MSSQL是否启用分页存储过程SelectBase，默认false

public static PagerBySelectBase {get; set;}

See Also

AppConfig.DB Class | CYQ.Data Namespace


SchemaMapPath Property

CYQ.Data API 帮助文档 For V5

AppConfig.DB.SchemaMapPath Property

MAction 可将表架构映射到外部指定相对路径[外部存储,可避开数据库读取]

public static SchemaMapPath {get; set;}

See Also

AppConfig.DB Class | CYQ.Data Namespace


AppConfig.Debug Class

调试类AppDebug 相关的配置

For a list of all members of this type, see AppConfig.Debug Members.

System.Object
AppConfig.Debug

public class AppConfig.Debug

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

AppConfig.Debug Members | CYQ.Data Namespace


AppConfig.Debug Members

AppConfig.Debug overview

Public Static Properties

OpenDebugInfo | 开启信息调试记录：开启后MAction.DebugInfo可输出执行日志。 同时AppDebug若要使用，也需要开启此项。
SqlFilter | 毫秒数（这个是在对所有SQL语句的：将所有长时间(ms)的SQL语句写入日志，对应配置项LogPath的路径） 此项设置后，即启用（无视OpenDebugInfo是否设置）
InfoFilter | 毫秒数（这个是在AppDebug开启后的：可通过此项设置条件过滤出时间(ms)较长的SQL语句） OpenDebugInfo为true，同时 AppDebug.Start() 后，此项才有效。

Public Instance Constructors

AppConfig.Debug Constructor

See Also

AppConfig.Debug Class | CYQ.Data Namespace


AppConfig.Debug Constructor

public AppConfig.Debug();

See Also

AppConfig.Debug Class | CYQ.Data Namespace


AppConfig.Debug Properties

The properties of the AppConfig.Debug class are listed below. For a complete list of AppConfig.Debug class members, see the AppConfig.Debug Members topic.

Public Static Properties

OpenDebugInfo | 开启信息调试记录：开启后MAction.DebugInfo可输出执行日志。 同时AppDebug若要使用，也需要开启此项。
SqlFilter | 毫秒数（这个是在对所有SQL语句的：将所有长时间(ms)的SQL语句写入日志，对应配置项LogPath的路径） 此项设置后，即启用（无视OpenDebugInfo是否设置）
InfoFilter | 毫秒数（这个是在AppDebug开启后的：可通过此项设置条件过滤出时间(ms)较长的SQL语句） OpenDebugInfo为true，同时 AppDebug.Start() 后，此项才有效。

See Also

AppConfig.Debug Class | CYQ.Data Namespace


InfoFilter Property

CYQ.Data API 帮助文档 For V5

AppConfig.Debug.InfoFilter Property

毫秒数（这个是在AppDebug开启后的：可通过此项设置条件过滤出时间(ms)较长的SQL语句） OpenDebugInfo为true，同时 AppDebug.Start() 后，此项才有效。

public static InfoFilter {get; set;}

See Also

AppConfig.Debug Class | CYQ.Data Namespace


OpenDebugInfo Property

CYQ.Data API 帮助文档 For V5

AppConfig.Debug.OpenDebugInfo Property

开启信息调试记录：开启后MAction.DebugInfo可输出执行日志。 同时AppDebug若要使用，也需要开启此项。

public static OpenDebugInfo {get; set;}

See Also

AppConfig.Debug Class | CYQ.Data Namespace


SqlFilter Property

CYQ.Data API 帮助文档 For V5

AppConfig.Debug.SqlFilter Property

毫秒数（这个是在对所有SQL语句的：将所有长时间(ms)的SQL语句写入日志，对应配置项LogPath的路径） 此项设置后，即启用（无视OpenDebugInfo是否设置）

public static SqlFilter {get; set;}

See Also

AppConfig.Debug Class | CYQ.Data Namespace


AppConfig.Log Class

日志类Log 相关的配置

For a list of all members of this type, see AppConfig.Log Members.

System.Object
AppConfig.Log

public static class AppConfig.Log

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

AppConfig.Log Members | CYQ.Data Namespace


AppConfig.Log Members

AppConfig.Log overview

Public Static Properties

IsWriteLog | 是否写数据库异常日志（默认true）:开启时：有异常不抛出，转写入数据库；不开启：有异常会抛出
LogConn | CYQ.Data.Log 类记录数据库异常日志 - 数据库链接配置
LogPath | 文本日志的配置相对路径（默认为：Logs/"）
LogTableName | 异常日志表名（默认为SysLogs，可配置）

See Also

AppConfig.Log Class | CYQ.Data Namespace


AppConfig.Log Properties

The properties of the AppConfig.Log class are listed below. For a complete list of AppConfig.Log class members, see the AppConfig.Log Members topic.

Public Static Properties

IsWriteLog | 是否写数据库异常日志（默认true）:开启时：有异常不抛出，转写入数据库；不开启：有异常会抛出
LogConn | CYQ.Data.Log 类记录数据库异常日志 - 数据库链接配置
LogPath | 文本日志的配置相对路径（默认为：Logs/"）
LogTableName | 异常日志表名（默认为SysLogs，可配置）

See Also

AppConfig.Log Class | CYQ.Data Namespace


IsWriteLog Property

CYQ.Data API 帮助文档 For V5

AppConfig.Log.IsWriteLog Property

是否写数据库异常日志（默认true）:开启时：有异常不抛出，转写入数据库；不开启：有异常会抛出

public static IsWriteLog {get; set;}

See Also

AppConfig.Log Class | CYQ.Data Namespace


LogConn Property

CYQ.Data API 帮助文档 For V5

AppConfig.Log.LogConn Property

CYQ.Data.Log 类记录数据库异常日志 - 数据库链接配置

public static LogConn {get; set;}

See Also

AppConfig.Log Class | CYQ.Data Namespace


LogPath Property

CYQ.Data API 帮助文档 For V5

AppConfig.Log.LogPath Property

文本日志的配置相对路径（默认为：Logs/"）

public static LogPath {get; set;}

See Also

AppConfig.Log Class | CYQ.Data Namespace


LogTableName Property

CYQ.Data API 帮助文档 For V5

AppConfig.Log.LogTableName Property

异常日志表名（默认为SysLogs，可配置）

public static LogTableName {get; set;}

See Also

AppConfig.Log Class | CYQ.Data Namespace


AppConfig.UI Class

For a list of all members of this type, see AppConfig.UI Members.

System.Object
AppConfig.UI

public static class AppConfig.UI

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

AppConfig.UI Members | CYQ.Data Namespace


AppConfig.UI Members

AppConfig.UI overview

Public Static Properties

AutoPrefixs UI取值的默认前缀（ddl,chb,txt)，多个用逗号（,）分隔

See Also

AppConfig.UI Class | CYQ.Data Namespace


AppConfig.UI Properties

The properties of the AppConfig.UI class are listed below. For a complete list of AppConfig.UI class members, see the AppConfig.UI Members topic.

Public Static Properties

AutoPrefixs UI取值的默认前缀（ddl,chb,txt)，多个用逗号（,）分隔

See Also

AppConfig.UI Class | CYQ.Data Namespace


AutoPrefixs Property

CYQ.Data API 帮助文档 For V5

AppConfig.UI.AutoPrefixs Property

UI取值的默认前缀（ddl,chb,txt)，多个用逗号（,）分隔

public static AutoPrefixs {get; set;}

See Also

AppConfig.UI Class | CYQ.Data Namespace


AppConfig.XHtml Class

XHtml 相关的配置

For a list of all members of this type, see AppConfig.XHtml Members.

System.Object
AppConfig.XHtml

public static class AppConfig.XHtml

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

AppConfig.XHtml Members | CYQ.Data Namespace


AppConfig.XHtml Members

AppConfig.XHtml overview

Public Static Properties

DtdUri | Xml.XHtmlHelper 中操作Html需要配置的DTD解析文档相对路径
Domain | Xml.MutilLanguage 语言切换设置时Cookie所需要的网站主域名[不带www]
SysLangKey | Xml.MutilLanguage 类的默认语言Key，默认值：Chinese

See Also

AppConfig.XHtml Class | CYQ.Data Namespace


AppConfig.XHtml Properties

The properties of the AppConfig.XHtml class are listed below. For a complete list of AppConfig.XHtml class members, see the AppConfig.XHtml Members topic.

Public Static Properties

DtdUri | Xml.XHtmlHelper 中操作Html需要配置的DTD解析文档相对路径
Domain | Xml.MutilLanguage 语言切换设置时Cookie所需要的网站主域名[不带www]
SysLangKey | Xml.MutilLanguage 类的默认语言Key，默认值：Chinese

See Also

AppConfig.XHtml Class | CYQ.Data Namespace


Domain Property

CYQ.Data API 帮助文档 For V5

AppConfig.XHtml.Domain Property

Xml.MutilLanguage 语言切换设置时Cookie所需要的网站主域名[不带www]

public static Domain {get; set;}

See Also

AppConfig.XHtml Class | CYQ.Data Namespace


DtdUri Property

CYQ.Data API 帮助文档 For V5

AppConfig.XHtml.DtdUri Property

Xml.XHtmlHelper 中操作Html需要配置的DTD解析文档相对路径

public static DtdUri {get; set;}

See Also

AppConfig.XHtml Class | CYQ.Data Namespace


SysLangKey Property

CYQ.Data API 帮助文档 For V5

AppConfig.XHtml.SysLangKey Property

Xml.MutilLanguage 类的默认语言Key，默认值：Chinese

public static SysLangKey {get; set;}

See Also

AppConfig.XHtml Class | CYQ.Data Namespace


AppDebug Class

this class can intercept sql

应用程序调试类,能截到应用程序所有执行的SQL

For a list of all members of this type, see AppDebug Members.

System.Object
AppDebug

public static class AppDebug

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

AppDebug Members | CYQ.Data Namespace


AppDebug Members

AppDebug overview

Public Static Properties

IsRecording | is recoreding sql ? 正在记录中
Info | get sql detail info 获取调试信息

Public Static Methods

Start | start to record sql 开始记录调试信息
Stop | stop to record sql 停止并清除记录的调试信息

See Also

AppDebug Class | CYQ.Data Namespace


AppDebug Properties

The properties of the AppDebug class are listed below. For a complete list of AppDebug class members, see the AppDebug Members topic.

Public Static Properties

IsRecording | is recoreding sql ? 正在记录中
Info | get sql detail info 获取调试信息

See Also

AppDebug Class | CYQ.Data Namespace


Info Property

CYQ.Data API 帮助文档 For V5

AppDebug.Info Property

get sql detail info

获取调试信息

public static Info {get;}

See Also

AppDebug Class | CYQ.Data Namespace


IsRecording Property

CYQ.Data API 帮助文档 For V5

AppDebug.IsRecording Property

is recoreding sql ?

正在记录中

public static IsRecording {get;}

See Also

AppDebug Class | CYQ.Data Namespace


AppDebug Methods

The methods of the AppDebug class are listed below. For a complete list of AppDebug class members, see the AppDebug Members topic.

Public Static Methods

Start | start to record sql 开始记录调试信息
Stop | stop to record sql 停止并清除记录的调试信息

See Also

AppDebug Class | CYQ.Data Namespace


AppDebug.Start Method

start to record sql

开始记录调试信息

public static void Start();

See Also

AppDebug Class | CYQ.Data Namespace


AppDebug.Stop Method

stop to record sql

停止并清除记录的调试信息

public static void Stop();

See Also

AppDebug Class | CYQ.Data Namespace


DalType Enumeration

操作的数据库类型

public enum DalType

Members

Member Name | Description
None |
MsSql | MSSQL[2000/2005/2008/2012/...]
Access |
Oracle |
MySql |
SQLite |
PostgreSQL | PostgreSQL
Txt | Txt DataBase
Xml | Xml DataBase
Sybase |

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data Namespace


InsertOp Enumeration

MAction Insert Options

MAction的Insert方法的返回值选项

public enum InsertOp

Members

Member Name | Description
None | only insert,no return autoIncrement id 使用此项：插入数据后[MSSQL会返回ID,其它数据库则不会返回ID]
ID | insert and return autoincrement id (default option) 使用此项：插入数据后会返回ID[默认选项]。
Fill | insert and select top 1 data to fill row 使用此项：插入数据后,会根据返回ID进行查询后填充数据行。

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data Namespace


Log Class

Write Log to txt or database

日志静态类（可将日志输出到文本中）

For a list of all members of this type, see Log Members.

System.Object
Log

public static class Log

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

Log Members | CYQ.Data Namespace


Log Members

Log overview

Public Static Methods

GetExceptionMessage | Convert Exception to string 获取异常的内部信息
Write | Overloaded. 如果配置数据库则写数据库，没有配置写文本
WriteLogToDB | Overloaded.
WriteLogToTxt | Overloaded.

See Also

Log Class | CYQ.Data Namespace


Log Methods

The methods of the Log class are listed below. For a complete list of Log class members, see the Log Members topic.

Public Static Methods

GetExceptionMessage | Convert Exception to string 获取异常的内部信息
Write | Overloaded. 如果配置数据库则写数据库，没有配置写文本
WriteLogToDB | Overloaded.
WriteLogToTxt | Overloaded.

See Also

Log Class | CYQ.Data Namespace


Log.GetExceptionMessage Method

Convert Exception to string

获取异常的内部信息

public static string GetExceptionMessage(
Exception err
);

See Also

Log Class | CYQ.Data Namespace


Write Method

CYQ.Data API 帮助文档 For V5

Log.Write Method

如果配置数据库则写数据库，没有配置写文本

Overload List

如果配置数据库则写数据库，没有配置写文本

public static void Write(Exception);

public static void Write(Exception,String);

如果配置数据库则写数据库，没有配置写文本

public static void Write(String);

public static void Write(String,String);

See Also

Log Class | CYQ.Data Namespace


Log.Write Method (Exception)

如果配置数据库则写数据库，没有配置写文本

public static void Write(
Exception err
);

See Also

Log Class | CYQ.Data Namespace | Log.Write Overload List


Log.Write Method (Exception, String)

public static void Write(
Exception err,
String logType
);

See Also

Log Class | CYQ.Data Namespace | Log.Write Overload List


Log.Write Method (String)

如果配置数据库则写数据库，没有配置写文本

public static void Write(
String message
);

See Also

Log Class | CYQ.Data Namespace | Log.Write Overload List


Log.Write Method (String, String)

public static void Write(
String message,
String logType
);

See Also

Log Class | CYQ.Data Namespace | Log.Write Overload List


WriteLogToDB Method

CYQ.Data API 帮助文档 For V5

Log.WriteLogToDB Method

Overload List

public static void WriteLogToDB(Exception);

write log to database [LogConn must has config value] 将日志写到数据库中[需要配置LogConn项后方生效 ]

public static void WriteLogToDB(Exception,String);

public static void WriteLogToDB(String);

write log to database [LogConn must has config value] 将日志写到数据库中[需要配置LogConn项后方生效 ]

public static void WriteLogToDB(String,String);

See Also

Log Class | CYQ.Data Namespace


Log.WriteLogToDB Method (Exception)

public static void WriteLogToDB(
Exception err
);

See Also

Log Class | CYQ.Data Namespace | Log.WriteLogToDB Overload List


Log.WriteLogToDB Method (Exception, String)

write log to database [LogConn must has config value]

将日志写到数据库中[需要配置LogConn项后方生效 ]

public static void WriteLogToDB(
Exception err,
String logType
);

See Also

Log Class | CYQ.Data Namespace | Log.WriteLogToDB Overload List


Log.WriteLogToDB Method (String)

public static void WriteLogToDB(
String message
);

See Also

Log Class | CYQ.Data Namespace | Log.WriteLogToDB Overload List


Log.WriteLogToDB Method (String, String)

write log to database [LogConn must has config value]

将日志写到数据库中[需要配置LogConn项后方生效 ]

public static void WriteLogToDB(
String message,
String logType
);

See Also

Log Class | CYQ.Data Namespace | Log.WriteLogToDB Overload List


WriteLogToTxt Method

CYQ.Data API 帮助文档 For V5

Log.WriteLogToTxt Method

Overload List

public static void WriteLogToTxt(Exception);

public static void WriteLogToTxt(Exception,String);

Write log to txt 指定将日志写到外部txt[web.config中配置路径，配置项为Logpath,默认路径为 "Log/" ]

public static void WriteLogToTxt(String);

public static void WriteLogToTxt(String,String);

See Also

Log Class | CYQ.Data Namespace


Log.WriteLogToTxt Method (Exception)

public static void WriteLogToTxt(
Exception err
);

See Also

Log Class | CYQ.Data Namespace | Log.WriteLogToTxt Overload List


Log.WriteLogToTxt Method (Exception, String)

public static void WriteLogToTxt(
Exception err,
String logType
);

See Also

Log Class | CYQ.Data Namespace | Log.WriteLogToTxt Overload List


Log.WriteLogToTxt Method (String)

Write log to txt

指定将日志写到外部txt[web.config中配置路径，配置项为Logpath,默认路径为 "Log/" ]

public static void WriteLogToTxt(
String message
);

See Also

Log Class | CYQ.Data Namespace | Log.WriteLogToTxt Overload List


Log.WriteLogToTxt Method (String, String)

public static void WriteLogToTxt(
String message,
String logType
);

See Also

Log Class | CYQ.Data Namespace | Log.WriteLogToTxt Overload List


LogType Class

LogType

日志类型

For a list of all members of this type, see LogType Members.

System.Object
LogType

public class LogType

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

LogType Members | CYQ.Data Namespace


LogType Members

LogType overview

Public Static Fields

Cache | Cache
DataBase | DataBase
Debug | 调试
Error | 错误
Info | 信息
Warn | 警告

Public Instance Constructors

LogType Constructor

See Also

LogType Class | CYQ.Data Namespace


LogType Constructor

public LogType();

See Also

LogType Class | CYQ.Data Namespace


LogType Fields

The fields of the LogType class are listed below. For a complete list of LogType class members, see the LogType Members topic.

Public Static Fields

Cache | Cache
DataBase | DataBase
Debug | 调试
Error | 错误
Info | 信息
Warn | 警告

See Also

LogType Class | CYQ.Data Namespace


LogType.Cache Field

Cache

public const String Cache = "Cache";

See Also

LogType Class | CYQ.Data Namespace


LogType.DataBase Field

DataBase

public const String DataBase = "DataBase";

See Also

LogType Class | CYQ.Data Namespace


LogType.Debug Field

调试

public const String Debug = "Debug";

See Also

LogType Class | CYQ.Data Namespace


LogType.Error Field

错误

public const String Error = "Error";

See Also

LogType Class | CYQ.Data Namespace


LogType.Info Field

信息

public const String Info = "Info";

See Also

LogType Class | CYQ.Data Namespace


LogType.Warn Field

警告

public const String Warn = "Warn";

See Also

LogType Class | CYQ.Data Namespace


MAction Class

Manipulate：table / view / custom statement

操作：表/视图/自定义语句

For a list of all members of this type, see MAction Members.

System.Object
MAction

public class MAction :

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

MAction Members | CYQ.Data Namespace


MAction Members

MAction overview

Public Static Type Conversions

Implicit OrmBase to MAction Conversion
Implicit SimpleOrmBase to MAction Conversion

Public Instance Constructors

MAction Overloaded. Initializes a new instance of the MAction class.

Public Instance Properties

AllowInsertID | Whether to allow manual insertion of IDs for self-incrementing primary key identification 自增主键标识的，是否允许手动插入ID
ConnectionString | The database connection string 数据库链接字符串
DalType | The database type 数据库类型
DalVersion | The database version 数据库的版本号
Data | Archive the rows of the data structure 存档数据结构的行
DataBase | The database name 数据库名称
DebugInfo | Get or set debugging information [need to set App Config.Debug.Open DebugInfo to ture] 获取或设置调试信息[需要设置AppConfig.Debug.OpenDebugInfo为ture]
RecordsAffected | The number of rows affected when executing a SQL command (-2 is an exception) 执行SQL命令时受影响的行数（-2则为异常）。
TableName | Table name (if the view statement is the operation, the final view of the name) 当前操作的表名(若操作的是视图语句，则为最后的视图名字 ）
TimeOut | Command Timeout[seconds] 命令超时设置[单位秒]
UI | Manipulate UI UI操作

Public Instance Methods

BeginTransation | Begin Transation 开始事务
ClearPara | Clears paras (from SetPara method) 清除(SetPara设置的)自定义参数
Delete | Overloaded. Delete from database [Will automatically try to fetch from the UI when conditions are not passed] 删除数据[不传where条件时将自动尝试从UI获取]
Dispose |
EndTransation | Commit Transation 提交事务
Exists | Overloaded. Whether or not the specified condition exists 是否存在指定条件的数据
Fill | Overloaded. Select top one row to fill this.Data 选择一行数据，并填充到Data属性[不传where条件时将自动尝试从UI获取]
Get | Overloaded. Get value from this.Data 从Data属性里取值
GetCount | Overloaded. Returns the number of records 返回记录数
GetWhere | Overloaded. Get where statement 根据元数据列组合where条件。
Insert | Overloaded. Insert To DataBase 插入数据
ResetTable | Overloaded. Toggle Table Action: To switch between other tables, use this method 切换表操作：如需操作其它表，通过此方法切换
RollBack | RollBack Transation 事务回滚
Select | Overloaded. select all data 选择所有数据
Set | Overloaded. Set value to this.Data 为Data属性设置值
SetAopPara | Pass additional parameters for Aop use 传递额外的参数供Aop使用
SetAopState | Set Aop State 设置Aop状态
SetExpression | Sets a custom expression for the Update operation. 为Update操作设置自定义表达式。
SetPara | Overloaded. Parameterized pass [used when the Where condition is a parameterized (such as: name = @ name) statement] 参数化传参[当Where条件为参数化(如：name=@name)语句时使用]
SetSelectColumns | Specifies the column to read 指定读取的列
SetTransLevel | Set the transaction level 设置事务级别
Update | Overloaded. Update to database [Will automatically try to fetch from the UI when conditions are not passed] 更新数据[不传where条件时将自动尝试从UI获取]

See Also

MAction Class | CYQ.Data Namespace


MAction Constructor

Instantiation

实例化

Overload List

Instantiation 实例化

public MAction(Object);

public MAction(Object,String);

See Also

MAction Class | CYQ.Data Namespace


MAction Constructor (Object)

Instantiation

实例化

public MAction(
Object tableNamesEnum
);

Parameters

Object
Parameters: table name, view, custom statement, DataRow

参数：表名、视图、自定义语句、MDataRow

See Also

MAction Class | CYQ.Data Namespace | MAction Constructor Overload List


MAction Constructor (Object, String)

public MAction(
Object tableNamesEnum,
String conn
);

Parameters

Object
String
Database connection statement or configuration key

数据库链接语句或配置Key

See Also

MAction Class | CYQ.Data Namespace | MAction Constructor Overload List


MAction Properties

The properties of the MAction class are listed below. For a complete list of MAction class members, see the MAction Members topic.

Public Instance Properties

AllowInsertID | Whether to allow manual insertion of IDs for self-incrementing primary key identification 自增主键标识的，是否允许手动插入ID
ConnectionString | The database connection string 数据库链接字符串
DalType | The database type 数据库类型
DalVersion | The database version 数据库的版本号
Data | Archive the rows of the data structure 存档数据结构的行
DataBase | The database name 数据库名称
DebugInfo | Get or set debugging information [need to set App Config.Debug.Open DebugInfo to ture] 获取或设置调试信息[需要设置AppConfig.Debug.OpenDebugInfo为ture]
RecordsAffected | The number of rows affected when executing a SQL command (-2 is an exception) 执行SQL命令时受影响的行数（-2则为异常）。
TableName | Table name (if the view statement is the operation, the final view of the name) 当前操作的表名(若操作的是视图语句，则为最后的视图名字 ）
TimeOut | Command Timeout[seconds] 命令超时设置[单位秒]
UI | Manipulate UI UI操作

See Also

MAction Class | CYQ.Data Namespace


AllowInsertID Property

CYQ.Data API 帮助文档 For V5

MAction.AllowInsertID Property

Whether to allow manual insertion of IDs for self-incrementing primary key identification

自增主键标识的，是否允许手动插入ID

public AllowInsertID {get; set;}

See Also

MAction Class | CYQ.Data Namespace


ConnectionString Property

CYQ.Data API 帮助文档 For V5

MAction.ConnectionString Property

The database connection string

数据库链接字符串

public ConnectionString {get;}

See Also

MAction Class | CYQ.Data Namespace


DalType Property

CYQ.Data API 帮助文档 For V5

MAction.DalType Property

The database type

数据库类型

public DalType {get;}

See Also

MAction Class | CYQ.Data Namespace


DalVersion Property

CYQ.Data API 帮助文档 For V5

MAction.DalVersion Property

The database version 数据库的版本号

public DalVersion {get;}

See Also

MAction Class | CYQ.Data Namespace


Data Property

CYQ.Data API 帮助文档 For V5

MAction.Data Property

Archive the rows of the data structure

存档数据结构的行

public Data {get;}

See Also

MAction Class | CYQ.Data Namespace


DataBase Property

CYQ.Data API 帮助文档 For V5

MAction.DataBase Property

The database name

数据库名称

public DataBase {get;}

See Also

MAction Class | CYQ.Data Namespace


DebugInfo Property

CYQ.Data API 帮助文档 For V5

MAction.DebugInfo Property

Get or set debugging information [need to set App Config.Debug.Open DebugInfo to ture]

获取或设置调试信息[需要设置AppConfig.Debug.OpenDebugInfo为ture]

public DebugInfo {get; set;}

See Also

MAction Class | CYQ.Data Namespace


RecordsAffected Property

CYQ.Data API 帮助文档 For V5

MAction.RecordsAffected Property

The number of rows affected when executing a SQL command (-2 is an exception)

执行SQL命令时受影响的行数（-2则为异常）。

public RecordsAffected {get;}

See Also

MAction Class | CYQ.Data Namespace


TableName Property

CYQ.Data API 帮助文档 For V5

MAction.TableName Property

Table name (if the view statement is the operation, the final view of the name)

当前操作的表名(若操作的是视图语句，则为最后的视图名字

）
public TableName {get; set;}

See Also

MAction Class | CYQ.Data Namespace


TimeOut Property

CYQ.Data API 帮助文档 For V5

MAction.TimeOut Property

Command Timeout[seconds]

命令超时设置[单位秒]

public TimeOut {get; set;}

See Also

MAction Class | CYQ.Data Namespace


UI Property

CYQ.Data API 帮助文档 For V5

MAction.UI Property

Manipulate UI

UI操作

public UI {get;}

See Also

MAction Class | CYQ.Data Namespace


MAction Methods

The methods of the MAction class are listed below. For a complete list of MAction class members, see the MAction Members topic.

Public Instance Methods

BeginTransation | Begin Transation 开始事务
ClearPara | Clears paras (from SetPara method) 清除(SetPara设置的)自定义参数
Delete | Overloaded. Delete from database [Will automatically try to fetch from the UI when conditions are not passed] 删除数据[不传where条件时将自动尝试从UI获取]
Dispose |
EndTransation | Commit Transation 提交事务
Exists | Overloaded. Whether or not the specified condition exists 是否存在指定条件的数据
Fill | Overloaded. Select top one row to fill this.Data 选择一行数据，并填充到Data属性[不传where条件时将自动尝试从UI获取]
Get | Overloaded. Get value from this.Data 从Data属性里取值
GetCount | Overloaded. Returns the number of records 返回记录数
GetWhere | Overloaded. Get where statement 根据元数据列组合where条件。
Insert | Overloaded. Insert To DataBase 插入数据
ResetTable | Overloaded. Toggle Table Action: To switch between other tables, use this method 切换表操作：如需操作其它表，通过此方法切换
RollBack | RollBack Transation 事务回滚
Select | Overloaded. select all data 选择所有数据
Set | Overloaded. Set value to this.Data 为Data属性设置值
SetAopPara | Pass additional parameters for Aop use 传递额外的参数供Aop使用
SetAopState | Set Aop State 设置Aop状态
SetExpression | Sets a custom expression for the Update operation. 为Update操作设置自定义表达式。
SetPara | Overloaded. Parameterized pass [used when the Where condition is a parameterized (such as: name = @ name) statement] 参数化传参[当Where条件为参数化(如：name=@name)语句时使用]
SetSelectColumns | Specifies the column to read 指定读取的列
SetTransLevel | Set the transaction level 设置事务级别
Update | Overloaded. Update to database [Will automatically try to fetch from the UI when conditions are not passed] 更新数据[不传where条件时将自动尝试从UI获取]

See Also

MAction Class | CYQ.Data Namespace


MAction.BeginTransation Method

Begin Transation

开始事务

public void BeginTransation();

See Also

MAction Class | CYQ.Data Namespace


MAction.ClearPara Method

Clears paras (from SetPara method)

清除(SetPara设置的)自定义参数

public void ClearPara();

See Also

MAction Class | CYQ.Data Namespace


Delete Method

CYQ.Data API 帮助文档 For V5

MAction.Delete Method

Delete from database [Will automatically try to fetch from the UI when conditions are not passed]

删除数据[不传where条件时将自动尝试从UI获取]

Overload List

Delete from database [Will automatically try to fetch from the UI when conditions are not passed] 删除数据[不传where条件时将自动尝试从UI获取]

public bool Delete();

public bool Delete(Object);

See Also

MAction Class | CYQ.Data Namespace


MAction.Delete Method ()

Delete from database [Will automatically try to fetch from the UI when conditions are not passed]

删除数据[不传where条件时将自动尝试从UI获取]

public bool Delete();

See Also

MAction Class | CYQ.Data Namespace | MAction.Delete Overload List


MAction.Delete Method (Object)

public bool Delete(
Object where
);

Parameters

Object
Sql statement where the conditions: 88, "id = 88"

sql语句的where条件：88、"id=88"

See Also

MAction Class | CYQ.Data Namespace | MAction.Delete Overload List


MAction.Dispose Method

public void Dispose();

Implements

IDisposable.

See Also

MAction Class | CYQ.Data Namespace


MAction.EndTransation Method

Commit Transation

提交事务

public bool EndTransation();

See Also

MAction Class | CYQ.Data Namespace


Exists Method

CYQ.Data API 帮助文档 For V5

MAction.Exists Method

Whether or not the specified condition exists

是否存在指定条件的数据

Overload List

Whether or not the specified condition exists 是否存在指定条件的数据

public bool Exists();

public bool Exists(Object);

See Also

MAction Class | CYQ.Data Namespace


MAction.Exists Method ()

Whether or not the specified condition exists

是否存在指定条件的数据

public bool Exists();

See Also

MAction Class | CYQ.Data Namespace | MAction.Exists Overload List


MAction.Exists Method (Object)

public bool Exists(
Object where
);

Parameters

Object
Sql statement where the conditions: 88, "id = 88"

sql语句的where条件：88、"id=88"

See Also

MAction Class | CYQ.Data Namespace | MAction.Exists Overload List


Fill Method

CYQ.Data API 帮助文档 For V5

MAction.Fill Method

Select top one row to fill this.Data

选择一行数据，并填充到Data属性[不传where条件时将自动尝试从UI获取]

Overload List

Select top one row to fill this.Data 选择一行数据，并填充到Data属性[不传where条件时将自动尝试从UI获取]

public bool Fill();

public bool Fill(Object);

See Also

MAction Class | CYQ.Data Namespace


MAction.Fill Method ()

Select top one row to fill this.Data

选择一行数据，并填充到Data属性[不传where条件时将自动尝试从UI获取]

public bool Fill();

See Also

MAction Class | CYQ.Data Namespace | MAction.Fill Overload List


MAction.Fill Method (Object)

public bool Fill(
Object where
);

Parameters

Object
Sql statement where the conditions: 88, "id = 88"

sql语句的where条件：88、"id=88"

See Also

MAction Class | CYQ.Data Namespace | MAction.Fill Overload List


Get Method

CYQ.Data API 帮助文档 For V5

MAction.Get Method

Get value from this.Data

从Data属性里取值

Overload List

Get value from this.Data 从Data属性里取值

public T Get<T>(Object);

public T Get<T>(Object,MAction.T);

See Also

MAction Class | CYQ.Data Namespace


MAction.Get Method (Object)

Get value from this.Data

从Data属性里取值

public T <T>Get(
Object key
);

See Also

MAction Class | CYQ.Data Namespace | MAction.Get Overload List


MAction.Get Method (Object, ``0)

public T <T>Get(
Object key,
MAction.T defaultValue
);

Parameters

Object
MAction.T
defaultValue

值为Null时的默认替换值

See Also

MAction Class | CYQ.Data Namespace | MAction.Get Overload List


GetCount Method

CYQ.Data API 帮助文档 For V5

MAction.GetCount Method

Returns the number of records

返回记录数

Overload List

Returns the number of records 返回记录数

public int GetCount();

public int GetCount(Object);

See Also

MAction Class | CYQ.Data Namespace


MAction.GetCount Method ()

Returns the number of records

返回记录数

public int GetCount();

See Also

MAction Class | CYQ.Data Namespace | MAction.GetCount Overload List


MAction.GetCount Method (Object)

public int GetCount(
Object where
);

Parameters

Object
Sql statement where the conditions: 88, "id = 88"

sql语句的where条件：88、"id=88"

See Also

MAction Class | CYQ.Data Namespace | MAction.GetCount Overload List


GetWhere Method

CYQ.Data API 帮助文档 For V5

MAction.GetWhere Method

Overload List

public string GetWhere(params MDataCell[]);

Get where statement 根据元数据列组合where条件。

public string GetWhere(Boolean,params MDataCell[]);

See Also

MAction Class | CYQ.Data Namespace


MAction.GetWhere Method (MDataCell[])

public string GetWhere(
params MDataCell[] cells
);

Parameters

MDataCell[]
MDataCell

单元格

See Also

MAction Class | CYQ.Data Namespace | MAction.GetWhere Overload List


MAction.GetWhere Method (Boolean, MDataCell[])

Get where statement

根据元数据列组合where条件。

public string GetWhere(
Boolean isAnd,
params MDataCell[] cells
);

Parameters

Boolean
connect by and/or

true为and连接，反之为or链接

MDataCell[]

See Also

MAction Class | CYQ.Data Namespace | MAction.GetWhere Overload List


Insert Method

CYQ.Data API 帮助文档 For V5

MAction.Insert Method

Insert To DataBase

插入数据

Overload List

Insert To DataBase 插入数据

public bool Insert();

public bool Insert(InsertOp);

public bool Insert(Boolean);

public bool Insert(Boolean,InsertOp);

See Also

MAction Class | CYQ.Data Namespace


MAction.Insert Method ()

Insert To DataBase

插入数据

public bool Insert();

See Also

MAction Class | CYQ.Data Namespace | MAction.Insert Overload List


MAction.Insert Method (InsertOp)

public bool Insert(
InsertOp option
);

Parameters

InsertOp
InsertOp

插入选项

See Also

MAction Class | CYQ.Data Namespace | MAction.Insert Overload List


MAction.Insert Method (Boolean)

public bool Insert(
Boolean autoSetValue
);

Parameters

Boolean
Automatic get values from context

自动取值（从上下文环境中）

See Also

MAction Class | CYQ.Data Namespace | MAction.Insert Overload List


MAction.Insert Method (Boolean, InsertOp)

public bool Insert(
Boolean autoSetValue,
InsertOp option
);

Parameters

Boolean
InsertOp
InsertOp

插入选项

See Also

MAction Class | CYQ.Data Namespace | MAction.Insert Overload List


ResetTable Method

CYQ.Data API 帮助文档 For V5

MAction.ResetTable Method

Toggle Table Action: To switch between other tables, use this method

切换表操作：如需操作其它表，通过此方法切换

Overload List

Toggle Table Action: To switch between other tables, use this method 切换表操作：如需操作其它表，通过此方法切换

public void ResetTable(Object);

public void ResetTable(Object,Boolean);

public void ResetTable(Object,Boolean,String);

See Also

MAction Class | CYQ.Data Namespace


MAction.ResetTable Method (Object)

Toggle Table Action: To switch between other tables, use this method

切换表操作：如需操作其它表，通过此方法切换

public void ResetTable(
Object tableObj
);

Parameters

Object
Parameters: table name, view, custom statement, DataRow

参数：表名、视图、自定义语句、MDataRow

See Also

MAction Class | CYQ.Data Namespace | MAction.ResetTable Overload List


MAction.ResetTable Method (Object, Boolean)

public void ResetTable(
Object tableObj,
Boolean resetState
);

Parameters

Object
Boolean
Reset Row State (defaultValue:true)

是否重置原有的数据状态（默认true)

See Also

MAction Class | CYQ.Data Namespace | MAction.ResetTable Overload List


MAction.ResetTable Method (Object, Boolean, String)

public void ResetTable(
Object tableObj,
Boolean resetState,
String newDbName
);

Parameters

Object
Boolean
String
Other DataBaseName

其它数据库名称

See Also

MAction Class | CYQ.Data Namespace | MAction.ResetTable Overload List


MAction.RollBack Method

RollBack Transation

事务回滚

public bool RollBack();

See Also

MAction Class | CYQ.Data Namespace


Select Method

CYQ.Data API 帮助文档 For V5

MAction.Select Method

select all data

选择所有数据

Overload List

select all data 选择所有数据

public MDataTable Select();

public MDataTable Select(Int32,Int32);

public MDataTable Select(Int32,Int32,Object);

public MDataTable Select(Int32,Int32,Object,out Int32&);

public MDataTable Select(Int32,Object);

public MDataTable Select(Object);

See Also

MAction Class | CYQ.Data Namespace


MAction.Select Method ()

select all data

选择所有数据

public MDataTable Select();

See Also

MAction Class | CYQ.Data Namespace | MAction.Select Overload List


MAction.Select Method (Int32, Int32)

public MDataTable Select(
Int32 pageIndex,
Int32 pageSize
);

Parameters

Int32
pageIndex

第几页

Int32
pageSize

每页数量[为0时默认选择所有]

See Also

MAction Class | CYQ.Data Namespace | MAction.Select Overload List


MAction.Select Method (Int32, Int32, Object)

public MDataTable Select(
Int32 pageIndex,
Int32 pageSize,
Object where
);

See Also

MAction Class | CYQ.Data Namespace | MAction.Select Overload List


MAction.Select Method (Int32, Int32, Object, Int32@)

public MDataTable Select(
Int32 pageIndex,
Int32 pageSize,
Object where,
out Int32& rowCount
);

Parameters

Int32
Int32
Object
Int32&
The total number of records returned

返回的记录总数

See Also

MAction Class | CYQ.Data Namespace | MAction.Select Overload List


MAction.Select Method (Int32, Object)

public MDataTable Select(
Int32 topN,
Object where
);

See Also

MAction Class | CYQ.Data Namespace | MAction.Select Overload List


MAction.Select Method (Object)

public MDataTable Select(
Object where
);

Parameters

Object
Sql statement where the conditions: 88, "id = 88"

sql语句的where条件：88、"id=88"

See Also

MAction Class | CYQ.Data Namespace | MAction.Select Overload List


Set Method

CYQ.Data API 帮助文档 For V5

MAction.Set Method

Set value to this.Data

为Data属性设置值

Overload List

Set value to this.Data 为Data属性设置值

public MAction Set(Object,Object);

public MAction Set(Object,Object,Int32);

See Also

MAction Class | CYQ.Data Namespace


MAction.Set Method (Object, Object)

Set value to this.Data

为Data属性设置值

public MAction Set(
Object key,
Object value
);

Parameters

Object
columnName

列名

Object
value

值

See Also

MAction Class | CYQ.Data Namespace | MAction.Set Overload List


MAction.Set Method (Object, Object, Int32)

public MAction Set(
Object key,
Object value,
Int32 state
);

Parameters

Object
Object
Int32
set value state (0: unchanged; 1: assigned, the same value [insertable]; 2: assigned, different values [updateable])

设置值状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]

See Also

MAction Class | CYQ.Data Namespace | MAction.Set Overload List


MAction.SetAopPara Method

Pass additional parameters for Aop use

传递额外的参数供Aop使用

public MAction SetAopPara(
Object para
);

See Also

MAction Class | CYQ.Data Namespace


MAction.SetAopState Method

Set Aop State

设置Aop状态

public MProc SetAopState(
AopOp op
);

See Also

MAction Class | CYQ.Data Namespace


MAction.SetExpression Method

Sets a custom expression for the Update operation.

为Update操作设置自定义表达式。

public MAction SetExpression(
String updateExpression
);

Parameters

String
as："a=a+1"

如："a=a+1"

See Also

MAction Class | CYQ.Data Namespace


SetPara Method

CYQ.Data API 帮助文档 For V5

MAction.SetPara Method

Aop scenes can only be used by the parameterization of the Senate

Aop场景才可能使用的参数化传参

Overload List

Aop scenes can only be used by the parameterization of the Senate Aop场景才可能使用的参数化传参

public MAction SetPara(List<T>);

Parameterized pass [used when the Where condition is a parameterized (such as: name = @ name) statement] 参数化传参[当Where条件为参数化(如：name=@name)语句时使用]

public MAction SetPara(Object,Object);

public MAction SetPara(Object,Object,DbType);

See Also

MAction Class | CYQ.Data Namespace


MAction.SetPara Method (List`1)

Aop scenes can only be used by the parameterization of the Senate

Aop场景才可能使用的参数化传参

public MAction SetPara(
List<T> customParas
);

Parameters

List<T>
Paras

参数列表

See Also

MAction Class | CYQ.Data Namespace | MAction.SetPara Overload List


MAction.SetPara Method (Object, Object)

Parameterized pass [used when the Where condition is a parameterized (such as: name = @ name) statement]

参数化传参[当Where条件为参数化(如：name=@name)语句时使用]

public MAction SetPara(
Object paraName,
Object value
);

Parameters

Object
paraName

参数名称

Object
value

参数值

See Also

MAction Class | CYQ.Data Namespace | MAction.SetPara Overload List


MAction.SetPara Method (Object, Object, DbType)

public MAction SetPara(
Object paraName,
Object value,
DbType dbType
);

Parameters

Object
Object
DbType
dbType

参数类型

See Also

MAction Class | CYQ.Data Namespace | MAction.SetPara Overload List


MAction.SetSelectColumns Method

Specifies the column to read

指定读取的列

public MAction SetSelectColumns(
params Object[] columnNames
);

Parameters

Object[]
as："columnA","columnB as B"

See Also

MAction Class | CYQ.Data Namespace


MAction.SetTransLevel Method

Set the transaction level

设置事务级别

public MAction SetTransLevel(
IsolationLevel level
);

Parameters

IsolationLevel
IsolationLevel

See Also

MAction Class | CYQ.Data Namespace


Update Method

CYQ.Data API 帮助文档 For V5

MAction.Update Method

Update to database [Will automatically try to fetch from the UI when conditions are not passed]

更新数据[不传where条件时将自动尝试从UI获取]

Overload List

Update to database [Will automatically try to fetch from the UI when conditions are not passed] 更新数据[不传where条件时将自动尝试从UI获取]

public bool Update();

public bool Update(Boolean);

public bool Update(Object);

public bool Update(Object,Boolean);

See Also

MAction Class | CYQ.Data Namespace


MAction.Update Method ()

Update to database [Will automatically try to fetch from the UI when conditions are not passed]

更新数据[不传where条件时将自动尝试从UI获取]

public bool Update();

See Also

MAction Class | CYQ.Data Namespace | MAction.Update Overload List


MAction.Update Method (Boolean)

public bool Update(
Boolean autoSetValue
);

Parameters

Boolean
Automatic get values from context

自动取值（从上下文环境中）

See Also

MAction Class | CYQ.Data Namespace | MAction.Update Overload List


MAction.Update Method (Object)

public bool Update(
Object where
);

Parameters

Object
Sql statement where the conditions: 88, "id = 88"

sql语句的where条件：88、"id=88"

See Also

MAction Class | CYQ.Data Namespace | MAction.Update Overload List


MAction.Update Method (Object, Boolean)

public bool Update(
Object where,
Boolean autoSetValue
);

Parameters

Object
Boolean
Automatic get values from context

自动取值（从上下文环境中）

See Also

MAction Class | CYQ.Data Namespace | MAction.Update Overload List


MAction Type Conversions

The type conversions of the MAction class are listed below. For a complete list of MAction class members, see the MAction Members topic.

Public Static Type Conversions

Implicit OrmBase to MAction Conversion
Implicit SimpleOrmBase to MAction Conversion

See Also

MAction Class | MAction Members | CYQ.Data Namespace


MAction Implicit OrmBase to MAction Conversion

public static implicit operator MAction(
OrmBase orm
);

See Also

MAction Class | CYQ.Data Namespace


MAction Implicit SimpleOrmBase to MAction Conversion

public static implicit operator MAction(
SimpleOrmBase orm
);

See Also

MAction Class | CYQ.Data Namespace


MProc Class

Manipulate：sql / procedure

操作：SQL或存储过程

For a list of all members of this type, see MProc Members.

System.Object
MProc

public class MProc :

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

MProc Members | CYQ.Data Namespace


MProc Members

MProc overview

Public Static Type Conversions

Implicit MAction to MProc Conversion | Change MAction to MProc 将一个MAction 转换成一个MProc。
Implicit OrmBase to MProc Conversion |
Implicit SimpleOrmBase to MProc Conversion |

Public Instance Constructors

MProc Overloaded. Initializes a new instance of the MProc class.

Public Instance Properties

ConnectionString | The database connection string 数据库链接字符串
DalType | The database type 数据库类型
DalVersion | The database version 数据库的版本号
DataBase | The database name 数据库名称
DebugInfo | Get or set debugging information [need to set App Config.Debug.Open DebugInfo to ture] 获取或设置调试信息[需要设置AppConfig.Debug.OpenDebugInfo为ture]
OutPutValue | The OutPut value for the stored procedure: Dictionary for multiple values 存储过程的OutPut值：多个值时为Dictionary
RecordsAffected | The number of rows affected when executing a SQL command (-2 is an exception) 执行SQL命令时受影响的行数（-2则为异常）。
ReturnValue | Get Procedure Return Value 存储过程的返回值
TimeOut | Command Timeout[seconds] 命令超时设置[单位秒]

Public Instance Methods

BeginTransation | Begin Transation 开始事务
Clear | Clear Parameters 清除存储过程参数
Dispose | Dispose 释放资源
EndTransation | Commit Transation 提交事务
ExeMDataTable | Get MDataTable
ExeMDataTableList | Get MDataTables
ExeNonQuery | Returns the number of rows affected [used to insert update or delete], and returns -2 if an exception is executed 返回受影响的行数[用于更新或删除]，执行异常时返回-2
ExeScalar | Returns the value of the first column of the first row 返回首行首列的值
ResetProc | Overloaded. IsClearParameters 是否清除参数
RollBack | RollBack Transation 事务回滚
Set | Overloaded. Set Input Para 设置存储过程Input参数
SetAopPara | Pass additional parameters for Aop use 传递额外的参数供Aop使用
SetAopState | Set Aop State 设置Aop状态
SetCustom | Overloaded. 设置特殊自定义参数
SetTransLevel | Set the transaction level 设置事务级别

See Also

MProc Class | CYQ.Data Namespace


MProc Constructor

Instantiation

实例化

Overload List

Instantiation 实例化

public MProc(Object);

public MProc(Object,String);

See Also

MProc Class | CYQ.Data Namespace


MProc Constructor (Object)

Instantiation

实例化

public MProc(
Object procNameOrSql
);

Parameters

Object
Parameters: sql or procedure

参数：SQL语句或存储过程名称

See Also

MProc Class | CYQ.Data Namespace | MProc Constructor Overload List


MProc Constructor (Object, String)

public MProc(
Object procNameOrSql,
String conn
);

See Also

MProc Class | CYQ.Data Namespace | MProc Constructor Overload List


MProc Properties

The properties of the MProc class are listed below. For a complete list of MProc class members, see the MProc Members topic.

Public Instance Properties

ConnectionString | The database connection string 数据库链接字符串
DalType | The database type 数据库类型
DalVersion | The database version 数据库的版本号
DataBase | The database name 数据库名称
DebugInfo | Get or set debugging information [need to set App Config.Debug.Open DebugInfo to ture] 获取或设置调试信息[需要设置AppConfig.Debug.OpenDebugInfo为ture]
OutPutValue | The OutPut value for the stored procedure: Dictionary for multiple values 存储过程的OutPut值：多个值时为Dictionary
RecordsAffected | The number of rows affected when executing a SQL command (-2 is an exception) 执行SQL命令时受影响的行数（-2则为异常）。
ReturnValue | Get Procedure Return Value 存储过程的返回值
TimeOut | Command Timeout[seconds] 命令超时设置[单位秒]

See Also

MProc Class | CYQ.Data Namespace


ConnectionString Property

CYQ.Data API 帮助文档 For V5

MProc.ConnectionString Property

The database connection string

数据库链接字符串

public ConnectionString {get;}

See Also

MProc Class | CYQ.Data Namespace


DalType Property

CYQ.Data API 帮助文档 For V5

MProc.DalType Property

The database type

数据库类型

public DalType {get;}

See Also

MProc Class | CYQ.Data Namespace


DalVersion Property

CYQ.Data API 帮助文档 For V5

MProc.DalVersion Property

The database version 数据库的版本号

public DalVersion {get;}

See Also

MProc Class | CYQ.Data Namespace


DataBase Property

CYQ.Data API 帮助文档 For V5

MProc.DataBase Property

The database name

数据库名称

public DataBase {get;}

See Also

MProc Class | CYQ.Data Namespace


DebugInfo Property

CYQ.Data API 帮助文档 For V5

MProc.DebugInfo Property

Get or set debugging information [need to set App Config.Debug.Open DebugInfo to ture]

获取或设置调试信息[需要设置AppConfig.Debug.OpenDebugInfo为ture]

public DebugInfo {get;}

See Also

MProc Class | CYQ.Data Namespace


OutPutValue Property

CYQ.Data API 帮助文档 For V5

MProc.OutPutValue Property

The OutPut value for the stored procedure: Dictionary for multiple values

存储过程的OutPut值：多个值时为Dictionary

public OutPutValue {get;}

See Also

MProc Class | CYQ.Data Namespace


RecordsAffected Property

CYQ.Data API 帮助文档 For V5

MProc.RecordsAffected Property

The number of rows affected when executing a SQL command (-2 is an exception)

执行SQL命令时受影响的行数（-2则为异常）。

public RecordsAffected {get;}

See Also

MProc Class | CYQ.Data Namespace


ReturnValue Property

CYQ.Data API 帮助文档 For V5

MProc.ReturnValue Property

Get Procedure Return Value

存储过程的返回值

public ReturnValue {get;}

See Also

MProc Class | CYQ.Data Namespace


TimeOut Property

CYQ.Data API 帮助文档 For V5

MProc.TimeOut Property

Command Timeout[seconds]

命令超时设置[单位秒]

public TimeOut {get; set;}

See Also

MProc Class | CYQ.Data Namespace


MProc Methods

The methods of the MProc class are listed below. For a complete list of MProc class members, see the MProc Members topic.

Public Instance Methods

BeginTransation | Begin Transation 开始事务
Clear | Clear Parameters 清除存储过程参数
Dispose | Dispose 释放资源
EndTransation | Commit Transation 提交事务
ExeMDataTable | Get MDataTable
ExeMDataTableList | Get MDataTables
ExeNonQuery | Returns the number of rows affected [used to insert update or delete], and returns -2 if an exception is executed 返回受影响的行数[用于更新或删除]，执行异常时返回-2
ExeScalar | Returns the value of the first column of the first row 返回首行首列的值
ResetProc | Overloaded. IsClearParameters 是否清除参数
RollBack | RollBack Transation 事务回滚
Set | Overloaded. Set Input Para 设置存储过程Input参数
SetAopPara | Pass additional parameters for Aop use 传递额外的参数供Aop使用
SetAopState | Set Aop State 设置Aop状态
SetCustom | Overloaded. 设置特殊自定义参数
SetTransLevel | Set the transaction level 设置事务级别

See Also

MProc Class | CYQ.Data Namespace


MProc.BeginTransation Method

Begin Transation

开始事务

public void BeginTransation();

See Also

MProc Class | CYQ.Data Namespace


MProc.Clear Method

Clear Parameters

清除存储过程参数

public void Clear();

See Also

MProc Class | CYQ.Data Namespace


MProc.Dispose Method

Dispose

释放资源

public void Dispose();

Implements

IDisposable.

See Also

MProc Class | CYQ.Data Namespace


MProc.EndTransation Method

Commit Transation

提交事务

public bool EndTransation();

See Also

MProc Class | CYQ.Data Namespace


MProc.ExeMDataTable Method

Get MDataTable

public MDataTable ExeMDataTable();

See Also

MProc Class | CYQ.Data Namespace


MProc.ExeMDataTableList Method

Get MDataTables

public List<T> ExeMDataTableList();

See Also

MProc Class | CYQ.Data Namespace


MProc.ExeNonQuery Method

Returns the number of rows affected [used to insert update or delete], and returns -2 if an exception is executed

返回受影响的行数[用于更新或删除]，执行异常时返回-2

public int ExeNonQuery();

See Also

MProc Class | CYQ.Data Namespace


MProc.ExeScalar Method

Returns the value of the first column of the first row

返回首行首列的值

public T <T>ExeScalar();

See Also

MProc Class | CYQ.Data Namespace


ResetProc Method

CYQ.Data API 帮助文档 For V5

MProc.ResetProc Method

Toggle tProc Action: To switch between other sql/procedure, use this method

切换操作：如需操作其它语句或存储过程，通过此方法切换

Overload List

Toggle tProc Action: To switch between other sql/procedure, use this method 切换操作：如需操作其它语句或存储过程，通过此方法切换

public void ResetProc(Object);

IsClearParameters

是否清除参数

public void ResetProc(Object,Boolean);

See Also

MProc Class | CYQ.Data Namespace


MProc.ResetProc Method (Object)

Toggle tProc Action: To switch between other sql/procedure, use this method

切换操作：如需操作其它语句或存储过程，通过此方法切换

public void ResetProc(
Object procNameOrSql
);

Parameters

Object
Parameters: sql or procedure

参数：存储过程名或Sql语句

See Also

MProc Class | CYQ.Data Namespace | MProc.ResetProc Overload List


MProc.ResetProc Method (Object, Boolean)

IsClearParameters

是否清除参数

public void ResetProc(
Object procNameOrSql,
Boolean isClearPara
);

See Also

MProc Class | CYQ.Data Namespace | MProc.ResetProc Overload List


MProc.RollBack Method

RollBack Transation

事务回滚

public bool RollBack();

See Also

MProc Class | CYQ.Data Namespace


Set Method

CYQ.Data API 帮助文档 For V5

MProc.Set Method

Set Input Para

设置存储过程Input参数

Overload List

Set Input Para 设置存储过程Input参数

public MProc Set(Object,Object);

public MProc Set(Object,Object,DbType);

See Also

MProc Class | CYQ.Data Namespace


MProc.Set Method (Object, Object)

Set Input Para

设置存储过程Input参数

public MProc Set(
Object paraName,
Object value
);

See Also

MProc Class | CYQ.Data Namespace | MProc.Set Overload List


MProc.Set Method (Object, Object, DbType)

public MProc Set(
Object paraName,
Object value,
DbType dbType
);

See Also

MProc Class | CYQ.Data Namespace | MProc.Set Overload List


MProc.SetAopPara Method

Pass additional parameters for Aop use

传递额外的参数供Aop使用

public MProc SetAopPara(
Object para
);

See Also

MProc Class | CYQ.Data Namespace


MProc.SetAopState Method

Set Aop State

设置Aop状态

public MProc SetAopState(
AopOp op
);

See Also

MProc Class | CYQ.Data Namespace


SetCustom Method

CYQ.Data API 帮助文档 For V5

MProc.SetCustom Method

设置特殊自定义参数

Overload List

设置特殊自定义参数

public MProc SetCustom(Object,ParaType);

Set the stored procedure OutPut, the return value and other special types of parameters 设置存储过程OutPut、返回值等特殊类型参数

public MProc SetCustom(Object,ParaType,Object);

public MProc SetCustom(Object,ParaType,Object,String);

See Also

MProc Class | CYQ.Data Namespace


MProc.SetCustom Method (Object, ParaType)

设置特殊自定义参数

public MProc SetCustom(
Object paraName,
ParaType paraType
);

See Also

MProc Class | CYQ.Data Namespace | MProc.SetCustom Overload List


MProc.SetCustom Method (Object, ParaType, Object)

Set the stored procedure OutPut, the return value and other special types of parameters

设置存储过程OutPut、返回值等特殊类型参数

public MProc SetCustom(
Object paraName,
ParaType paraType,
Object value
);

See Also

MProc Class | CYQ.Data Namespace | MProc.SetCustom Overload List


MProc.SetCustom Method (Object, ParaType, Object, String)

public MProc SetCustom(
Object paraName,
ParaType paraType,
Object value,
String typeName
);

Parameters

Object
ParaType
Object
String
MSSQL The name of the user-defined table type

MSSQL的用户定义表类型的名称

See Also

MProc Class | CYQ.Data Namespace | MProc.SetCustom Overload List


MProc.SetTransLevel Method

Set the transaction level

设置事务级别

public MProc SetTransLevel(
IsolationLevel level
);

Parameters

IsolationLevel
IsolationLevel

See Also

MProc Class | CYQ.Data Namespace


MProc Type Conversions

The type conversions of the MProc class are listed below. For a complete list of MProc class members, see the MProc Members topic.

Public Static Type Conversions

Implicit MAction to MProc Conversion | Change MAction to MProc 将一个MAction 转换成一个MProc。
Implicit OrmBase to MProc Conversion |
Implicit SimpleOrmBase to MProc Conversion |

See Also

MProc Class | MProc Members | CYQ.Data Namespace


MProc Implicit MAction to MProc Conversion

Change MAction to MProc

将一个MAction 转换成一个MProc。

public static implicit operator MProc(
MAction action
);

See Also

MProc Class | CYQ.Data Namespace


MProc Implicit OrmBase to MProc Conversion

public static implicit operator MProc(
OrmBase orm
);

See Also

MProc Class | CYQ.Data Namespace


MProc Implicit SimpleOrmBase to MProc Conversion

public static implicit operator MProc(
SimpleOrmBase orm
);

See Also

MProc Class | CYQ.Data Namespace


ParaType Enumeration

特殊参数类型[MProc SetCustom方法所使用的参数]

public enum ParaType

Members

Member Name | Description
Cursor | Oracle 游标类型
OutPut | 输出类型
InputOutput | 输入输出类型
ReturnValue | 返回值类型
CLOB | Oracle CLOB类型
NCLOB | Oracle NCLOB类型
Structured | MSSQL 用户定义表类型

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data Namespace


SysLogs Class

A class for you to Write log to database

日志记录到数据库（需要配置LogConn链接后方有效）

For a list of all members of this type, see SysLogs Members.

System.Object
SimpleOrmBase
SysLogs

public class SysLogs : SimpleOrmBase

Requirements

Namespace: CYQ.Data

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

SysLogs Members | CYQ.Data Namespace


SysLogs Members

SysLogs overview

Public Instance Constructors

SysLogs Constructor

Public Instance Properties

CreateTime | 创建时间
Host | 请求的主机地址
ID | 标识主键
LogType | 日志类型
Message | 日志内容
PageUrl | 请求的地址
RefererUrl | 请求的地址

See Also

SysLogs Class | CYQ.Data Namespace


SysLogs Constructor

public SysLogs();

See Also

SysLogs Class | CYQ.Data Namespace


SysLogs Properties

The properties of the SysLogs class are listed below. For a complete list of SysLogs class members, see the SysLogs Members topic.

Public Instance Properties

CreateTime | 创建时间
Host | 请求的主机地址
ID | 标识主键
LogType | 日志类型
Message | 日志内容
PageUrl | 请求的地址
RefererUrl | 请求的地址

See Also

SysLogs Class | CYQ.Data Namespace


CreateTime Property

CYQ.Data API 帮助文档 For V5

SysLogs.CreateTime Property

创建时间

public CreateTime {get; set;}

See Also

SysLogs Class | CYQ.Data Namespace


Host Property

CYQ.Data API 帮助文档 For V5

SysLogs.Host Property

请求的主机地址

public Host {get; set;}

See Also

SysLogs Class | CYQ.Data Namespace


ID Property

CYQ.Data API 帮助文档 For V5

SysLogs.ID Property

标识主键

public ID {get; set;}

See Also

SysLogs Class | CYQ.Data Namespace


LogType Property

CYQ.Data API 帮助文档 For V5

SysLogs.LogType Property

日志类型

public LogType {get; set;}

See Also

SysLogs Class | CYQ.Data Namespace


Message Property

CYQ.Data API 帮助文档 For V5

SysLogs.Message Property

日志内容

public Message {get; set;}

See Also

SysLogs Class | CYQ.Data Namespace


PageUrl Property

CYQ.Data API 帮助文档 For V5

SysLogs.PageUrl Property

请求的地址

public PageUrl {get; set;}

See Also

SysLogs Class | CYQ.Data Namespace


RefererUrl Property

CYQ.Data API 帮助文档 For V5

SysLogs.RefererUrl Property

请求的地址

public RefererUrl {get; set;}

See Also

SysLogs Class | CYQ.Data Namespace


CYQ.Data.Aop

CYQ.Data API 帮助文档 For V5

CYQ.Data.Aop Namespace

Namespace hierarchy

Classes

Class | Description
AopCustomDbPara | 设置自定义参数[使用MAction时，对Where条件进行的参数化传参使用]
AopInfo | Aop参数信息

Interfaces

Interface | Description
IAop | Aop接口，需要实现时继承

Enumerations

Enumeration | Description
AopEnum | 框架内部数据库操作方法枚举
AopOp | Aop开关选项
AopResult | Aop函数的处理结果


AopCustomDbPara Class

设置自定义参数[使用MAction时，对Where条件进行的参数化传参使用]

For a list of all members of this type, see AopCustomDbPara Members.

System.Object
AopCustomDbPara

public class AopCustomDbPara

Requirements

Namespace: CYQ.Data.Aop

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

AopCustomDbPara Members | CYQ.Data.Aop Namespace


AopCustomDbPara Members

AopCustomDbPara overview

Public Instance Constructors

AopCustomDbPara Constructor

Public Instance Properties

ParaDbType | 参数类型
ParaName | 参数名称
Value | 参数值

See Also

AopCustomDbPara Class | CYQ.Data.Aop Namespace


AopCustomDbPara Constructor

public AopCustomDbPara();

See Also

AopCustomDbPara Class | CYQ.Data.Aop Namespace


AopCustomDbPara Properties

The properties of the AopCustomDbPara class are listed below. For a complete list of AopCustomDbPara class members, see the AopCustomDbPara Members topic.

Public Instance Properties

ParaDbType | 参数类型
ParaName | 参数名称
Value | 参数值

See Also

AopCustomDbPara Class | CYQ.Data.Aop Namespace


ParaDbType Property

CYQ.Data API 帮助文档 For V5

AopCustomDbPara.ParaDbType Property

参数类型

public ParaDbType {get; set;}

See Also

AopCustomDbPara Class | CYQ.Data.Aop Namespace


ParaName Property

CYQ.Data API 帮助文档 For V5

AopCustomDbPara.ParaName Property

参数名称

public ParaName {get; set;}

See Also

AopCustomDbPara Class | CYQ.Data.Aop Namespace


Value Property

CYQ.Data API 帮助文档 For V5

AopCustomDbPara.Value Property

参数值

public Value {get; set;}

See Also

AopCustomDbPara Class | CYQ.Data.Aop Namespace


AopEnum Enumeration

框架内部数据库操作方法枚举

public enum AopEnum

Members

Member Name | Description
Select |
Insert |
Update |
Delete |
Fill |
GetCount |
Exists |
ExeMDataTableList |
ExeMDataTable |
ExeNonQuery |
ExeScalar |

Requirements

Namespace: CYQ.Data.Aop

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Aop Namespace


AopInfo Class

Aop参数信息

For a list of all members of this type, see AopInfo Members.

System.Object
AopInfo

public class AopInfo

Requirements

Namespace: CYQ.Data.Aop

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

AopInfo Members | CYQ.Data.Aop Namespace


AopInfo Members

AopInfo overview

Public Instance Constructors

AopInfo Constructor

Public Instance Properties

AopPara | AOP的自定义参数
AutoSetValue | 自动从Form表单提取值[插入或更新时使用]
CustomDbPara | 用户调用SetPara新增加的自定义参数
DalType | 数据类型(只读)
DataBase | 数据库名称(只读)
DBParameters | 命令参数
ExeResult | 执行后返回的结果
InsertOp | 数据插入选项
IsProc | 是否存储过程
IsSuccess | Begin方法是否调用成功[在End中使用]
IsTransaction | 是否事务中
MAction | 当前上下文的处理程序。
MProc | 当前上下文的处理程序。
PageIndex | 分页起始页
PageSize | 分页每页条数
ProcName | 存储过程名或SQL语句
Row | 数据行
RowCount | 查询时返回的记录总数或ExeNonQuery的返回值
SelectColumns | 指定的查询列
Table | 数据表
TableList | 数据列表
TableName | 表名
UpdateExpression | 更新操作的附加表达式。
Where | 查询条件

See Also

AopInfo Class | CYQ.Data.Aop Namespace


AopInfo Constructor

public AopInfo();

See Also

AopInfo Class | CYQ.Data.Aop Namespace


AopInfo Properties

The properties of the AopInfo class are listed below. For a complete list of AopInfo class members, see the AopInfo Members topic.

Public Instance Properties

AopPara | AOP的自定义参数
AutoSetValue | 自动从Form表单提取值[插入或更新时使用]
CustomDbPara | 用户调用SetPara新增加的自定义参数
DalType | 数据类型(只读)
DataBase | 数据库名称(只读)
DBParameters | 命令参数
ExeResult | 执行后返回的结果
InsertOp | 数据插入选项
IsProc | 是否存储过程
IsSuccess | Begin方法是否调用成功[在End中使用]
IsTransaction | 是否事务中
MAction | 当前上下文的处理程序。
MProc | 当前上下文的处理程序。
PageIndex | 分页起始页
PageSize | 分页每页条数
ProcName | 存储过程名或SQL语句
Row | 数据行
RowCount | 查询时返回的记录总数或ExeNonQuery的返回值
SelectColumns | 指定的查询列
Table | 数据表
TableList | 数据列表
TableName | 表名
UpdateExpression | 更新操作的附加表达式。
Where | 查询条件

See Also

AopInfo Class | CYQ.Data.Aop Namespace


AopPara Property

CYQ.Data API 帮助文档 For V5

AopInfo.AopPara Property

AOP的自定义参数

public AopPara {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


AutoSetValue Property

CYQ.Data API 帮助文档 For V5

AopInfo.AutoSetValue Property

自动从Form表单提取值[插入或更新时使用]

public AutoSetValue {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


CustomDbPara Property

CYQ.Data API 帮助文档 For V5

AopInfo.CustomDbPara Property

用户调用SetPara新增加的自定义参数

public CustomDbPara {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


DalType Property

CYQ.Data API 帮助文档 For V5

AopInfo.DalType Property

数据类型(只读)

public DalType {get;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


DataBase Property

CYQ.Data API 帮助文档 For V5

AopInfo.DataBase Property

数据库名称(只读)

public DataBase {get;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


DBParameters Property

CYQ.Data API 帮助文档 For V5

AopInfo.DBParameters Property

命令参数

public DBParameters {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


ExeResult Property

CYQ.Data API 帮助文档 For V5

AopInfo.ExeResult Property

执行后返回的结果

public ExeResult {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


InsertOp Property

CYQ.Data API 帮助文档 For V5

AopInfo.InsertOp Property

数据插入选项

public InsertOp {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


IsProc Property

CYQ.Data API 帮助文档 For V5

AopInfo.IsProc Property

是否存储过程

public IsProc {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


IsSuccess Property

CYQ.Data API 帮助文档 For V5

AopInfo.IsSuccess Property

Begin方法是否调用成功[在End中使用]

public IsSuccess {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


IsTransaction Property

CYQ.Data API 帮助文档 For V5

AopInfo.IsTransaction Property

是否事务中

public IsTransaction {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


MAction Property

CYQ.Data API 帮助文档 For V5

AopInfo.MAction Property

当前上下文的处理程序。

public MAction {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


MProc Property

CYQ.Data API 帮助文档 For V5

AopInfo.MProc Property

当前上下文的处理程序。

public MProc {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


PageIndex Property

CYQ.Data API 帮助文档 For V5

AopInfo.PageIndex Property

分页起始页

public PageIndex {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


PageSize Property

CYQ.Data API 帮助文档 For V5

AopInfo.PageSize Property

分页每页条数

public PageSize {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


ProcName Property

CYQ.Data API 帮助文档 For V5

AopInfo.ProcName Property

存储过程名或SQL语句

public ProcName {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


Row Property

CYQ.Data API 帮助文档 For V5

AopInfo.Row Property

数据行

public Row {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


RowCount Property

CYQ.Data API 帮助文档 For V5

AopInfo.RowCount Property

查询时返回的记录总数或ExeNonQuery的返回值

public RowCount {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


SelectColumns Property

CYQ.Data API 帮助文档 For V5

AopInfo.SelectColumns Property

指定的查询列

public SelectColumns {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


Table Property

CYQ.Data API 帮助文档 For V5

AopInfo.Table Property

数据表

public Table {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


TableList Property

CYQ.Data API 帮助文档 For V5

AopInfo.TableList Property

数据列表

public TableList {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


TableName Property

CYQ.Data API 帮助文档 For V5

AopInfo.TableName Property

表名

public TableName {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


UpdateExpression Property

CYQ.Data API 帮助文档 For V5

AopInfo.UpdateExpression Property

更新操作的附加表达式。

public UpdateExpression {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


Where Property

CYQ.Data API 帮助文档 For V5

AopInfo.Where Property

查询条件

public Where {get; set;}

See Also

AopInfo Class | CYQ.Data.Aop Namespace


AopOp Enumeration

Aop开关选项

public enum AopOp

Members

Member Name | Description
OpenAll | 正常打开
OnlyInner | 仅打开内部Aop（即自动缓存，关闭外部Aop）
OnlyOuter | 仅打开外部Aop（关闭自动缓存）
CloseAll | 内外都关（自动缓存和外部Aop）

Requirements

Namespace: CYQ.Data.Aop

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Aop Namespace


AopResult Enumeration

Aop函数的处理结果

public enum AopResult

Members

Member Name | Description
Default | 本结果将执行原有事件，但跳过Aop.End事件
Continue | 本结果将继续执行原有事件和Aop.End事件
Break | 本结果将跳过原有事件,但会执行Aop End事件
Return | 本结果将直接跳出原有函数的执行

Requirements

Namespace: CYQ.Data.Aop

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Aop Namespace


IAop Interface

Aop接口，需要实现时继承

For a list of all members of this type, see IAop Members.

public interface IAop

Requirements

Namespace: CYQ.Data.Aop

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

IAop Members | CYQ.Data.Aop Namespace


IAop Members

IAop overview

Public Instance Methods

Begin | 方法调用之前被调用
Clone | 克隆返回一个新的对象
End | 方法调用之后被调用
OnError | 数据库操作产生异常时,引发此方法
OnLoad | Aop 首次加载时被触发的事件

See Also

IAop Interface | CYQ.Data.Aop Namespace


IAop Methods

The methods of the IAop interface are listed below. For a complete list of IAop interface members, see the IAop Members topic.

Public Instance Methods

Begin | 方法调用之前被调用
Clone | 克隆返回一个新的对象
End | 方法调用之后被调用
OnError | 数据库操作产生异常时,引发此方法
OnLoad | Aop 首次加载时被触发的事件

See Also

IAop Interface | CYQ.Data.Aop Namespace


IAop.Begin Method

方法调用之前被调用

AopResult Begin(
AopEnum action,
AopInfo aopInfo
);

Parameters

AopEnum
方法名称
AopInfo
附带分支参数

See Also

IAop Interface | CYQ.Data.Aop Namespace


IAop.Clone Method

克隆返回一个新的对象

IAop Clone();

Return Value

See Also

IAop Interface | CYQ.Data.Aop Namespace


IAop.End Method

方法调用之后被调用

void End(
AopEnum action,
AopInfo aopInfo
);

Parameters

AopEnum
方法名称
AopInfo
附带分支参数

See Also

IAop Interface | CYQ.Data.Aop Namespace


IAop.OnError Method

数据库操作产生异常时,引发此方法

void OnError(
String msg
);

Parameters

String

See Also

IAop Interface | CYQ.Data.Aop Namespace


IAop.OnLoad Method

Aop 首次加载时被触发的事件

void OnLoad();

See Also

IAop Interface | CYQ.Data.Aop Namespace


CYQ.Data.Cache

CYQ.Data API 帮助文档 For V5

CYQ.Data.Cache Namespace

Namespace hierarchy

Classes

Class | Description
CacheManage | 全局缓存类

Enumerations

Enumeration | Description
CacheKeyType | Cache的Key类型
CacheType | 支持的Cache类型


CacheKeyType Enumeration

Cache的Key类型

public enum CacheKeyType

Members

Member Name | Description
Schema | 表架构的Key
AutoCache | 智能缓存Key

Requirements

Namespace: CYQ.Data.Cache

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Cache Namespace


CacheManage Class

全局缓存类

For a list of all members of this type, see CacheManage Members.

System.Object
CacheManage

public class CacheManage

Example

使用示例：
实例化： CacheManage cache=CacheManage.Instance;
添加：   Cache.Set("路过秋天",new MDataTable);
判断：   if(cache.Contains("路过秋天"))
         {
获取：       MDataTable table=cache.Get("路过秋天") as MDataTable;
         }

Requirements

Namespace: CYQ.Data.Cache

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CacheManage Members | CYQ.Data.Cache Namespace


CacheManage Members

CacheManage overview

Public Static Properties

Instance | 返回唯一实例(根据配置(AppConfig.Cache.XXXCacheServers)决定启用顺序：Redis、MemCache、本地缓存）
LocalInstance | 单机本地缓存
MemCacheInstance | MemCache缓存（需要配置AppConfig.Cache.MemCacheServers）
RedisInstance | Redis缓存（需要配置AppConfig.Cache.RedisServers）

Public Static Methods

GetKey | Overloaded. 获取系统内部缓存Key
PreLoadDBSchemaToCache | Overloaded. 通过该方法可以预先加载整个数据库的表结构缓存

Public Instance Properties

CacheInfo | 缓存的信息
CacheType | 缓存的实例类型
Count | 获和缓存总数
WorkInfo | 缓存的工作信息

Public Instance Methods

Clear | 清除所有缓存
Contains |
Get | Overloaded. 获得一个Cache对象
Remove | 删除一个Cache对象
Set | Overloaded. 设置一个Cache对象

See Also

CacheManage Class | CYQ.Data.Cache Namespace


CacheManage Properties

The properties of the CacheManage class are listed below. For a complete list of CacheManage class members, see the CacheManage Members topic.

Public Static Properties

Instance | 返回唯一实例(根据配置(AppConfig.Cache.XXXCacheServers)决定启用顺序：Redis、MemCache、本地缓存）
LocalInstance | 单机本地缓存
MemCacheInstance | MemCache缓存（需要配置AppConfig.Cache.MemCacheServers）
RedisInstance | Redis缓存（需要配置AppConfig.Cache.RedisServers）

Public Instance Properties

CacheInfo | 缓存的信息
CacheType | 缓存的实例类型
Count | 获和缓存总数
WorkInfo | 缓存的工作信息

See Also

CacheManage Class | CYQ.Data.Cache Namespace


CacheInfo Property

CYQ.Data API 帮助文档 For V5

CacheManage.CacheInfo Property

缓存的信息

public abstract CacheInfo {get;}

See Also

CacheManage Class | CYQ.Data.Cache Namespace


CacheType Property

CYQ.Data API 帮助文档 For V5

CacheManage.CacheType Property

缓存的实例类型

public abstract CacheType {get;}

See Also

CacheManage Class | CYQ.Data.Cache Namespace


Count Property

CYQ.Data API 帮助文档 For V5

CacheManage.Count Property

获和缓存总数

public abstract Count {get;}

See Also

CacheManage Class | CYQ.Data.Cache Namespace


Instance Property

CYQ.Data API 帮助文档 For V5

CacheManage.Instance Property

返回唯一实例(根据配置(AppConfig.Cache.XXXCacheServers)决定启用顺序：Redis、MemCache、本地缓存）

public static Instance {get;}

See Also

CacheManage Class | CYQ.Data.Cache Namespace


LocalInstance Property

CYQ.Data API 帮助文档 For V5

CacheManage.LocalInstance Property

单机本地缓存

public static LocalInstance {get;}

See Also

CacheManage Class | CYQ.Data.Cache Namespace


MemCacheInstance Property

CYQ.Data API 帮助文档 For V5

CacheManage.MemCacheInstance Property

MemCache缓存（需要配置AppConfig.Cache.MemCacheServers）

public static MemCacheInstance {get;}

See Also

CacheManage Class | CYQ.Data.Cache Namespace


RedisInstance Property

CYQ.Data API 帮助文档 For V5

CacheManage.RedisInstance Property

Redis缓存（需要配置AppConfig.Cache.RedisServers）

public static RedisInstance {get;}

See Also

CacheManage Class | CYQ.Data.Cache Namespace


WorkInfo Property

CYQ.Data API 帮助文档 For V5

CacheManage.WorkInfo Property

缓存的工作信息

public abstract WorkInfo {get;}

See Also

CacheManage Class | CYQ.Data.Cache Namespace


CacheManage Methods

The methods of the CacheManage class are listed below. For a complete list of CacheManage class members, see the CacheManage Members topic.

Public Static Methods

GetKey | Overloaded. 获取系统内部缓存Key
PreLoadDBSchemaToCache | Overloaded. 通过该方法可以预先加载整个数据库的表结构缓存

Public Instance Methods

Clear | 清除所有缓存
Contains |
Get | Overloaded. 获得一个Cache对象
Remove | 删除一个Cache对象
Set | Overloaded. 设置一个Cache对象

See Also

CacheManage Class | CYQ.Data.Cache Namespace


CacheManage.Clear Method

清除所有缓存

public abstract void Clear();

See Also

CacheManage Class | CYQ.Data.Cache Namespace


CacheManage.Contains Method

public abstract bool Contains(
String key
);

See Also

CacheManage Class | CYQ.Data.Cache Namespace


Get Method

CYQ.Data API 帮助文档 For V5

CacheManage.Get Method

获得一个Cache对象

Overload List

获得一个Cache对象

public abstract object Get(String);

获得一个Cache对象

public T Get<T>(String);

See Also

CacheManage Class | CYQ.Data.Cache Namespace


CacheManage.Get Method (String)

获得一个Cache对象

public abstract object Get(
String key
);

See Also

CacheManage Class | CYQ.Data.Cache Namespace | CacheManage.Get Overload List


CacheManage.Get Method (String)

获得一个Cache对象

public T <T>Get(
String key
);

See Also

CacheManage Class | CYQ.Data.Cache Namespace | CacheManage.Get Overload List


GetKey Method

CYQ.Data API 帮助文档 For V5

CacheManage.GetKey Method

获取系统内部缓存Key

Overload List

获取系统内部缓存Key

public static string GetKey(CacheKeyType,String);

获取系统内部缓存Key

public static string GetKey(CacheKeyType,String,String,DalType);

See Also

CacheManage Class | CYQ.Data.Cache Namespace


CacheManage.GetKey Method (CacheKeyType, String)

获取系统内部缓存Key

public static string GetKey(
CacheKeyType ckt,
String tableName
);

See Also

CacheManage Class | CYQ.Data.Cache Namespace | CacheManage.GetKey Overload List


CacheManage.GetKey Method (CacheKeyType, String, String, DalType)

获取系统内部缓存Key

public static string GetKey(
CacheKeyType ckt,
String tableName,
String dbName,
DalType dalType
);

See Also

CacheManage Class | CYQ.Data.Cache Namespace | CacheManage.GetKey Overload List


PreLoadDBSchemaToCache Method

CYQ.Data API 帮助文档 For V5

CacheManage.PreLoadDBSchemaToCache Method

通过该方法可以预先加载整个数据库的表结构缓存

Overload List

通过该方法可以预先加载整个数据库的表结构缓存

public static void PreLoadDBSchemaToCache();

通过该方法可以预先加载整个数据库的表结构缓存(异常会抛，外层Try Catch)

public static void PreLoadDBSchemaToCache(String,Boolean);

See Also

CacheManage Class | CYQ.Data.Cache Namespace


CacheManage.PreLoadDBSchemaToCache Method ()

通过该方法可以预先加载整个数据库的表结构缓存

public static void PreLoadDBSchemaToCache();

See Also

CacheManage Class | CYQ.Data.Cache Namespace | CacheManage.PreLoadDBSchemaToCache Overload List


CacheManage.PreLoadDBSchemaToCache Method (String, Boolean)

通过该方法可以预先加载整个数据库的表结构缓存(异常会抛，外层Try Catch)

public static void PreLoadDBSchemaToCache(
String conn,
Boolean isUseThread
);

Parameters

String
指定数据链接
Boolean
是否开启线程

See Also

CacheManage Class | CYQ.Data.Cache Namespace | CacheManage.PreLoadDBSchemaToCache Overload List


CacheManage.Remove Method

删除一个Cache对象

public abstract bool Remove(
String key
);

See Also

CacheManage Class | CYQ.Data.Cache Namespace


Set Method

CYQ.Data API 帮助文档 For V5

CacheManage.Set Method

设置一个Cache对象

Overload List

设置一个Cache对象

public abstract bool Set(String,Object);

public abstract bool Set(String,Object,Double);

public abstract bool Set(String,Object,Double,String);

See Also

CacheManage Class | CYQ.Data.Cache Namespace


CacheManage.Set Method (String, Object)

设置一个Cache对象

public abstract bool Set(
String key,
Object value
);

See Also

CacheManage Class | CYQ.Data.Cache Namespace | CacheManage.Set Overload List


CacheManage.Set Method (String, Object, Double)

public abstract bool Set(
String key,
Object value,
Double cacheMinutes
);

See Also

CacheManage Class | CYQ.Data.Cache Namespace | CacheManage.Set Overload List


CacheManage.Set Method (String, Object, Double, String)

public abstract bool Set(
String key,
Object value,
Double cacheMinutes,
String fileName
);

See Also

CacheManage Class | CYQ.Data.Cache Namespace | CacheManage.Set Overload List


CacheType Enumeration

支持的Cache类型

public enum CacheType

Members

Member Name | Description
LocalCache | 本地缓存
MemCache | MemCached分布式缓存
Redis | Redis分布式缓存

Requirements

Namespace: CYQ.Data.Cache

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Cache Namespace


CYQ.Data.Extension

CYQ.Data API 帮助文档 For V5

CYQ.Data.Extension Namespace

Namespace hierarchy

Interfaces

Interface | Description
IField | 实现此接口，来扩展自定义IField语法


IField Interface

实现此接口，来扩展自定义IField语法

For a list of all members of this type, see IField Members.

public interface IField

Requirements

Namespace: CYQ.Data.Extension

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

IField Members | CYQ.Data.Extension Namespace


IField Members

IField overview

Public Instance Properties

ColID | 列序号[列的顺序]
Name | 列名或表名
Sql | 内部的SQL语句

See Also

IField Interface | CYQ.Data.Extension Namespace


IField Properties

The properties of the IField interface are listed below. For a complete list of IField interface members, see the IField Members topic.

Public Instance Properties

ColID | 列序号[列的顺序]
Name | 列名或表名
Sql | 内部的SQL语句

See Also

IField Interface | CYQ.Data.Extension Namespace


ColID Property

CYQ.Data API 帮助文档 For V5

IField.ColID Property

列序号[列的顺序]

ColID {get;}

See Also

IField Interface | CYQ.Data.Extension Namespace


Name Property

CYQ.Data API 帮助文档 For V5

IField.Name Property

列名或表名

Name {get;}

See Also

IField Interface | CYQ.Data.Extension Namespace


Sql Property

CYQ.Data API 帮助文档 For V5

IField.Sql Property

内部的SQL语句

Sql {get; set;}

See Also

IField Interface | CYQ.Data.Extension Namespace


CYQ.Data.Orm

CYQ.Data API 帮助文档 For V5

CYQ.Data.Orm Namespace

Namespace hierarchy

Classes

Class | Description
DBFast | 快速操作操作类。
DefaultValueAttribute | 默认值
DescriptionAttribute | 表名或字段描述
KeyAttribute | 主键自增是否允许Null
LengthAttribute | 列长度
OrmBase | ORM扩展基类
SimpleOrmBase | 简单ORM基类（纯数据交互功能）

Enumerations

Enumeration | Description
FieldSource | ORM CodeFirst 字段来源


DBFast Class

快速操作操作类。

For a list of all members of this type, see DBFast Members.

System.Object
DBFast

public static class DBFast

Requirements

Namespace: CYQ.Data.Orm

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

DBFast Members | CYQ.Data.Orm Namespace


DBFast Members

DBFast overview

Public Static Methods

Delete | 删除记录
Exists | 是否存在指定的条件
Find | 查找单条记录
GetCount |
Insert | Overloaded.
Select | Overloaded.
Update | Overloaded.

See Also

DBFast Class | CYQ.Data.Orm Namespace


DBFast Methods

The methods of the DBFast class are listed below. For a complete list of DBFast class members, see the DBFast Members topic.

Public Static Methods

Delete | 删除记录
Exists | 是否存在指定的条件
Find | 查找单条记录
GetCount |
Insert | Overloaded.
Select | Overloaded.
Update | Overloaded.

See Also

DBFast Class | CYQ.Data.Orm Namespace


DBFast.Delete Method

删除记录

public static bool <T>Delete(
Object where
);

Parameters

Object
条件

Return Value

See Also

DBFast Class | CYQ.Data.Orm Namespace


DBFast.Exists Method

是否存在指定的条件

public static bool <T>Exists(
Object where
);

See Also

DBFast Class | CYQ.Data.Orm Namespace


DBFast.Find Method

查找单条记录

public static T <T>Find(
Object where,
params String[] columns
);

Parameters

Object
条件
String[]
指定查询的列（可选）

Return Value

See Also

DBFast Class | CYQ.Data.Orm Namespace


DBFast.GetCount Method

public static int <T>GetCount(
Object where
);

See Also

DBFast Class | CYQ.Data.Orm Namespace


Insert Method

CYQ.Data API 帮助文档 For V5

DBFast.Insert Method

Overload List

public static bool Insert<T>(DBFast.T);

public static bool Insert<T>(DBFast.T,InsertOp);

添加一条记录

public static bool Insert<T>(DBFast.T,InsertOp,Boolean);

See Also

DBFast Class | CYQ.Data.Orm Namespace


DBFast.Insert Method (``0)

public static bool <T>Insert(
DBFast.T t
);

See Also

DBFast Class | CYQ.Data.Orm Namespace | DBFast.Insert Overload List


DBFast.Insert Method (``0, InsertOp)

public static bool <T>Insert(
DBFast.T t,
InsertOp op
);

See Also

DBFast Class | CYQ.Data.Orm Namespace | DBFast.Insert Overload List


DBFast.Insert Method (``0, InsertOp, Boolean)

添加一条记录

public static bool <T>Insert(
DBFast.T t,
InsertOp op,
Boolean insertID
);

Parameters

DBFast.T
实体对象
InsertOp
Boolean

Return Value

See Also

DBFast Class | CYQ.Data.Orm Namespace | DBFast.Insert Overload List


Select Method

CYQ.Data API 帮助文档 For V5

DBFast.Select Method

Overload List

public static List<T> Select<T>();

查找多条记录

public static List<T> Select<T>(Int32,Int32,Object,out Int32&,params String[]);

public static List<T> Select<T>(Int32,Int32,String,params String[]);

public static List<T> Select<T>(Int32,Int32,params String[]);

列表查询

public static List<T> Select<T>(Int32,String,params String[]);

列表查询

public static List<T> Select<T>(String,params String[]);

See Also

DBFast Class | CYQ.Data.Orm Namespace


DBFast.Select Method ()

public static List<T> <T>Select();

See Also

DBFast Class | CYQ.Data.Orm Namespace | DBFast.Select Overload List


DBFast.Select Method (Int32, Int32, Object, Int32@, String[])

查找多条记录

public static List<T> <T>Select(
Int32 pageIndex,
Int32 pageSize,
Object where,
out Int32& count,
params String[] columns
);

Parameters

Int32
第N页
Int32
每页N条
Object
条件
Int32&
返回记录总数
String[]
指定查询的列（可选）

Return Value

See Also

DBFast Class | CYQ.Data.Orm Namespace | DBFast.Select Overload List


DBFast.Select Method (Int32, Int32, String, String[])

public static List<T> <T>Select(
Int32 pageIndex,
Int32 pageSize,
String where,
params String[] columns
);

See Also

DBFast Class | CYQ.Data.Orm Namespace | DBFast.Select Overload List


DBFast.Select Method (Int32, Int32, String[])

public static List<T> <T>Select(
Int32 pageIndex,
Int32 pageSize,
params String[] columns
);

See Also

DBFast Class | CYQ.Data.Orm Namespace | DBFast.Select Overload List


DBFast.Select Method (Int32, String, String[])

列表查询

public static List<T> <T>Select(
Int32 topN,
String where,
params String[] columns
);

Parameters

Int32
查询几条
String
查询条件[可附带 order by 语句]
String[]

Return Value

See Also

DBFast Class | CYQ.Data.Orm Namespace | DBFast.Select Overload List


DBFast.Select Method (String, String[])

列表查询

public static List<T> <T>Select(
String where,
params String[] columns
);

Parameters

String
查询条件[可附带 order by 语句]
String[]

Return Value

See Also

DBFast Class | CYQ.Data.Orm Namespace | DBFast.Select Overload List


Update Method

CYQ.Data API 帮助文档 For V5

DBFast.Update Method

Overload List

public static bool Update<T>(DBFast.T);

更新记录

public static bool Update<T>(DBFast.T,Object);

See Also

DBFast Class | CYQ.Data.Orm Namespace


DBFast.Update Method (``0)

public static bool <T>Update(
DBFast.T t
);

See Also

DBFast Class | CYQ.Data.Orm Namespace | DBFast.Update Overload List


DBFast.Update Method (``0, Object)

更新记录

public static bool <T>Update(
DBFast.T t,
Object where
);

Parameters

DBFast.T
实体对象
Object
条件

Return Value

See Also

DBFast Class | CYQ.Data.Orm Namespace | DBFast.Update Overload List


DefaultValueAttribute Class

默认值

For a list of all members of this type, see DefaultValueAttribute Members.

System.Object
Attribute
DefaultValueAttribute

public class DefaultValueAttribute : Attribute

Requirements

Namespace: CYQ.Data.Orm

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

DefaultValueAttribute Members | CYQ.Data.Orm Namespace


DefaultValueAttribute Members

DefaultValueAttribute overview

Public Instance Constructors

DefaultValueAttribute Constructor

Public Instance Properties

DefaultValue

See Also

DefaultValueAttribute Class | CYQ.Data.Orm Namespace


DefaultValueAttribute Constructor

public DefaultValueAttribute(
Object defaultValue
);

See Also

DefaultValueAttribute Class | CYQ.Data.Orm Namespace


DefaultValueAttribute Properties

The properties of the DefaultValueAttribute class are listed below. For a complete list of DefaultValueAttribute class members, see the DefaultValueAttribute Members topic.

Public Instance Properties

DefaultValue

See Also

DefaultValueAttribute Class | CYQ.Data.Orm Namespace


DefaultValue Property

CYQ.Data API 帮助文档 For V5

DefaultValueAttribute.DefaultValue Property

public DefaultValue {get; set;}

See Also

DefaultValueAttribute Class | CYQ.Data.Orm Namespace


DescriptionAttribute Class

表名或字段描述

For a list of all members of this type, see DescriptionAttribute Members.

System.Object
Attribute
DescriptionAttribute

public class DescriptionAttribute : Attribute

Requirements

Namespace: CYQ.Data.Orm

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

DescriptionAttribute Members | CYQ.Data.Orm Namespace


DescriptionAttribute Members

DescriptionAttribute overview

Public Instance Constructors

DescriptionAttribute Constructor

Public Instance Properties

Description

See Also

DescriptionAttribute Class | CYQ.Data.Orm Namespace


DescriptionAttribute Constructor

public DescriptionAttribute(
String description
);

See Also

DescriptionAttribute Class | CYQ.Data.Orm Namespace


DescriptionAttribute Properties

The properties of the DescriptionAttribute class are listed below. For a complete list of DescriptionAttribute class members, see the DescriptionAttribute Members topic.

Public Instance Properties

Description

See Also

DescriptionAttribute Class | CYQ.Data.Orm Namespace


Description Property

CYQ.Data API 帮助文档 For V5

DescriptionAttribute.Description Property

public Description {get; set;}

See Also

DescriptionAttribute Class | CYQ.Data.Orm Namespace


FieldSource Enumeration

ORM CodeFirst 字段来源

public enum FieldSource

Members

Member Name | Description
Property | 从实体属性来
Data | 从数据库或文本数据来
BothOfAll | 综合以上两者

Requirements

Namespace: CYQ.Data.Orm

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Orm Namespace


KeyAttribute Class

主键自增是否允许Null

For a list of all members of this type, see KeyAttribute Members.

System.Object
Attribute
KeyAttribute

public class KeyAttribute : Attribute

Requirements

Namespace: CYQ.Data.Orm

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

KeyAttribute Members | CYQ.Data.Orm Namespace


KeyAttribute Members

KeyAttribute overview

Public Instance Constructors

KeyAttribute Overloaded. Initializes a new instance of the KeyAttribute class.

Public Instance Properties

IsAutoIncrement
IsCanNull
IsPrimaryKey

See Also

KeyAttribute Class | CYQ.Data.Orm Namespace


KeyAttribute Constructor

Overload List

public KeyAttribute(Boolean);

public KeyAttribute(Boolean,Boolean);

public KeyAttribute(Boolean,Boolean,Boolean);

See Also

KeyAttribute Class | CYQ.Data.Orm Namespace


KeyAttribute Constructor (Boolean)

public KeyAttribute(
Boolean isAutoIncrement
);

See Also

KeyAttribute Class | CYQ.Data.Orm Namespace | KeyAttribute Constructor Overload List


KeyAttribute Constructor (Boolean, Boolean)

public KeyAttribute(
Boolean isAutoIncrement,
Boolean isPrimaryKey
);

See Also

KeyAttribute Class | CYQ.Data.Orm Namespace | KeyAttribute Constructor Overload List


KeyAttribute Constructor (Boolean, Boolean, Boolean)

public KeyAttribute(
Boolean isAutoIncrement,
Boolean isPrimaryKey,
Boolean isCanNull
);

See Also

KeyAttribute Class | CYQ.Data.Orm Namespace | KeyAttribute Constructor Overload List


KeyAttribute Properties

The properties of the KeyAttribute class are listed below. For a complete list of KeyAttribute class members, see the KeyAttribute Members topic.

Public Instance Properties

IsAutoIncrement
IsCanNull
IsPrimaryKey

See Also

KeyAttribute Class | CYQ.Data.Orm Namespace


IsAutoIncrement Property

CYQ.Data API 帮助文档 For V5

KeyAttribute.IsAutoIncrement Property

public IsAutoIncrement {get; set;}

See Also

KeyAttribute Class | CYQ.Data.Orm Namespace


IsCanNull Property

CYQ.Data API 帮助文档 For V5

KeyAttribute.IsCanNull Property

public IsCanNull {get; set;}

See Also

KeyAttribute Class | CYQ.Data.Orm Namespace


IsPrimaryKey Property

CYQ.Data API 帮助文档 For V5

KeyAttribute.IsPrimaryKey Property

public IsPrimaryKey {get; set;}

See Also

KeyAttribute Class | CYQ.Data.Orm Namespace


LengthAttribute Class

列长度

For a list of all members of this type, see LengthAttribute Members.

System.Object
Attribute
LengthAttribute

public class LengthAttribute : Attribute

Requirements

Namespace: CYQ.Data.Orm

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

LengthAttribute Members | CYQ.Data.Orm Namespace


LengthAttribute Members

LengthAttribute overview

Public Instance Constructors

LengthAttribute Overloaded. Initializes a new instance of the LengthAttribute class.

Public Instance Properties

MaxSize | 长度
Scale | 精度

See Also

LengthAttribute Class | CYQ.Data.Orm Namespace


LengthAttribute Constructor

Overload List

public LengthAttribute(Int32);

public LengthAttribute(Int32,Int16);

See Also

LengthAttribute Class | CYQ.Data.Orm Namespace


LengthAttribute Constructor (Int32)

public LengthAttribute(
Int32 maxSize
);

See Also

LengthAttribute Class | CYQ.Data.Orm Namespace | LengthAttribute Constructor Overload List


LengthAttribute Constructor (Int32, Int16)

public LengthAttribute(
Int32 maxSize,
Int16 scale
);

See Also

LengthAttribute Class | CYQ.Data.Orm Namespace | LengthAttribute Constructor Overload List


LengthAttribute Properties

The properties of the LengthAttribute class are listed below. For a complete list of LengthAttribute class members, see the LengthAttribute Members topic.

Public Instance Properties

MaxSize | 长度
Scale | 精度

See Also

LengthAttribute Class | CYQ.Data.Orm Namespace


MaxSize Property

CYQ.Data API 帮助文档 For V5

LengthAttribute.MaxSize Property

长度

public MaxSize {get; set;}

See Also

LengthAttribute Class | CYQ.Data.Orm Namespace


Scale Property

CYQ.Data API 帮助文档 For V5

LengthAttribute.Scale Property

精度

public Scale {get; set;}

See Also

LengthAttribute Class | CYQ.Data.Orm Namespace


OrmBase Class

ORM扩展基类

For a list of all members of this type, see OrmBase Members.

System.Object
MarshalByRefObject
ContextBoundObject
OrmBase

public class OrmBase : ContextBoundObject,

Requirements

Namespace: CYQ.Data.Orm

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

OrmBase Members | CYQ.Data.Orm Namespace


OrmBase Members

OrmBase overview

Public Static Properties

FieldSource 字段来源（当字段变更时，可以设置此属性来切换更新）

Public Instance Constructors

OrmBase Constructor 构造函数

Public Instance Properties

AllowInsertID | 是否允许插入自增ID
Columns | 获取表的结构。
DalType | 当前的数据库类型
DebugInfo | 执行的调试语句输出
RawData | 原始行数据。
TableName | 获取或设置表名
UI | UI操作

Public Instance Methods

ClearPara | 清除(SetPara设置的)自定义参数
Delete | Overloaded. 删除数据
Dispose | 释放资源
Exists | 查询是否存在指定的条件的数据
Fill | Overloaded. 查询1条数据（自动取值）
GetCount | Overloaded. 获取记录总数
Insert | Overloaded. 插入数据
LoadFrom | 批量加载值（可从Json、实体对象、MDataRow、泛型字段等批量加载值）
Select | Overloaded. 列表查询
SetAopState | 设置Aop状态
SetExpression | 更新操作的自定义表达式设置。
SetPara | 参数化传参[当Where条件为参数化(如：name=@name)语句时使用]
SetSelectColumns | 本方法可以在单表使用时查询指定的列[设置后可使用Fill与Select方法] 提示：分页查询时，排序条件的列必须指定选择。
Update | Overloaded. 更新数据

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase Constructor

构造函数

public OrmBase();

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase Properties

The properties of the OrmBase class are listed below. For a complete list of OrmBase class members, see the OrmBase Members topic.

Public Static Properties

FieldSource 字段来源（当字段变更时，可以设置此属性来切换更新）

Public Instance Properties

AllowInsertID | 是否允许插入自增ID
Columns | 获取表的结构。
DalType | 当前的数据库类型
DebugInfo | 执行的调试语句输出
RawData | 原始行数据。
TableName | 获取或设置表名
UI | UI操作

See Also

OrmBase Class | CYQ.Data.Orm Namespace


AllowInsertID Property

CYQ.Data API 帮助文档 For V5

OrmBase.AllowInsertID Property

是否允许插入自增ID

public AllowInsertID {get; set;}

See Also

OrmBase Class | CYQ.Data.Orm Namespace


Columns Property

CYQ.Data API 帮助文档 For V5

OrmBase.Columns Property

获取表的结构。

public Columns {get;}

See Also

OrmBase Class | CYQ.Data.Orm Namespace


DalType Property

CYQ.Data API 帮助文档 For V5

OrmBase.DalType Property

当前的数据库类型

public DalType {get;}

See Also

OrmBase Class | CYQ.Data.Orm Namespace


DebugInfo Property

CYQ.Data API 帮助文档 For V5

OrmBase.DebugInfo Property

执行的调试语句输出

public DebugInfo {get;}

See Also

OrmBase Class | CYQ.Data.Orm Namespace


FieldSource Property

CYQ.Data API 帮助文档 For V5

OrmBase.FieldSource Property

字段来源（当字段变更时，可以设置此属性来切换更新）

public static FieldSource {get; set;}

See Also

OrmBase Class | CYQ.Data.Orm Namespace


RawData Property

CYQ.Data API 帮助文档 For V5

OrmBase.RawData Property

原始行数据。

public RawData {get;}

See Also

OrmBase Class | CYQ.Data.Orm Namespace


TableName Property

CYQ.Data API 帮助文档 For V5

OrmBase.TableName Property

获取或设置表名

public TableName {get; set;}

See Also

OrmBase Class | CYQ.Data.Orm Namespace


UI Property

CYQ.Data API 帮助文档 For V5

OrmBase.UI Property

UI操作

public UI {get;}

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase Methods

The methods of the OrmBase class are listed below. For a complete list of OrmBase class members, see the OrmBase Members topic.

Public Instance Methods

ClearPara | 清除(SetPara设置的)自定义参数
Delete | Overloaded. 删除数据
Dispose | 释放资源
Exists | 查询是否存在指定的条件的数据
Fill | Overloaded. 查询1条数据（自动取值）
GetCount | Overloaded. 获取记录总数
Insert | Overloaded. 插入数据
LoadFrom | 批量加载值（可从Json、实体对象、MDataRow、泛型字段等批量加载值）
Select | Overloaded. 列表查询
SetAopState | 设置Aop状态
SetExpression | 更新操作的自定义表达式设置。
SetPara | 参数化传参[当Where条件为参数化(如：name=@name)语句时使用]
SetSelectColumns | 本方法可以在单表使用时查询指定的列[设置后可使用Fill与Select方法] 提示：分页查询时，排序条件的列必须指定选择。
Update | Overloaded. 更新数据

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase.ClearPara Method

清除(SetPara设置的)自定义参数

public void ClearPara();

See Also

OrmBase Class | CYQ.Data.Orm Namespace


Delete Method

CYQ.Data API 帮助文档 For V5

OrmBase.Delete Method

删除数据

Overload List

删除数据

public bool Delete();

删除数据

public bool Delete(Object);

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase.Delete Method ()

删除数据

public bool Delete();

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Delete Overload List


OrmBase.Delete Method (Object)

删除数据

public bool Delete(
Object where
);

Parameters

Object
where条件,可直接传id的值如:[88],或传完整where条件如:[id=88 and name='路过秋天']

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Delete Overload List


OrmBase.Dispose Method

释放资源

public void Dispose();

Implements

IDisposable.

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase.Exists Method

查询是否存在指定的条件的数据

public bool Exists(
Object where
);

See Also

OrmBase Class | CYQ.Data.Orm Namespace


Fill Method

CYQ.Data API 帮助文档 For V5

OrmBase.Fill Method

查询1条数据（自动取值）

Overload List

查询1条数据（自动取值）

public bool Fill();

查询1条数据

public bool Fill(Object);

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase.Fill Method ()

查询1条数据（自动取值）

public bool Fill();

Return Value

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Fill Overload List


OrmBase.Fill Method (Object)

查询1条数据

public bool Fill(
Object where
);

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Fill Overload List


GetCount Method

CYQ.Data API 帮助文档 For V5

OrmBase.GetCount Method

获取记录总数

Overload List

获取记录总数

public int GetCount();

获取记录总数

public int GetCount(Object);

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase.GetCount Method ()

获取记录总数

public int GetCount();

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.GetCount Overload List


OrmBase.GetCount Method (Object)

获取记录总数

public int GetCount(
Object where
);

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.GetCount Overload List


Insert Method

CYQ.Data API 帮助文档 For V5

OrmBase.Insert Method

插入数据

Overload List

插入数据

public bool Insert();

插入数据

public bool Insert(InsertOp);

插入数据

public bool Insert(Boolean);

插入数据

public bool Insert(Boolean,InsertOp);

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase.Insert Method ()

插入数据

public bool Insert();

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Insert Overload List


OrmBase.Insert Method (InsertOp)

插入数据

public bool Insert(
InsertOp option
);

Parameters

InsertOp
插入选项

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Insert Overload List


OrmBase.Insert Method (Boolean)

插入数据

public bool Insert(
Boolean autoSetValue
);

Parameters

Boolean
自动从控制获取值

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Insert Overload List


OrmBase.Insert Method (Boolean, InsertOp)

插入数据

public bool Insert(
Boolean autoSetValue,
InsertOp option
);

Parameters

Boolean
自动从控制获取值
InsertOp
插入选项

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Insert Overload List


OrmBase.LoadFrom Method

批量加载值（可从Json、实体对象、MDataRow、泛型字段等批量加载值）

public void LoadFrom(
Object jsonOrEntity
);

Parameters

Object
json字符串或实体对象

See Also

OrmBase Class | CYQ.Data.Orm Namespace


Select Method

CYQ.Data API 帮助文档 For V5

OrmBase.Select Method

列表查询

Overload List

列表查询

public MDataTable Select();

public MDataTable Select(Int32,Int32);

public MDataTable Select(Int32,Int32,String);

带分布功能的选择[多条件查询,选择所有时只需把PageIndex/PageSize设置为0]

public MDataTable Select(Int32,Int32,String,out Int32&);

列表查询

public MDataTable Select(Int32,String);

列表查询

public MDataTable Select(String);

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase.Select Method ()

列表查询

public MDataTable Select();

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Select Overload List


OrmBase.Select Method (Int32, Int32)

public MDataTable Select(
Int32 pageIndex,
Int32 pageSize
);

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Select Overload List


OrmBase.Select Method (Int32, Int32, String)

public MDataTable Select(
Int32 pageIndex,
Int32 pageSize,
String where
);

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Select Overload List


OrmBase.Select Method (Int32, Int32, String, Int32@)

带分布功能的选择[多条件查询,选择所有时只需把PageIndex/PageSize设置为0]

public MDataTable Select(
Int32 pageIndex,
Int32 pageSize,
String where,
out Int32& count
);

Parameters

Int32
第几页
Int32
每页数量[为0时默认选择所有]
String
查询条件[可附带 order by 语句]
Int32&
返回的记录总数

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Select Overload List


OrmBase.Select Method (Int32, String)

列表查询

public MDataTable Select(
Int32 topN,
String where
);

Parameters

Int32
查询几条
String
查询条件[可附带 order by 语句]

Return Value

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Select Overload List


OrmBase.Select Method (String)

列表查询

public MDataTable Select(
String where
);

Parameters

String
查询条件[可附带 order by 语句]

Return Value

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Select Overload List


OrmBase.SetAopState Method

设置Aop状态

public void SetAopState(
AopOp op
);

Parameters

AopOp

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase.SetExpression Method

更新操作的自定义表达式设置。

public void SetExpression(
String updateExpression
);

Parameters

String
例如a字段值自加1："a=a+1"

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase.SetPara Method

参数化传参[当Where条件为参数化(如：name=@name)语句时使用]

public void SetPara(
Object paraName,
Object value,
DbType dbType
);

Parameters

Object
参数名称
Object
参数值
DbType
参数类型

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase.SetSelectColumns Method

本方法可以在单表使用时查询指定的列[设置后可使用Fill与Select方法] 提示：分页查询时，排序条件的列必须指定选择。

public void SetSelectColumns(
params Object[] columnNames
);

Parameters

Object[]
可设置多个列名[调用Fill或Select后,本参数将被清除]

See Also

OrmBase Class | CYQ.Data.Orm Namespace


Update Method

CYQ.Data API 帮助文档 For V5

OrmBase.Update Method

更新数据

Overload List

更新数据

public bool Update();

更新数据

public bool Update(Object);

更新数据

public bool Update(Object,Boolean);

See Also

OrmBase Class | CYQ.Data.Orm Namespace


OrmBase.Update Method ()

更新数据

public bool Update();

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Update Overload List


OrmBase.Update Method (Object)

更新数据

public bool Update(
Object where
);

Parameters

Object
where条件,可直接传id的值如:[88],或传完整where条件如:[id=88 and name='路过秋天']

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Update Overload List


OrmBase.Update Method (Object, Boolean)

更新数据

public bool Update(
Object where,
Boolean autoSetValue
);

Parameters

Object
where条件,可直接传id的值如:[88],或传完整where条件如:[id=88 and name='路过秋天']
Boolean
是否自动获取值[自动从控件获取值,需要先调用SetAutoPrefix或SetAutoParentControl方法设置控件前缀]

See Also

OrmBase Class | CYQ.Data.Orm Namespace | OrmBase.Update Overload List


SimpleOrmBase Class

简单ORM基类（纯数据交互功能）

For a list of all members of this type, see SimpleOrmBase Members.

System.Object
SimpleOrmBase
SysLogs

public class SimpleOrmBase :

Requirements

Namespace: CYQ.Data.Orm

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

SimpleOrmBase Members | CYQ.Data.Orm Namespace


SimpleOrmBase Members

SimpleOrmBase overview

Public Static Properties

FieldSource 字段来源（当字段变更时，可以设置此属性来切换更新）

Public Instance Constructors

SimpleOrmBase Constructor 构造函数

Public Instance Methods

Delete | Overloaded. 删除数据
Dispose | 释放资源
Exists | 查询是否存在指定的条件的数据
Fill | Overloaded. 查询1条数据
GetCount | Overloaded. 获取记录总数
Insert | Overloaded. 插入数据
Select | Overloaded. 列表查询
SetAopState | 设置Aop状态
Update | Overloaded. 更新数据

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


SimpleOrmBase Constructor

构造函数

public SimpleOrmBase();

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


SimpleOrmBase Properties

The properties of the SimpleOrmBase class are listed below. For a complete list of SimpleOrmBase class members, see the SimpleOrmBase Members topic.

Public Static Properties

FieldSource 字段来源（当字段变更时，可以设置此属性来切换更新）

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


FieldSource Property

CYQ.Data API 帮助文档 For V5

SimpleOrmBase.FieldSource Property

字段来源（当字段变更时，可以设置此属性来切换更新）

public static FieldSource {get; set;}

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


SimpleOrmBase Methods

The methods of the SimpleOrmBase class are listed below. For a complete list of SimpleOrmBase class members, see the SimpleOrmBase Members topic.

Public Instance Methods

Delete | Overloaded. 删除数据
Dispose | 释放资源
Exists | 查询是否存在指定的条件的数据
Fill | Overloaded. 查询1条数据
GetCount | Overloaded. 获取记录总数
Insert | Overloaded. 插入数据
Select | Overloaded. 列表查询
SetAopState | 设置Aop状态
Update | Overloaded. 更新数据

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


Delete Method

CYQ.Data API 帮助文档 For V5

SimpleOrmBase.Delete Method

删除数据

Overload List

删除数据

public bool Delete();

删除数据

public bool Delete(Object);

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


SimpleOrmBase.Delete Method ()

删除数据

public bool Delete();

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Delete Overload List


SimpleOrmBase.Delete Method (Object)

删除数据

public bool Delete(
Object where
);

Parameters

Object
where条件,可直接传id的值如:[88],或传完整where条件如:[id=88 and name='路过秋天']

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Delete Overload List


SimpleOrmBase.Dispose Method

释放资源

public void Dispose();

Implements

IDisposable.

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


SimpleOrmBase.Exists Method

查询是否存在指定的条件的数据

public bool Exists(
Object where
);

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


Fill Method

CYQ.Data API 帮助文档 For V5

SimpleOrmBase.Fill Method

查询1条数据

Overload List

查询1条数据

public bool Fill();

查询1条数据

public bool Fill(Object);

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


SimpleOrmBase.Fill Method ()

查询1条数据

public bool Fill();

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Fill Overload List


SimpleOrmBase.Fill Method (Object)

查询1条数据

public bool Fill(
Object where
);

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Fill Overload List


GetCount Method

CYQ.Data API 帮助文档 For V5

SimpleOrmBase.GetCount Method

获取记录总数

Overload List

获取记录总数

public int GetCount();

获取记录总数

public int GetCount(Object);

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


SimpleOrmBase.GetCount Method ()

获取记录总数

public int GetCount();

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.GetCount Overload List


SimpleOrmBase.GetCount Method (Object)

获取记录总数

public int GetCount(
Object where
);

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.GetCount Overload List


Insert Method

CYQ.Data API 帮助文档 For V5

SimpleOrmBase.Insert Method

插入数据

Overload List

插入数据

public bool Insert();

插入数据

public bool Insert(InsertOp);

插入数据

public bool Insert(InsertOp,Boolean);

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


SimpleOrmBase.Insert Method ()

插入数据

public bool Insert();

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Insert Overload List


SimpleOrmBase.Insert Method (InsertOp)

插入数据

public bool Insert(
InsertOp option
);

Parameters

InsertOp
插入选项

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Insert Overload List


SimpleOrmBase.Insert Method (InsertOp, Boolean)

插入数据

public bool Insert(
InsertOp option,
Boolean insertID
);

Parameters

InsertOp
Boolean
插入主键

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Insert Overload List


Select Method

CYQ.Data API 帮助文档 For V5

SimpleOrmBase.Select Method

列表查询

Overload List

列表查询

public List<T> Select<T>();

public List<T> Select<T>(Int32,Int32);

public List<T> Select<T>(Int32,Int32,String);

带分布功能的选择[多条件查询,选择所有时只需把PageIndex/PageSize设置为0]

public List<T> Select<T>(Int32,Int32,String,out Int32&);

列表查询

public List<T> Select<T>(Int32,String);

列表查询

public List<T> Select<T>(String);

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


SimpleOrmBase.Select Method ()

列表查询

public List<T> <T>Select();

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Select Overload List


SimpleOrmBase.Select Method (Int32, Int32)

public List<T> <T>Select(
Int32 pageIndex,
Int32 pageSize
);

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Select Overload List


SimpleOrmBase.Select Method (Int32, Int32, String)

public List<T> <T>Select(
Int32 pageIndex,
Int32 pageSize,
String where
);

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Select Overload List


SimpleOrmBase.Select Method (Int32, Int32, String, Int32@)

带分布功能的选择[多条件查询,选择所有时只需把PageIndex/PageSize设置为0]

public List<T> <T>Select(
Int32 pageIndex,
Int32 pageSize,
String where,
out Int32& count
);

Parameters

Int32
第几页
Int32
每页数量[为0时默认选择所有]
String
查询条件[可附带 order by 语句]
Int32&
返回的记录总数

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Select Overload List


SimpleOrmBase.Select Method (Int32, String)

列表查询

public List<T> <T>Select(
Int32 topN,
String where
);

Parameters

Int32
查询几条
String
查询条件[可附带 order by 语句]

Return Value

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Select Overload List


SimpleOrmBase.Select Method (String)

列表查询

public List<T> <T>Select(
String where
);

Parameters

String
查询条件[可附带 order by 语句]

Return Value

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Select Overload List


SimpleOrmBase.SetAopState Method

设置Aop状态

public void SetAopState(
AopOp op
);

Parameters

AopOp

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


Update Method

CYQ.Data API 帮助文档 For V5

SimpleOrmBase.Update Method

更新数据

Overload List

更新数据

public bool Update();

更新数据

public bool Update(Object);

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace


SimpleOrmBase.Update Method ()

更新数据

public bool Update();

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Update Overload List


SimpleOrmBase.Update Method (Object)

更新数据

public bool Update(
Object where
);

Parameters

Object
where条件,可直接传id的值如:[88],或传完整where条件如:[id=88 and name='路过秋天']

See Also

SimpleOrmBase Class | CYQ.Data.Orm Namespace | SimpleOrmBase.Update Overload List


CYQ.Data.SQL

CYQ.Data API 帮助文档 For V5

CYQ.Data.SQL Namespace

Namespace hierarchy

Classes

Class | Description
DataType | 数据类型转换类
SqlValue | 用于多数据库兼容的替换关键字/函数


DataType Class

数据类型转换类

For a list of all members of this type, see DataType Members.

System.Object
DataType

public static class DataType

Requirements

Namespace: CYQ.Data.SQL

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

DataType Members | CYQ.Data.SQL Namespace


DataType Members

DataType overview

Public Static Methods

GetDbType | Overloaded. 将DbType类型字符串表达形式对应映射到DbType类型
GetGroup | Overloaded. 字母型返回0；数字型返回1；日期型返回2；bool返回3；guid返回4；其它返回999
GetSqlType | Overloaded. 将DbType类型对应映射到SqlDbType类型
GetType | Overloaded. 获得数据类型对应的Type

See Also

DataType Class | CYQ.Data.SQL Namespace


DataType Methods

The methods of the DataType class are listed below. For a complete list of DataType class members, see the DataType Members topic.

Public Static Methods

GetDbType | Overloaded. 将DbType类型字符串表达形式对应映射到DbType类型
GetGroup | Overloaded. 字母型返回0；数字型返回1；日期型返回2；bool返回3；guid返回4；其它返回999
GetSqlType | Overloaded. 将DbType类型对应映射到SqlDbType类型
GetType | Overloaded. 获得数据类型对应的Type

See Also

DataType Class | CYQ.Data.SQL Namespace


GetDbType Method

CYQ.Data API 帮助文档 For V5

DataType.GetDbType Method

将DbType类型字符串表达形式对应映射到DbType类型

Overload List

将DbType类型字符串表达形式对应映射到DbType类型

public static DbType GetDbType(String);

将DbType类型字符串表达形式对应映射到DbType类型

public static DbType GetDbType(String,DalType);

将SqlDbType类型对应映射到DbType类型

public static DbType GetDbType(Type);

See Also

DataType Class | CYQ.Data.SQL Namespace


DataType.GetDbType Method (String)

将DbType类型字符串表达形式对应映射到DbType类型

public static DbType GetDbType(
String typeName
);

Parameters

String
类型名称

Return Value

See Also

DataType Class | CYQ.Data.SQL Namespace | DataType.GetDbType Overload List


DataType.GetDbType Method (String, DalType)

将DbType类型字符串表达形式对应映射到DbType类型

public static DbType GetDbType(
String typeName,
DalType dalType
);

Parameters

String
类型名称
DalType

Return Value

See Also

DataType Class | CYQ.Data.SQL Namespace | DataType.GetDbType Overload List


DataType.GetDbType Method (Type)

将SqlDbType类型对应映射到DbType类型

public static DbType GetDbType(
Type type
);

Parameters

Type
SqlDbType类型

Return Value

See Also

DataType Class | CYQ.Data.SQL Namespace | DataType.GetDbType Overload List


GetGroup Method

CYQ.Data API 帮助文档 For V5

DataType.GetGroup Method

字母型返回0；数字型返回1；日期型返回2；bool返回3；guid返回4；其它返回999

Overload List

字母型返回0；数字型返回1；日期型返回2；bool返回3；guid返回4；其它返回999

public static int GetGroup(SqlDbType);

字母型返回0；数字型返回1；日期型返回2；bool返回3；guid返回4；其它返回999

public static int GetGroup(SqlDbType,DalType);

See Also

DataType Class | CYQ.Data.SQL Namespace


DataType.GetGroup Method (SqlDbType)

字母型返回0；数字型返回1；日期型返回2；bool返回3；guid返回4；其它返回999

public static int GetGroup(
SqlDbType sqlDbType
);

Parameters

SqlDbType

Return Value

See Also

DataType Class | CYQ.Data.SQL Namespace | DataType.GetGroup Overload List


DataType.GetGroup Method (SqlDbType, DalType)

字母型返回0；数字型返回1；日期型返回2；bool返回3；guid返回4；其它返回999

public static int GetGroup(
SqlDbType sqlDbType,
DalType dalType
);

Parameters

SqlDbType
DalType

Return Value

See Also

DataType Class | CYQ.Data.SQL Namespace | DataType.GetGroup Overload List


GetSqlType Method

CYQ.Data API 帮助文档 For V5

DataType.GetSqlType Method

将DbType类型字符串表达方式对应映射到SqlDbType类型

Overload List

将DbType类型字符串表达方式对应映射到SqlDbType类型

public static SqlDbType GetSqlType(String);

将DbType类型对应映射到SqlDbType类型

public static SqlDbType GetSqlType(Type);

See Also

DataType Class | CYQ.Data.SQL Namespace


DataType.GetSqlType Method (String)

将DbType类型字符串表达方式对应映射到SqlDbType类型

public static SqlDbType GetSqlType(
String typeName
);

Parameters

String
类型名称

Return Value

See Also

DataType Class | CYQ.Data.SQL Namespace | DataType.GetSqlType Overload List


DataType.GetSqlType Method (Type)

将DbType类型对应映射到SqlDbType类型

public static SqlDbType GetSqlType(
Type type
);

Parameters

Type
DbType类型

Return Value

See Also

DataType Class | CYQ.Data.SQL Namespace | DataType.GetSqlType Overload List


GetType Method

CYQ.Data API 帮助文档 For V5

DataType.GetType Method

获得数据类型对应的Type

Overload List

获得数据类型对应的Type

public static Type GetType(SqlDbType);

获得数据类型对应的Type

public static Type GetType(SqlDbType,DalType);

See Also

DataType Class | CYQ.Data.SQL Namespace


DataType.GetType Method (SqlDbType)

获得数据类型对应的Type

public static Type GetType(
SqlDbType sqlType
);

See Also

DataType Class | CYQ.Data.SQL Namespace | DataType.GetType Overload List


DataType.GetType Method (SqlDbType, DalType)

获得数据类型对应的Type

public static Type GetType(
SqlDbType sqlType,
DalType dalType
);

See Also

DataType Class | CYQ.Data.SQL Namespace | DataType.GetType Overload List


SqlValue Class

用于多数据库兼容的替换关键字/函数

For a list of all members of this type, see SqlValue Members.

System.Object
SqlValue

public class SqlValue

Requirements

Namespace: CYQ.Data.SQL

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

SqlValue Members | CYQ.Data.SQL Namespace


SqlValue Members

SqlValue overview

Public Static Fields

Asc | 对于Bit类型[是/否] 类型的排序：[#ASC] (Access特殊)
Case 数据库函数 Case 分支语句，其它Case 一起的关键字也需要包含。
示例： [#CASE] [#WHEN] languageID={1} [#THEN] {2} [#ELSE] 0 [#END]
CaseWhen 数据库函数 Case When 分支语句，其它Case 一起的关键字也需要包含。
示例： [#CASE#WHEN] languageID={0} [#THEN] 1000000 [#ELSE] 0 [#END]
CharIndex 数据库函数 CharIndex 查询字符所在的位置：[#CHARINDEX]('要查询的字符',字段)
示例： [#CHARINDEX]('findtitle',Title)>0
Contact | 数据库链接符号 + Oracle下为：||
DateDiff | 数据库函数 DateDiff 比较日期的差异天数：[#DATEDIFF](参数,开始时间,结束时间) 参数："yyyy", "m","d", "h", "n", "s"
Day | 数据库函数 Day 获取时间的日：[#DAY](字段)
Desc | 对于Bit类型[是/否] 类型的排序：[#DESC] (Access特殊)
False | 对于Bit类型[是/否] 的条件值：[#FALSE]
GetDate | 数据库函数 GetDate 获取当前时间：[#GETDATE]
Guid | 数据库函数 GUID 获取：[#GUID]
IsNull | 数据库函数 ISNULL 判断：[#ISNULL](ColumnName,ReplaceValueWhenIsNull)
Left | 数据库函数:Left(column,length)
Len | 数据库函数 Len 取长度：[#LEN](字段)
Month | 数据库函数 Month 获取时间的月：[#MONTH](字段)
Right | 数据库函数：Right(column,length)
Substring 数据库函数 Substring 截取字符串：[#SUBSTRING](字段,起始索引int,长度int)
示例： [#Substring](Title,0,2)
True | 对于Bit类型[是/否] 的条件值：[#TRUE]
Year | 数据库函数 Year 获取时间的年：[#YEAR](字段)

Public Instance Constructors

SqlValue Constructor

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue Constructor

public SqlValue();

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue Fields

The fields of the SqlValue class are listed below. For a complete list of SqlValue class members, see the SqlValue Members topic.

Public Static Fields

Asc | 对于Bit类型[是/否] 类型的排序：[#ASC] (Access特殊)
Case 数据库函数 Case 分支语句，其它Case 一起的关键字也需要包含。
示例： [#CASE] [#WHEN] languageID={1} [#THEN] {2} [#ELSE] 0 [#END]
CaseWhen 数据库函数 Case When 分支语句，其它Case 一起的关键字也需要包含。
示例： [#CASE#WHEN] languageID={0} [#THEN] 1000000 [#ELSE] 0 [#END]
CharIndex 数据库函数 CharIndex 查询字符所在的位置：[#CHARINDEX]('要查询的字符',字段)
示例： [#CHARINDEX]('findtitle',Title)>0
Contact | 数据库链接符号 + Oracle下为：||
DateDiff | 数据库函数 DateDiff 比较日期的差异天数：[#DATEDIFF](参数,开始时间,结束时间) 参数："yyyy", "m","d", "h", "n", "s"
Day | 数据库函数 Day 获取时间的日：[#DAY](字段)
Desc | 对于Bit类型[是/否] 类型的排序：[#DESC] (Access特殊)
False | 对于Bit类型[是/否] 的条件值：[#FALSE]
GetDate | 数据库函数 GetDate 获取当前时间：[#GETDATE]
Guid | 数据库函数 GUID 获取：[#GUID]
IsNull | 数据库函数 ISNULL 判断：[#ISNULL](ColumnName,ReplaceValueWhenIsNull)
Left | 数据库函数:Left(column,length)
Len | 数据库函数 Len 取长度：[#LEN](字段)
Month | 数据库函数 Month 获取时间的月：[#MONTH](字段)
Right | 数据库函数：Right(column,length)
Substring 数据库函数 Substring 截取字符串：[#SUBSTRING](字段,起始索引int,长度int)
示例： [#Substring](Title,0,2)
True | 对于Bit类型[是/否] 的条件值：[#TRUE]
Year | 数据库函数 Year 获取时间的年：[#YEAR](字段)

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.Asc Field

对于Bit类型[是/否] 类型的排序：[#ASC] (Access特殊)

public const String Asc = "[#ASC]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.Case Field

数据库函数 Case 分支语句，其它Case 一起的关键字也需要包含。

示例： [#CASE] [#WHEN] languageID={1} [#THEN] {2} [#ELSE] 0 [#END]

public const String Case = "[#CASE]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.CaseWhen Field

数据库函数 Case When 分支语句，其它Case 一起的关键字也需要包含。

示例： [#CASE#WHEN] languageID={0} [#THEN] 1000000 [#ELSE] 0 [#END]

public const String CaseWhen = "[#CASE#WHEN]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.CharIndex Field

数据库函数 CharIndex 查询字符所在的位置：[#CHARINDEX]('要查询的字符',字段)

示例： [#CHARINDEX]('findtitle',Title)>0

public const String CharIndex = "[#CHARINDEX]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.Contact Field

数据库链接符号 + Oracle下为：||

public const String Contact = "[#+]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.DateDiff Field

数据库函数 DateDiff 比较日期的差异天数：[#DATEDIFF](参数,开始时间,结束时间) 参数："yyyy", "m","d", "h", "n", "s"

public const String DateDiff = "[#DATEDIFF]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.Day Field

数据库函数 Day 获取时间的日：[#DAY](字段)

public const String Day = "[#DAY]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.Desc Field

对于Bit类型[是/否] 类型的排序：[#DESC] (Access特殊)

public const String Desc = "[#DESC]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.False Field

对于Bit类型[是/否] 的条件值：[#FALSE]

public const String False = "[#FALSE]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.GetDate Field

数据库函数 GetDate 获取当前时间：[#GETDATE]

public const String GetDate = "[#GETDATE]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.Guid Field

数据库函数 GUID 获取：[#GUID]

public const String Guid = "[#GUID]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.IsNull Field

数据库函数 ISNULL 判断：[#ISNULL](ColumnName,ReplaceValueWhenIsNull)

public const String IsNull = "[#ISNULL]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.Left Field

数据库函数:Left(column,length)

public const String Left = "[#LEFT]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.Len Field

数据库函数 Len 取长度：[#LEN](字段)

public const String Len = "[#LEN]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.Month Field

数据库函数 Month 获取时间的月：[#MONTH](字段)

public const String Month = "[#MONTH]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.Right Field

数据库函数：Right(column,length)

public const String Right = "[#RIGHT]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.Substring Field

数据库函数 Substring 截取字符串：[#SUBSTRING](字段,起始索引int,长度int)

示例： [#Substring](Title,0,2)

public const String Substring = "[#SUBSTRING]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.True Field

对于Bit类型[是/否] 的条件值：[#TRUE]

public const String True = "[#TRUE]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


SqlValue.Year Field

数据库函数 Year 获取时间的年：[#YEAR](字段)

public const String Year = "[#YEAR]";

See Also

SqlValue Class | CYQ.Data.SQL Namespace


CYQ.Data.Table

CYQ.Data API 帮助文档 For V5

CYQ.Data.Table Namespace

Namespace hierarchy

Classes

Class | Description
MCellStruct | 单元结构属性
MDataCell | 单元格
MDataColumn | 头列表集合
MDataRow | 一行记录
MDataRowCollection | 实现Winform DataGridView 的添加编辑和删除操作功能。
MDataTable | 表格

Enumerations

Enumeration | Description
AcceptOp | 批量更新选项
AlterOp | 列结构修选项
BreakOp | MDataTable 与 MDataRow SetState 的过滤选项
RowOp | MDataRow 与 JsonHelper 行数据的过滤选项


AcceptOp Enumeration

批量更新选项

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum AcceptOp

Members

Member Name | Description | Value
Insert | 批量插入（由系统产生自增加ID） 该执行会开启事务。 | 1
InsertWithID | 批量插入（由用户指定ID插入） 该执行会开启事务。 | 2
Update | 批量更新 该执行会开启事务。 | 4
Delete | 批量删除 | 8
Auto | 批量自动插入或更新（检测主键数据若存在，则更新；不存在，则插入） 该执行不会开启事务。 | 16
Truncate | 清空表（只有和Insert或InsertWithID组合使用时才有效） | 32

Requirements

Namespace: CYQ.Data.Table

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Table Namespace


AlterOp Enumeration

列结构修选项

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum AlterOp

Members

Member Name | Description | Value
None | 默认不修改状态 | 0
AddOrModify | 添加或修改状态 | 1
Drop | 删除列状态 | 2
Rename | 重命名列状态 | 4

Requirements

Namespace: CYQ.Data.Table

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Table Namespace


BreakOp Enumeration

MDataTable 与 MDataRow SetState 的过滤选项

public enum BreakOp

Members

Member Name | Description
None | 未设置，设置所有
Null | 跳过设置值为Null的。
Empty | 跳过设置值为空的。
NullOrEmpty | 跳过设置值为Null或空的。

Requirements

Namespace: CYQ.Data.Table

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Table Namespace


MCellStruct Class

单元结构属性

For a list of all members of this type, see MCellStruct Members.

System.Object
MCellStruct

public class MCellStruct

Requirements

Namespace: CYQ.Data.Table

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

MCellStruct Members | CYQ.Data.Table Namespace


MCellStruct Members

MCellStruct overview

Public Instance Constructors

MCellStruct Overloaded. Initializes a new instance of the MCellStruct class.

Public Instance Fields

Description | 字段描述
FKTableName | 外键表名
IsAutoIncrement | 是否自增加
IsCanNull | 是否允许为Null
IsForeignKey | 是否外键
IsPrimaryKey | 是否关键字
IsUniqueKey | 是否唯一索引
MaxSize | 最大字节
OldName | 旧的列名（AlterOp为Rename时可用）
Scale | 精度（小数位）
TableName | 表名

Public Instance Properties

AlterOp | 列结构改变状态
ColumnName | 列名
DefaultValue | 默认值
MDataColumn | 结构集合
SqlType | SqlDbType类型

Public Instance Methods

Clone | 克隆一个对象。
GetWhereIn | 返回该列的where In 条件 : Name in("aa","bb")
Set | Overloaded. 为列的所有行设置值

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct Constructor

Overload List

public MCellStruct(String,SqlDbType);

public MCellStruct(String,SqlDbType,Boolean,Boolean,Int32);

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct Constructor (String, SqlDbType)

public MCellStruct(
String columnName,
SqlDbType sqlType
);

See Also

MCellStruct Class | CYQ.Data.Table Namespace | MCellStruct Constructor Overload List


MCellStruct Constructor (String, SqlDbType, Boolean, Boolean, Int32)

public MCellStruct(
String columnName,
SqlDbType sqlType,
Boolean isAutoIncrement,
Boolean isCanNull,
Int32 maxSize
);

See Also

MCellStruct Class | CYQ.Data.Table Namespace | MCellStruct Constructor Overload List


MCellStruct Fields

The fields of the MCellStruct class are listed below. For a complete list of MCellStruct class members, see the MCellStruct Members topic.

Public Instance Fields

Description | 字段描述
FKTableName | 外键表名
IsAutoIncrement | 是否自增加
IsCanNull | 是否允许为Null
IsForeignKey | 是否外键
IsPrimaryKey | 是否关键字
IsUniqueKey | 是否唯一索引
MaxSize | 最大字节
OldName | 旧的列名（AlterOp为Rename时可用）
Scale | 精度（小数位）
TableName | 表名

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.Description Field

字段描述

public String Description;

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.FKTableName Field

外键表名

public String FKTableName;

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.IsAutoIncrement Field

是否自增加

public Boolean IsAutoIncrement;

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.IsCanNull Field

是否允许为Null

public Boolean IsCanNull;

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.IsForeignKey Field

是否外键

public Boolean IsForeignKey;

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.IsPrimaryKey Field

是否关键字

public Boolean IsPrimaryKey;

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.IsUniqueKey Field

是否唯一索引

public Boolean IsUniqueKey;

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.MaxSize Field

最大字节

public Int32 MaxSize;

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.OldName Field

旧的列名（AlterOp为Rename时可用）

public String OldName;

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.Scale Field

精度（小数位）

public Int16 Scale;

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.TableName Field

表名

public String TableName;

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct Properties

The properties of the MCellStruct class are listed below. For a complete list of MCellStruct class members, see the MCellStruct Members topic.

Public Instance Properties

AlterOp | 列结构改变状态
ColumnName | 列名
DefaultValue | 默认值
MDataColumn | 结构集合
SqlType | SqlDbType类型

See Also

MCellStruct Class | CYQ.Data.Table Namespace


AlterOp Property

CYQ.Data API 帮助文档 For V5

MCellStruct.AlterOp Property

列结构改变状态

public AlterOp {get; set;}

See Also

MCellStruct Class | CYQ.Data.Table Namespace


ColumnName Property

CYQ.Data API 帮助文档 For V5

MCellStruct.ColumnName Property

列名

public ColumnName {get; set;}

See Also

MCellStruct Class | CYQ.Data.Table Namespace


DefaultValue Property

CYQ.Data API 帮助文档 For V5

MCellStruct.DefaultValue Property

默认值

public DefaultValue {get; set;}

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MDataColumn Property

CYQ.Data API 帮助文档 For V5

MCellStruct.MDataColumn Property

结构集合

public MDataColumn {get; set;}

See Also

MCellStruct Class | CYQ.Data.Table Namespace


SqlType Property

CYQ.Data API 帮助文档 For V5

MCellStruct.SqlType Property

SqlDbType类型

public SqlType {get; set;}

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct Methods

The methods of the MCellStruct class are listed below. For a complete list of MCellStruct class members, see the MCellStruct Members topic.

Public Instance Methods

Clone | 克隆一个对象。
GetWhereIn | 返回该列的where In 条件 : Name in("aa","bb")
Set | Overloaded. 为列的所有行设置值

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.Clone Method

克隆一个对象。

public MCellStruct Clone();

Return Value

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.GetWhereIn Method

返回该列的where In 条件 : Name in("aa","bb")

public string GetWhereIn();

Return Value

See Also

MCellStruct Class | CYQ.Data.Table Namespace


Set Method

CYQ.Data API 帮助文档 For V5

MCellStruct.Set Method

为列的所有行设置值

Overload List

为列的所有行设置值

public MCellStruct Set(Object);

public MCellStruct Set(Object,Int32);

See Also

MCellStruct Class | CYQ.Data.Table Namespace


MCellStruct.Set Method (Object)

为列的所有行设置值

public MCellStruct Set(
Object value
);

See Also

MCellStruct Class | CYQ.Data.Table Namespace | MCellStruct.Set Overload List


MCellStruct.Set Method (Object, Int32)

public MCellStruct Set(
Object value,
Int32 state
);

See Also

MCellStruct Class | CYQ.Data.Table Namespace | MCellStruct.Set Overload List


MDataCell Class

单元格

For a list of all members of this type, see MDataCell Members.

System.Object
MDataCell

public class MDataCell

Requirements

Namespace: CYQ.Data.Table

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

MDataCell Members | CYQ.Data.Table Namespace


MDataCell Members

MDataCell overview

Public Instance Properties

ColumnName | 列名[只读属性]
IsNull | 值是否为Null值[只读属性]
IsNullOrEmpty | 值是否为Null或为空[只读属性]
State | Value的状态:0;未改,1;进行赋值操作[但值相同],2:赋值,值不同改变了
StringValue | 字符串值
Struct | 单元格的结构
Value | 值

Public Instance Methods

Clear | 将值重置为空
Equals | 是否值相同[已重写该方法]
FixValue | Overloaded. 数据类型被切换，重新修正值的类型。
ToString | 已被重载，默认返回Value值。

See Also

MDataCell Class | CYQ.Data.Table Namespace


MDataCell Properties

The properties of the MDataCell class are listed below. For a complete list of MDataCell class members, see the MDataCell Members topic.

Public Instance Properties

ColumnName | 列名[只读属性]
IsNull | 值是否为Null值[只读属性]
IsNullOrEmpty | 值是否为Null或为空[只读属性]
State | Value的状态:0;未改,1;进行赋值操作[但值相同],2:赋值,值不同改变了
StringValue | 字符串值
Struct | 单元格的结构
Value | 值

See Also

MDataCell Class | CYQ.Data.Table Namespace


ColumnName Property

CYQ.Data API 帮助文档 For V5

MDataCell.ColumnName Property

列名[只读属性]

public ColumnName {get;}

See Also

MDataCell Class | CYQ.Data.Table Namespace


IsNull Property

CYQ.Data API 帮助文档 For V5

MDataCell.IsNull Property

值是否为Null值[只读属性]

public IsNull {get; set;}

See Also

MDataCell Class | CYQ.Data.Table Namespace


IsNullOrEmpty Property

CYQ.Data API 帮助文档 For V5

MDataCell.IsNullOrEmpty Property

值是否为Null或为空[只读属性]

public IsNullOrEmpty {get;}

See Also

MDataCell Class | CYQ.Data.Table Namespace


State Property

CYQ.Data API 帮助文档 For V5

MDataCell.State Property

Value的状态:0;未改,1;进行赋值操作[但值相同],2:赋值,值不同改变了

public State {get; set;}

See Also

MDataCell Class | CYQ.Data.Table Namespace


StringValue Property

CYQ.Data API 帮助文档 For V5

MDataCell.StringValue Property

字符串值

public StringValue {get; set;}

See Also

MDataCell Class | CYQ.Data.Table Namespace


Struct Property

CYQ.Data API 帮助文档 For V5

MDataCell.Struct Property

单元格的结构

public Struct {get;}

See Also

MDataCell Class | CYQ.Data.Table Namespace


Value Property

CYQ.Data API 帮助文档 For V5

MDataCell.Value Property

值

public Value {get; set;}

See Also

MDataCell Class | CYQ.Data.Table Namespace


MDataCell Methods

The methods of the MDataCell class are listed below. For a complete list of MDataCell class members, see the MDataCell Members topic.

Public Instance Methods

Clear | 将值重置为空
Equals | 是否值相同[已重写该方法]
FixValue | Overloaded. 数据类型被切换，重新修正值的类型。
ToString | 已被重载，默认返回Value值。

See Also

MDataCell Class | CYQ.Data.Table Namespace


MDataCell.Clear Method

将值重置为空

public void Clear();

See Also

MDataCell Class | CYQ.Data.Table Namespace


MDataCell.Equals Method

是否值相同[已重写该方法]

public override bool Equals(
Object value
);

See Also

MDataCell Class | CYQ.Data.Table Namespace


FixValue Method

CYQ.Data API 帮助文档 For V5

MDataCell.FixValue Method

数据类型被切换，重新修正值的类型。

Overload List

数据类型被切换，重新修正值的类型。

public bool FixValue();

数据类型被切换，重新修正值的类型。

public bool FixValue(out Exception&);

See Also

MDataCell Class | CYQ.Data.Table Namespace


MDataCell.FixValue Method ()

数据类型被切换，重新修正值的类型。

public bool FixValue();

See Also

MDataCell Class | CYQ.Data.Table Namespace | MDataCell.FixValue Overload List


MDataCell.FixValue Method (Exception@)

数据类型被切换，重新修正值的类型。

public bool FixValue(
out Exception& ex
);

See Also

MDataCell Class | CYQ.Data.Table Namespace | MDataCell.FixValue Overload List


MDataCell.ToString Method

已被重载，默认返回Value值。

public override string ToString();

Return Value

See Also

MDataCell Class | CYQ.Data.Table Namespace


MDataColumn Class

头列表集合

For a list of all members of this type, see MDataColumn Members.

System.Object
MDataColumn

public class MDataColumn : , , ,

Requirements

Namespace: CYQ.Data.Table

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

MDataColumn Members | CYQ.Data.Table Namespace


MDataColumn Members

MDataColumn overview

Public Static Methods

CreateFrom Overloaded. 从Json或文件中加载成列信息

Public Static Type Conversions

Implicit DataColumnCollection to MDataColumn Conversion 隐式转换列头

Public Instance Constructors

MDataColumn Constructor

Public Instance Fields

CheckDuplicate 添加列时，检测名称是否重复(默认为true)。

Public Instance Properties

Count |
Description | 表名描述
FirstPrimary | 第一个主键
FirstUnique | 首个唯一键
Item | Overloaded.
JointPrimary | 联合主键
Table | 架构所引用的表

Public Instance Methods

Add | Overloaded. 添加列
AddRange |
Clear |
Clone |
Contains | Overloaded.
GetIndex | 获取列所在的索引位置(若不存在返回-1）
Insert |
InsertRange |
Remove | Overloaded.
RemoveAt |
RemoveRange |
SetOrdinal | 将 列 的序号或位置更改为指定的序号或位置。
ToJson | 输出Json格式的表构架
ToRow | 转成行
ToTable | 将表结构的数据转成Table显示
WriteSchema | 保存表架构到外部文件中(json格式）

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn Constructor

public MDataColumn();

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn Fields

The fields of the MDataColumn class are listed below. For a complete list of MDataColumn class members, see the MDataColumn Members topic.

Public Instance Fields

CheckDuplicate 添加列时，检测名称是否重复(默认为true)。

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.CheckDuplicate Field

添加列时，检测名称是否重复(默认为true)。

public Boolean CheckDuplicate;

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn Properties

The properties of the MDataColumn class are listed below. For a complete list of MDataColumn class members, see the MDataColumn Members topic.

Public Instance Properties

Count |
Description | 表名描述
FirstPrimary | 第一个主键
FirstUnique | 首个唯一键
Item | Overloaded.
JointPrimary | 联合主键
Table | 架构所引用的表

See Also

MDataColumn Class | CYQ.Data.Table Namespace


Count Property

CYQ.Data API 帮助文档 For V5

MDataColumn.Count Property

public Count {get;}

Implements

ICollection`1.

See Also

MDataColumn Class | CYQ.Data.Table Namespace


Description Property

CYQ.Data API 帮助文档 For V5

MDataColumn.Description Property

表名描述

public Description {get; set;}

See Also

MDataColumn Class | CYQ.Data.Table Namespace


FirstPrimary Property

CYQ.Data API 帮助文档 For V5

MDataColumn.FirstPrimary Property

第一个主键

public FirstPrimary {get;}

See Also

MDataColumn Class | CYQ.Data.Table Namespace


FirstUnique Property

CYQ.Data API 帮助文档 For V5

MDataColumn.FirstUnique Property

首个唯一键

public FirstUnique {get;}

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MCellStruct Property

CYQ.Data API 帮助文档 For V5

MDataColumn.MCellStruct Property

ReadOnly

Overload List

ReadOnly

public this[Int32] {get; set;}

public this[String] {get;}

See Also

MDataColumn Class | CYQ.Data.Table Namespace


Item Property (Int32)

CYQ.Data API 帮助文档 For V5

MDataColumn.Item Property (Int32)

ReadOnly

public this[
Int32 index
] {get; set;}

Implements

IList`1.

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.MCellStruct Overload List


Item Property (String)

CYQ.Data API 帮助文档 For V5

MDataColumn.Item Property (String)

public this[
String key
] {get;}

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.MCellStruct Overload List


JointPrimary Property

CYQ.Data API 帮助文档 For V5

MDataColumn.JointPrimary Property

联合主键

public JointPrimary {get;}

See Also

MDataColumn Class | CYQ.Data.Table Namespace


Table Property

CYQ.Data API 帮助文档 For V5

MDataColumn.Table Property

架构所引用的表

public Table {get;}

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn Methods

The methods of the MDataColumn class are listed below. For a complete list of MDataColumn class members, see the MDataColumn Members topic.

Public Static Methods

CreateFrom Overloaded. 从Json或文件中加载成列信息

Public Instance Methods

Add | Overloaded. 添加列
AddRange |
Clear |
Clone |
Contains | Overloaded.
GetIndex | 获取列所在的索引位置(若不存在返回-1）
Insert |
InsertRange |
Remove | Overloaded.
RemoveAt |
RemoveRange |
SetOrdinal | 将 列 的序号或位置更改为指定的序号或位置。
ToJson | 输出Json格式的表构架
ToRow | 转成行
ToTable | 将表结构的数据转成Table显示
WriteSchema | 保存表架构到外部文件中(json格式）

See Also

MDataColumn Class | CYQ.Data.Table Namespace


Add Method

CYQ.Data API 帮助文档 For V5

MDataColumn.Add Method

Overload List

public void Add(MCellStruct);

添加列

public void Add(String);

public void Add(String,SqlDbType);

public void Add(String,SqlDbType,Boolean);

public void Add(String,SqlDbType,Boolean,Boolean,Int32);

public void Add(String,SqlDbType,Boolean,Boolean,Int32,Boolean,Object);

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.Add Method (MCellStruct)

public void Add(
MCellStruct item
);

Implements

ICollection<T>.

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.Add Overload List


MDataColumn.Add Method (String)

添加列

public void Add(
String columnName
);

Parameters

String
列名

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.Add Overload List


MDataColumn.Add Method (String, SqlDbType)

public void Add(
String columnName,
SqlDbType sqlType
);

Parameters

String
SqlDbType

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.Add Overload List


MDataColumn.Add Method (String, SqlDbType, Boolean)

public void Add(
String columnName,
SqlDbType sqlType,
Boolean isAutoIncrement
);

Parameters

String
SqlDbType
Boolean
是否自增ID列

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.Add Overload List


MDataColumn.Add Method (String, SqlDbType, Boolean, Boolean, Int32)

public void Add(
String columnName,
SqlDbType sqlType,
Boolean isAutoIncrement,
Boolean isCanNull,
Int32 maxSize
);

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.Add Overload List


MDataColumn.Add Method (String, SqlDbType, Boolean, Boolean, Int32, Boolean, Object)

public void Add(
String columnName,
SqlDbType sqlType,
Boolean isAutoIncrement,
Boolean isCanNull,
Int32 maxSize,
Boolean isPrimaryKey,
Object defaultValue
);

Parameters

String
SqlDbType
Boolean
Boolean
Int32
Boolean
Object
默认值[日期类型请传入SqlValue.GetDate]

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.Add Overload List


MDataColumn.AddRange Method

public void AddRange(
MDataColumn items
);

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.Clear Method

public void Clear();

Implements

ICollection<T>.

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.Clone Method

public MDataColumn Clone();

See Also

MDataColumn Class | CYQ.Data.Table Namespace


Contains Method

CYQ.Data API 帮助文档 For V5

MDataColumn.Contains Method

Overload List

public bool Contains(MCellStruct);

public bool Contains(String);

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.Contains Method (MCellStruct)

public bool Contains(
MCellStruct item
);

Implements

ICollection<T>.

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.Contains Overload List


MDataColumn.Contains Method (String)

public bool Contains(
String columnName
);

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.Contains Overload List


CreateFrom Method

CYQ.Data API 帮助文档 For V5

MDataColumn.CreateFrom Method

从Json或文件中加载成列信息

Overload List

从Json或文件中加载成列信息

public static MDataColumn CreateFrom(String);

从Json或文件中加载成列信息

public static MDataColumn CreateFrom(String,Boolean);

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.CreateFrom Method (String)

从Json或文件中加载成列信息

public static MDataColumn CreateFrom(
String jsonOrFileName
);

Parameters

String
Json或文件（完整路径）名称

Return Value

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.CreateFrom Overload List


MDataColumn.CreateFrom Method (String, Boolean)

从Json或文件中加载成列信息

public static MDataColumn CreateFrom(
String jsonOrFileName,
Boolean readTxtOrXml
);

Parameters

String
Json或文件（完整路径）名称
Boolean
是否从.txt或.xml文件中读取架构（默认为true）

Return Value

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.CreateFrom Overload List


MDataColumn.GetIndex Method

获取列所在的索引位置(若不存在返回-1）

public int GetIndex(
String columnName
);

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.Insert Method

public void Insert(
Int32 index,
MCellStruct item
);

Implements

IList<T>.

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.InsertRange Method

public void InsertRange(
Int32 index,
MDataColumn mdc
);

See Also

MDataColumn Class | CYQ.Data.Table Namespace


Remove Method

CYQ.Data API 帮助文档 For V5

MDataColumn.Remove Method

Overload List

public bool Remove(MCellStruct);

public void Remove(String);

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.Remove Method (MCellStruct)

public bool Remove(
MCellStruct item
);

Implements

ICollection<T>.

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.Remove Overload List


MDataColumn.Remove Method (String)

public void Remove(
String columnName
);

See Also

MDataColumn Class | CYQ.Data.Table Namespace | MDataColumn.Remove Overload List


MDataColumn.RemoveAt Method

public void RemoveAt(
Int32 index
);

Implements

IList<T>.

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.RemoveRange Method

public void RemoveRange(
Int32 index,
Int32 count
);

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.SetOrdinal Method

将 列 的序号或位置更改为指定的序号或位置。

public void SetOrdinal(
String columnName,
Int32 ordinal
);

Parameters

String
列名
Int32
序号

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.ToJson Method

输出Json格式的表构架

public string ToJson(
Boolean isFullSchema
);

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.ToRow Method

转成行

public MDataRow ToRow(
String tableName
);

Parameters

String
表名

Return Value

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.ToTable Method

将表结构的数据转成Table显示

public MDataTable ToTable();

Return Value

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn.WriteSchema Method

保存表架构到外部文件中(json格式）

public bool WriteSchema(
String fileName
);

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataColumn Type Conversions

The type conversions of the MDataColumn class are listed below. For a complete list of MDataColumn class members, see the MDataColumn Members topic.

Public Static Type Conversions

Implicit DataColumnCollection to MDataColumn Conversion 隐式转换列头

See Also

MDataColumn Class | MDataColumn Members | CYQ.Data.Table Namespace


MDataColumn Implicit DataColumnCollection to MDataColumn Conversion

隐式转换列头

public static implicit operator MDataColumn(
DataColumnCollection columns
);

Parameters

DataColumnCollection

Return Value

See Also

MDataColumn Class | CYQ.Data.Table Namespace


MDataRow Class

一行记录

For a list of all members of this type, see MDataRow Members.

System.Object
MDataRow

public class MDataRow : , , , , ,

Requirements

Namespace: CYQ.Data.Table

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

MDataRow Members | CYQ.Data.Table Namespace


MDataRow Members

MDataRow overview

Public Static Methods

CreateFrom Overloaded. 从实体、Json、Xml、IEnumerable接口实现的类、MDataRow

Public Static Type Conversions

Implicit DataRow to MDataRow Conversion

Public Instance Constructors

MDataRow Overloaded. Initializes a new instance of the MDataRow class.

Public Instance Properties

Columns | 获取列头
Conn | 所依属的数据库配置项名称[当MAction从带有架构的行加载时,此链接若存在,优先成为默认的数据库链接]
Count |
Item | Overloaded. 输入枚举型数据
ItemArray | 通过一个数组来获取或设置此行的所有值。
JointPrimaryCell | 获取联合主键列表（若有多个主键）
PrimaryCell | 获取第一个关键主键列
RowError | 获取或设置行的自定义错误说明。
Table | 获取该行拥有其架构的 MDataTable。
TableName | 原始表名[未经过多数据库兼容处理]

Public Instance Methods

Add | Overloaded.
Clear | 将行的数据行的值全重置为Null
Clone | 复制一行
Contains |
Get | Overloaded. 取值
GetItemValue | 此方法被Emit所调用
GetItemValues | 返回数组值
GetState | Overloaded. 获取行的当前状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]
Insert |
LoadFrom | Overloaded. 从数组里加载值
Remove | Overloaded.
RemoveAt |
Set | Overloaded. 为行设置值
SetState | Overloaded. 将行的数据行的状态全部重置
SetToAll | Overloaded. 将值批量赋给UI
SetToEntity | 将行中的数据值赋给实体对象
ToEntity | 转成实体
ToJson | Overloaded. 输出行的数据Json
ToTable | 将行的数据转成两列（ColumnName、Value）的表

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow Constructor

Overload List

public MDataRow();

public MDataRow(MDataColumn);

public MDataRow(MDataTable);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow Constructor ()

public MDataRow();

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow Constructor Overload List


MDataRow Constructor (MDataTable)

public MDataRow(
MDataTable dt
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow Constructor Overload List


MDataRow Constructor (MDataColumn)

public MDataRow(
MDataColumn mdc
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow Constructor Overload List


MDataRow Properties

The properties of the MDataRow class are listed below. For a complete list of MDataRow class members, see the MDataRow Members topic.

Public Instance Properties

Columns | 获取列头
Conn | 所依属的数据库配置项名称[当MAction从带有架构的行加载时,此链接若存在,优先成为默认的数据库链接]
Count |
Item | Overloaded. 输入枚举型数据
ItemArray | 通过一个数组来获取或设置此行的所有值。
JointPrimaryCell | 获取联合主键列表（若有多个主键）
PrimaryCell | 获取第一个关键主键列
RowError | 获取或设置行的自定义错误说明。
Table | 获取该行拥有其架构的 MDataTable。
TableName | 原始表名[未经过多数据库兼容处理]

See Also

MDataRow Class | CYQ.Data.Table Namespace


Columns Property

CYQ.Data API 帮助文档 For V5

MDataRow.Columns Property

获取列头

public Columns {get;}

See Also

MDataRow Class | CYQ.Data.Table Namespace


Conn Property

CYQ.Data API 帮助文档 For V5

MDataRow.Conn Property

所依属的数据库配置项名称[当MAction从带有架构的行加载时,此链接若存在,优先成为默认的数据库链接]

public Conn {get; set;}

See Also

MDataRow Class | CYQ.Data.Table Namespace


Count Property

CYQ.Data API 帮助文档 For V5

MDataRow.Count Property

public Count {get;}

Implements

ICollection`1.

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataCell Property

CYQ.Data API 帮助文档 For V5

MDataRow.MDataCell Property

Overload List

public this[Int32] {get; set;}

输入枚举型数据

public this[Object] {get;}

public this[String] {get;}

See Also

MDataRow Class | CYQ.Data.Table Namespace


Item Property (Int32)

CYQ.Data API 帮助文档 For V5

MDataRow.Item Property (Int32)

public this[
Int32 index
] {get; set;}

Implements

IList`1.

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.MDataCell Overload List


Item Property (Object)

CYQ.Data API 帮助文档 For V5

MDataRow.Item Property (Object)

输入枚举型数据

public this[
Object field
] {get;}

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.MDataCell Overload List


Item Property (String)

CYQ.Data API 帮助文档 For V5

MDataRow.Item Property (String)

public this[
String key
] {get;}

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.MDataCell Overload List


ItemArray Property

CYQ.Data API 帮助文档 For V5

MDataRow.ItemArray Property

通过一个数组来获取或设置此行的所有值。

public ItemArray {get;}

See Also

MDataRow Class | CYQ.Data.Table Namespace


JointPrimaryCell Property

CYQ.Data API 帮助文档 For V5

MDataRow.JointPrimaryCell Property

获取联合主键列表（若有多个主键）

public JointPrimaryCell {get;}

See Also

MDataRow Class | CYQ.Data.Table Namespace


PrimaryCell Property

CYQ.Data API 帮助文档 For V5

MDataRow.PrimaryCell Property

获取第一个关键主键列

public PrimaryCell {get;}

See Also

MDataRow Class | CYQ.Data.Table Namespace


RowError Property

CYQ.Data API 帮助文档 For V5

MDataRow.RowError Property

获取或设置行的自定义错误说明。

public RowError {get; set;}

See Also

MDataRow Class | CYQ.Data.Table Namespace


Table Property

CYQ.Data API 帮助文档 For V5

MDataRow.Table Property

获取该行拥有其架构的 MDataTable。

public Table {get; set;}

See Also

MDataRow Class | CYQ.Data.Table Namespace


TableName Property

CYQ.Data API 帮助文档 For V5

MDataRow.TableName Property

原始表名[未经过多数据库兼容处理]

public TableName {get; set;}

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow Methods

The methods of the MDataRow class are listed below. For a complete list of MDataRow class members, see the MDataRow Members topic.

Public Static Methods

CreateFrom Overloaded. 从实体、Json、Xml、IEnumerable接口实现的类、MDataRow

Public Instance Methods

Add | Overloaded.
Clear | 将行的数据行的值全重置为Null
Clone | 复制一行
Contains |
Get | Overloaded. 取值
GetItemValue | 此方法被Emit所调用
GetItemValues | 返回数组值
GetState | Overloaded. 获取行的当前状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]
Insert |
LoadFrom | Overloaded. 从数组里加载值
Remove | Overloaded.
RemoveAt |
Set | Overloaded. 为行设置值
SetState | Overloaded. 将行的数据行的状态全部重置
SetToAll | Overloaded. 将值批量赋给UI
SetToEntity | 将行中的数据值赋给实体对象
ToEntity | 转成实体
ToJson | Overloaded. 输出行的数据Json
ToTable | 将行的数据转成两列（ColumnName、Value）的表

See Also

MDataRow Class | CYQ.Data.Table Namespace


Add Method

CYQ.Data API 帮助文档 For V5

MDataRow.Add Method

Overload List

public void Add(MDataCell);

public void Add(String,SqlDbType,Object);

public void Add(String,Object);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.Add Method (MDataCell)

public void Add(
MDataCell cell
);

Implements

ICollection<T>.

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.Add Overload List


MDataRow.Add Method (String, SqlDbType, Object)

public void Add(
String columnName,
SqlDbType sqlType,
Object value
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.Add Overload List


MDataRow.Add Method (String, Object)

public void Add(
String columnName,
Object value
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.Add Overload List


MDataRow.Clear Method

将行的数据行的值全重置为Null

public void Clear();

Implements

ICollection<T>.

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.Clone Method

复制一行

public MDataRow Clone();

Return Value

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.Contains Method

public bool Contains(
MDataCell item
);

Implements

ICollection<T>.

See Also

MDataRow Class | CYQ.Data.Table Namespace


CreateFrom Method

CYQ.Data API 帮助文档 For V5

MDataRow.CreateFrom Method

从实体、Json、Xml、IEnumerable接口实现的类、MDataRow

Overload List

从实体、Json、Xml、IEnumerable接口实现的类、MDataRow

public static MDataRow CreateFrom(Object);

public static MDataRow CreateFrom(Object,Type);

public static MDataRow CreateFrom(Object,Type,BreakOp);

从实体、Json、Xml、IEnumerable接口实现的类、MDataRow

public static MDataRow CreateFrom(Object,Type,BreakOp,EscapeOp);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.CreateFrom Method (Object)

从实体、Json、Xml、IEnumerable接口实现的类、MDataRow

public static MDataRow CreateFrom(
Object anyObj
);

Return Value

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.CreateFrom Overload List


MDataRow.CreateFrom Method (Object, Type)

public static MDataRow CreateFrom(
Object anyObj,
Type valueType
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.CreateFrom Overload List


MDataRow.CreateFrom Method (Object, Type, BreakOp)

public static MDataRow CreateFrom(
Object anyObj,
Type valueType,
BreakOp op
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.CreateFrom Overload List


MDataRow.CreateFrom Method (Object, Type, BreakOp, EscapeOp)

从实体、Json、Xml、IEnumerable接口实现的类、MDataRow

public static MDataRow CreateFrom(
Object anyObj,
Type valueType,
BreakOp breakOp,
EscapeOp escapeOp
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.CreateFrom Overload List


Get Method

CYQ.Data API 帮助文档 For V5

MDataRow.Get Method

取值

Overload List

取值

public T Get<T>(Object);

public T Get<T>(Object,MDataRow.T);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.Get Method (Object)

取值

public T <T>Get(
Object key
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.Get Overload List


MDataRow.Get Method (Object, ``0)

public T <T>Get(
Object key,
MDataRow.T defaultValue
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.Get Overload List


MDataRow.GetItemValue Method

此方法被Emit所调用

public object GetItemValue(
Int32 index
);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.GetItemValues Method

返回数组值

public object[] GetItemValues();

Return Value

See Also

MDataRow Class | CYQ.Data.Table Namespace


GetState Method

CYQ.Data API 帮助文档 For V5

MDataRow.GetState Method

获取行的当前状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]

Overload List

获取行的当前状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]

public int GetState();

获取行的当前状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]

public int GetState(Boolean);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.GetState Method ()

获取行的当前状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]

public int GetState();

Return Value

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.GetState Overload List


MDataRow.GetState Method (Boolean)

获取行的当前状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]

public int GetState(
Boolean ignorePrimaryKey
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.GetState Overload List


MDataRow.Insert Method

public void Insert(
Int32 index,
MDataCell cell
);

Implements

IList<T>.

See Also

MDataRow Class | CYQ.Data.Table Namespace


LoadFrom Method

CYQ.Data API 帮助文档 For V5

MDataRow.LoadFrom Method

从Web Post表单里取值。

Overload List

从Web Post表单里取值。

public void LoadFrom();

从别的行加载值

public void LoadFrom(MDataRow);

从别的行加载值

public void LoadFrom(MDataRow,RowOp,Boolean);

从别的行加载值

public void LoadFrom(MDataRow,RowOp,Boolean,Boolean);

从Web Post表单里取值 或 从Winform、WPF的表单控件里取值。 True为Web应用，反之为Win应用Web时设置前缀，Win时设置父容器控件

public void LoadFrom(Boolean,params Object[]);

从泛型字典集合里加载

public void LoadFrom(IEnumerable);

将实体转成数据行。

public void LoadFrom(Object);

将实体转成数据行。

public void LoadFrom(Object,BreakOp);

从数组里加载值

public void LoadFrom(Object[]);

public void LoadFrom(String);

从json里加载值

public void LoadFrom(String,EscapeOp);

从json里加载值

public void LoadFrom(String,EscapeOp,BreakOp);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.LoadFrom Method ()

从Web Post表单里取值。

public void LoadFrom();

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.LoadFrom Overload List


MDataRow.LoadFrom Method (MDataRow)

从别的行加载值

public void LoadFrom(
MDataRow row
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.LoadFrom Overload List


MDataRow.LoadFrom Method (MDataRow, RowOp, Boolean)

从别的行加载值

public void LoadFrom(
MDataRow row,
RowOp rowOp,
Boolean isAllowAppendColumn
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.LoadFrom Overload List


MDataRow.LoadFrom Method (MDataRow, RowOp, Boolean, Boolean)

从别的行加载值

public void LoadFrom(
MDataRow row,
RowOp rowOp,
Boolean isAllowAppendColumn,
Boolean isWithValueState
);

Parameters

MDataRow
要加载数据的行
RowOp
行选项[从其它行加载的条件]
Boolean
如果row带有新列，是否加列
Boolean
是否同时加载值的状态[默认值为：true]

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.LoadFrom Overload List


MDataRow.LoadFrom Method (Boolean, Object[])

从Web Post表单里取值 或 从Winform、WPF的表单控件里取值。 True为Web应用，反之为Win应用Web时设置前缀，Win时设置父容器控件

public void LoadFrom(
Boolean isWeb,
params Object[] prefixOrParentControl
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.LoadFrom Overload List


MDataRow.LoadFrom Method (IEnumerable)

从泛型字典集合里加载

public void LoadFrom(
IEnumerable dic
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.LoadFrom Overload List


MDataRow.LoadFrom Method (Object)

将实体转成数据行。

public void LoadFrom(
Object entity
);

Parameters

Object
实体对象

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.LoadFrom Overload List


MDataRow.LoadFrom Method (Object, BreakOp)

将实体转成数据行。

public void LoadFrom(
Object entity,
BreakOp op
);

Parameters

Object
实体对象
BreakOp

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.LoadFrom Overload List


MDataRow.LoadFrom Method (Object[])

从数组里加载值

public void LoadFrom(
Object[] values
);

Parameters

Object[]

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.LoadFrom Overload List


MDataRow.LoadFrom Method (String)

public void LoadFrom(
String json
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.LoadFrom Overload List


MDataRow.LoadFrom Method (String, EscapeOp)

从json里加载值

public void LoadFrom(
String json,
EscapeOp op
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.LoadFrom Overload List


MDataRow.LoadFrom Method (String, EscapeOp, BreakOp)

从json里加载值

public void LoadFrom(
String json,
EscapeOp op,
BreakOp breakOp
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.LoadFrom Overload List


Remove Method

CYQ.Data API 帮助文档 For V5

MDataRow.Remove Method

Overload List

public bool Remove(MDataCell);

public void Remove(String);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.Remove Method (MDataCell)

public bool Remove(
MDataCell item
);

Implements

ICollection<T>.

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.Remove Overload List


MDataRow.Remove Method (String)

public void Remove(
String columnName
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.Remove Overload List


MDataRow.RemoveAt Method

public void RemoveAt(
Int32 index
);

Implements

IList<T>.

See Also

MDataRow Class | CYQ.Data.Table Namespace


Set Method

CYQ.Data API 帮助文档 For V5

MDataRow.Set Method

为行设置值

Overload List

为行设置值

public MDataRow Set(Object,Object);

为行设置值

public MDataRow Set(Object,Object,Int32);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.Set Method (Object, Object)

为行设置值

public MDataRow Set(
Object key,
Object value
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.Set Overload List


MDataRow.Set Method (Object, Object, Int32)

为行设置值

public MDataRow Set(
Object key,
Object value,
Int32 state
);

Parameters

Object
字段名
Object
值
Int32
手工设置状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.Set Overload List


SetState Method

CYQ.Data API 帮助文档 For V5

MDataRow.SetState Method

将行的数据行的状态全部重置

Overload List

将行的数据行的状态全部重置

public MDataRow SetState(Int32);

将行的数据行的状态全部重置

public MDataRow SetState(Int32,BreakOp);

public MDataRow SetState(Int32,BreakOp,String);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.SetState Method (Int32)

将行的数据行的状态全部重置

public MDataRow SetState(
Int32 state
);

Parameters

Int32
状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.SetState Overload List


MDataRow.SetState Method (Int32, BreakOp)

将行的数据行的状态全部重置

public MDataRow SetState(
Int32 state,
BreakOp op
);

Parameters

Int32
状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]
BreakOp
状态设置选项

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.SetState Overload List


MDataRow.SetState Method (Int32, BreakOp, String)

public MDataRow SetState(
Int32 state,
BreakOp op,
String columns
);

Parameters

Int32
BreakOp
String

批量指定某些列

Return Value

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.SetState Overload List


SetToAll Method

CYQ.Data API 帮助文档 For V5

MDataRow.SetToAll Method

将值批量赋给UI

Overload List

将值批量赋给UI

public void SetToAll(params Object[]);

将值批量赋给UI

public void SetToAll(String,params Object[]);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.SetToAll Method (Object[])

将值批量赋给UI

public void SetToAll(
params Object[] parentControls
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.SetToAll Overload List


MDataRow.SetToAll Method (String, Object[])

将值批量赋给UI

public void SetToAll(
String autoPrefix,
params Object[] parentControls
);

Parameters

String
自动前缀，多个可用逗号分隔
Object[]
页面控件

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.SetToAll Overload List


MDataRow.SetToEntity Method

将行中的数据值赋给实体对象

public void SetToEntity(
Object obj
);

Parameters

Object
实体对象

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.ToEntity Method

转成实体

public T <T>ToEntity();

See Also

MDataRow Class | CYQ.Data.Table Namespace


ToJson Method

CYQ.Data API 帮助文档 For V5

MDataRow.ToJson Method

输出行的数据Json

Overload List

输出行的数据Json

public string ToJson();

输出行的数据Json

public string ToJson(RowOp);

public string ToJson(RowOp,Boolean);

输出Json

public string ToJson(RowOp,Boolean,EscapeOp);

public string ToJson(Boolean);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow.ToJson Method ()

输出行的数据Json

public string ToJson();

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.ToJson Overload List


MDataRow.ToJson Method (RowOp)

输出行的数据Json

public string ToJson(
RowOp op
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.ToJson Overload List


MDataRow.ToJson Method (RowOp, Boolean)

public string ToJson(
RowOp op,
Boolean isConvertNameToLower
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.ToJson Overload List


MDataRow.ToJson Method (RowOp, Boolean, EscapeOp)

输出Json

public string ToJson(
RowOp op,
Boolean isConvertNameToLower,
EscapeOp escapeOp
);

Parameters

RowOp
过滤条件
Boolean
EscapeOp
转义选项

Return Value

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.ToJson Overload List


MDataRow.ToJson Method (Boolean)

public string ToJson(
Boolean isConvertNameToLower
);

See Also

MDataRow Class | CYQ.Data.Table Namespace | MDataRow.ToJson Overload List


MDataRow.ToTable Method

将行的数据转成两列（ColumnName、Value）的表

public MDataTable ToTable();

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRow Type Conversions

The type conversions of the MDataRow class are listed below. For a complete list of MDataRow class members, see the MDataRow Members topic.

Public Static Type Conversions

Implicit DataRow to MDataRow Conversion

See Also

MDataRow Class | MDataRow Members | CYQ.Data.Table Namespace


MDataRow Implicit DataRow to MDataRow Conversion

public static implicit operator MDataRow(
DataRow row
);

See Also

MDataRow Class | CYQ.Data.Table Namespace


MDataRowCollection Class

实现Winform DataGridView 的添加编辑和删除操作功能。

For a list of all members of this type, see MDataRowCollection Members.

System.Object
MDataRowCollection

public class MDataRowCollection : , , , , , , ,

Requirements

Namespace: CYQ.Data.Table

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

MDataRowCollection Members | CYQ.Data.Table Namespace


MDataRowCollection Members

MDataRowCollection overview

Public Static Type Conversions

Implicit List<T> to MDataRowCollection Conversion |
Implicit DataRowCollection to MDataRowCollection Conversion | 隐式转换列头

Public Instance Properties

Count |
Item |
Table | 获取该行拥有其架构的 MDataTable。

Public Instance Methods

Add | Overloaded. 创建使用指定值的行，并将其添加到 MDataRowCollection 中
AddRange |
Clear |
Compare |
Contains |
Insert |
InsertRange |
Remove |
RemoveAt |
Sort |

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection Properties

The properties of the MDataRowCollection class are listed below. For a complete list of MDataRowCollection class members, see the MDataRowCollection Members topic.

Public Instance Properties

Count |
Item |
Table | 获取该行拥有其架构的 MDataTable。

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


Count Property

CYQ.Data API 帮助文档 For V5

MDataRowCollection.Count Property

public Count {get;}

Implements

ICollection`1.

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


Item Property

CYQ.Data API 帮助文档 For V5

MDataRowCollection.Item Property

public this[
Int32 index
] {get; set;}

Implements

IList`1.

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


Table Property

CYQ.Data API 帮助文档 For V5

MDataRowCollection.Table Property

获取该行拥有其架构的 MDataTable。

public Table {get; set;}

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection Methods

The methods of the MDataRowCollection class are listed below. For a complete list of MDataRowCollection class members, see the MDataRowCollection Members topic.

Public Instance Methods

Add | Overloaded. 创建使用指定值的行，并将其添加到 MDataRowCollection 中
AddRange |
Clear |
Compare |
Contains |
Insert |
InsertRange |
Remove |
RemoveAt |
Sort |

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


Add Method

CYQ.Data API 帮助文档 For V5

MDataRowCollection.Add Method

Overload List

public void Add(MDataRow);

添加行[默认重置状态为true]

public void Add(MDataRow,Boolean);

创建使用指定值的行，并将其添加到 MDataRowCollection 中

public void Add(params Object[]);

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection.Add Method (MDataRow)

public void Add(
MDataRow item
);

Implements

ICollection<T>.

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace | MDataRowCollection.Add Overload List


MDataRowCollection.Add Method (MDataRow, Boolean)

添加行[默认重置状态为true]

public void Add(
MDataRow item,
Boolean resetState
);

Parameters

MDataRow
行
Boolean
重置状态,[默认true]，重置后的行数据不参与MDataTable的批量更新操作,状态在重新赋值时改变。

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace | MDataRowCollection.Add Overload List


MDataRowCollection.Add Method (Object[])

创建使用指定值的行，并将其添加到 MDataRowCollection 中

public void Add(
params Object[] values
);

Parameters

Object[]

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace | MDataRowCollection.Add Overload List


MDataRowCollection.AddRange Method

public void AddRange(
IEnumerable<T> collection
);

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection.Clear Method

public void Clear();

Implements

ICollection<T>.

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection.Compare Method

public int Compare(
MDataRow x,
MDataRow y
);

Implements

IComparer<T>.

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection.Contains Method

public bool Contains(
MDataRow item
);

Implements

ICollection<T>.

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection.Insert Method

public void Insert(
Int32 index,
MDataRow item
);

Implements

IList<T>.

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection.InsertRange Method

public void InsertRange(
Int32 index,
IEnumerable<T> collection
);

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection.Remove Method

public bool Remove(
MDataRow item
);

Implements

ICollection<T>.

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection.RemoveAt Method

public void RemoveAt(
Int32 index
);

Implements

IList<T>.

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection.Sort Method

public void Sort(
String orderby
);

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection Type Conversions

The type conversions of the MDataRowCollection class are listed below. For a complete list of MDataRowCollection class members, see the MDataRowCollection Members topic.

Public Static Type Conversions

Implicit List<T> to MDataRowCollection Conversion |
Implicit DataRowCollection to MDataRowCollection Conversion | 隐式转换列头

See Also

MDataRowCollection Class | MDataRowCollection Members | CYQ.Data.Table Namespace


MDataRowCollection Implicit List<T> to MDataRowCollection Conversion

public static implicit operator MDataRowCollection(
List<T> rows
);

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataRowCollection Implicit DataRowCollection to MDataRowCollection Conversion

隐式转换列头

public static implicit operator MDataRowCollection(
DataRowCollection rows
);

Parameters

DataRowCollection

Return Value

See Also

MDataRowCollection Class | CYQ.Data.Table Namespace


MDataTable Class

表格

For a list of all members of this type, see MDataTable Members.

System.Object
MDataTable

public class MDataTable : , , ,

Requirements

Namespace: CYQ.Data.Table

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

MDataTable Members | CYQ.Data.Table Namespace


MDataTable Members

MDataTable overview

Public Static Methods

CreateFrom Overloaded. 从List列表里加载成MDataTable

Public Static Type Conversions

Implicit MDataRow to MDataTable Conversion | 将一行数据装载成一个表。
Implicit MDataRowCollection to MDataTable Conversion | 将一行数据装载成一个表。
Implicit List<T> to MDataTable Conversion | 从行集合隐式转换成MDataTable
Implicit DbDataReader to MDataTable Conversion | 从DataReader隐式转换成MDataTable
Implicit DataTable to MDataTable Conversion | 从DataTable隐式转换成MDataTable

Public Instance Constructors

MDataTable Overloaded. Initializes a new instance of the MDataTable class.

Public Instance Properties

Columns | 表格的架构列
Conn | 该表归属的数据库链接。
Description | 表名描述
DynamicData | 动态存储数据
JoinOnName | 用于关联表的列名，不设置时默认取表主键值
RecordsAffected | 返回（查询时）记录总数。
Rows | 表格行
TableName | 表名

Public Instance Methods

AcceptChanges | Overloaded. 批量插入或更新 [提示：操作和当前表名有关，如当前表名不是要提交入库的表名,请给TableName属性重新赋值]
Avg | Overloaded. 记算某列的平均值
Bind | Overloaded. 将数据表绑定到列表控件
Clone | 复制表
Distinct | Overloaded. 过滤掉重复的数据行（仅比较基础类型、复杂数据类型仅比较类型名称）。 被过滤的数据集表
FindAll | 使用本查询，得到原数据的引用。
FindRow | 使用本查询，得到原数据的引用。
GetChanges | Overloaded. 获取修改过的数据
GetColumnItems | Overloaded. 返回某列的集合 列名
GetCount | 统计满足条件的行数
GetIndex | 统计满足条件的行所在的索引
GetSchema | 复制表的结构
Join | Overloaded. 两表LeftJoin关联
Max | Overloaded. 获取列的最大值
Merge | 将新表的行放到原表的下面。
Min | Overloaded. 获取列的最小值
NewRow | Overloaded. 新建一行
Pivot | Overloaded. 行转换列（不指定时，默认取最后三列处理）
Select | Overloaded. 使用本查询，得到克隆后的数据
SetState | Overloaded. 将表里所有行的数据行的状态全部重置
Split | 根据条件分拆成两个表【满足条件，和非满足条件的】，分出来的数据行和原始表仍是同一个引用
Sum | Overloaded. 汇总某列的值
ToDataTable | 转换成DataTable
ToJson | Overloaded. 输出Json
ToList | 转实体列表
ToString |
ToXml | Overloaded. 输出Xml文档
WriteJson | 输出Json[可指定保存路径]
WriteXml | Overloaded.

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable Constructor

Overload List

public MDataTable();

public MDataTable(String);

public MDataTable(String,MDataColumn);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable Constructor ()

public MDataTable();

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable Constructor Overload List


MDataTable Constructor (String)

public MDataTable(
String tableName
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable Constructor Overload List


MDataTable Constructor (String, MDataColumn)

public MDataTable(
String tableName,
MDataColumn mdc
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable Constructor Overload List


MDataTable Properties

The properties of the MDataTable class are listed below. For a complete list of MDataTable class members, see the MDataTable Members topic.

Public Instance Properties

Columns | 表格的架构列
Conn | 该表归属的数据库链接。
Description | 表名描述
DynamicData | 动态存储数据
JoinOnName | 用于关联表的列名，不设置时默认取表主键值
RecordsAffected | 返回（查询时）记录总数。
Rows | 表格行
TableName | 表名

See Also

MDataTable Class | CYQ.Data.Table Namespace


Columns Property

CYQ.Data API 帮助文档 For V5

MDataTable.Columns Property

表格的架构列

public Columns {get; set;}

See Also

MDataTable Class | CYQ.Data.Table Namespace


Conn Property

CYQ.Data API 帮助文档 For V5

MDataTable.Conn Property

该表归属的数据库链接。

public Conn {get; set;}

See Also

MDataTable Class | CYQ.Data.Table Namespace


Description Property

CYQ.Data API 帮助文档 For V5

MDataTable.Description Property

表名描述

public Description {get; set;}

See Also

MDataTable Class | CYQ.Data.Table Namespace


DynamicData Property

CYQ.Data API 帮助文档 For V5

MDataTable.DynamicData Property

动态存储数据

public DynamicData {get; set;}

See Also

MDataTable Class | CYQ.Data.Table Namespace


JoinOnName Property

CYQ.Data API 帮助文档 For V5

MDataTable.JoinOnName Property

用于关联表的列名，不设置时默认取表主键值

public JoinOnName {get; set;}

See Also

MDataTable Class | CYQ.Data.Table Namespace


RecordsAffected Property

CYQ.Data API 帮助文档 For V5

MDataTable.RecordsAffected Property

返回（查询时）记录总数。

public RecordsAffected {get; set;}

Implements

IDataReader.

See Also

MDataTable Class | CYQ.Data.Table Namespace


Rows Property

CYQ.Data API 帮助文档 For V5

MDataTable.Rows Property

表格行

public Rows {get;}

See Also

MDataTable Class | CYQ.Data.Table Namespace


TableName Property

CYQ.Data API 帮助文档 For V5

MDataTable.TableName Property

表名

public TableName {get; set;}

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable Methods

The methods of the MDataTable class are listed below. For a complete list of MDataTable class members, see the MDataTable Members topic.

Public Static Methods

CreateFrom Overloaded. 从List列表里加载成MDataTable

Public Instance Methods

AcceptChanges | Overloaded. 批量插入或更新 [提示：操作和当前表名有关，如当前表名不是要提交入库的表名,请给TableName属性重新赋值]
Avg | Overloaded. 记算某列的平均值
Bind | Overloaded. 将数据表绑定到列表控件
Clone | 复制表
Distinct | Overloaded. 过滤掉重复的数据行（仅比较基础类型、复杂数据类型仅比较类型名称）。 被过滤的数据集表
FindAll | 使用本查询，得到原数据的引用。
FindRow | 使用本查询，得到原数据的引用。
GetChanges | Overloaded. 获取修改过的数据
GetColumnItems | Overloaded. 返回某列的集合 列名
GetCount | 统计满足条件的行数
GetIndex | 统计满足条件的行所在的索引
GetSchema | 复制表的结构
Join | Overloaded. 两表LeftJoin关联
Max | Overloaded. 获取列的最大值
Merge | 将新表的行放到原表的下面。
Min | Overloaded. 获取列的最小值
NewRow | Overloaded. 新建一行
Pivot | Overloaded. 行转换列（不指定时，默认取最后三列处理）
Select | Overloaded. 使用本查询，得到克隆后的数据
SetState | Overloaded. 将表里所有行的数据行的状态全部重置
Split | 根据条件分拆成两个表【满足条件，和非满足条件的】，分出来的数据行和原始表仍是同一个引用
Sum | Overloaded. 汇总某列的值
ToDataTable | 转换成DataTable
ToJson | Overloaded. 输出Json
ToList | 转实体列表
ToString |
ToXml | Overloaded. 输出Xml文档
WriteJson | 输出Json[可指定保存路径]
WriteXml | Overloaded.

See Also

MDataTable Class | CYQ.Data.Table Namespace


AcceptChanges Method

CYQ.Data API 帮助文档 For V5

MDataTable.AcceptChanges Method

批量插入或更新 [提示：操作和当前表名有关，如当前表名不是要提交入库的表名,请给TableName属性重新赋值]

Overload List

批量插入或更新 [提示：操作和当前表名有关，如当前表名不是要提交入库的表名,请给TableName属性重新赋值]

public bool AcceptChanges(AcceptOp);

public bool AcceptChanges(AcceptOp,String,params Object[]);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.AcceptChanges Method (AcceptOp)

批量插入或更新 [提示：操作和当前表名有关，如当前表名不是要提交入库的表名,请给TableName属性重新赋值]

public bool AcceptChanges(
AcceptOp op
);

Parameters

AcceptOp
操作选项[插入|更新]

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.AcceptChanges Overload List


MDataTable.AcceptChanges Method (AcceptOp, String, Object[])

public bool AcceptChanges(
AcceptOp op,
String newConn,
params Object[] jointPrimaryKeys
);

Parameters

AcceptOp
操作选项[插入|更新]
String
指定新的数据库链接
Object[]
AcceptOp为Update或Auto时，若需要设置联合主键为唯一检测或更新条件，则可设置多个字段名

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.AcceptChanges Overload List


Avg Method

CYQ.Data API 帮助文档 For V5

MDataTable.Avg Method

记算某列的平均值

Overload List

记算某列的平均值

public T Avg<T>(Int32);

记算某列的平均值

public T Avg<T>(String);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.Avg Method (Int32)

记算某列的平均值

public T <T>Avg(
Int32 index
);

Parameters

Int32
列索引

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Avg Overload List


MDataTable.Avg Method (String)

记算某列的平均值

public T <T>Avg(
String columnName
);

Parameters

String
列名

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Avg Overload List


Bind Method

CYQ.Data API 帮助文档 For V5

MDataTable.Bind Method

将数据表绑定到列表控件

Overload List

将数据表绑定到列表控件

public void Bind(Object);

将数据表绑定到列表控件

public void Bind(Object,String);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.Bind Method (Object)

将数据表绑定到列表控件

public void Bind(
Object control
);

Parameters

Object
列表控件[包括Repeater/DataList/GridView/DataGrid等]

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Bind Overload List


MDataTable.Bind Method (Object, String)

将数据表绑定到列表控件

public void Bind(
Object control,
String nodeID
);

Parameters

Object
列表控件[包括Repeater/DataList/GridView/DataGrid等]
String
当Control为XHtmlAction对象时，需要指定绑定的节点ID

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Bind Overload List


MDataTable.Clone Method

复制表

public MDataTable Clone();

See Also

MDataTable Class | CYQ.Data.Table Namespace


CreateFrom Method

CYQ.Data API 帮助文档 For V5

MDataTable.CreateFrom Method

Overload List

public static MDataTable CreateFrom(NameObjectCollectionBase);

public static MDataTable CreateFrom(Object);

从List列表里加载成MDataTable

public static MDataTable CreateFrom(Object,BreakOp);

从Json或Xml字符串反加载成MDataTable

public static MDataTable CreateFrom(String);

public static MDataTable CreateFrom(String,MDataColumn);

从Json或Xml字符串反加载成MDataTable

public static MDataTable CreateFrom(String,MDataColumn,EscapeOp);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.CreateFrom Method (NameObjectCollectionBase)

public static MDataTable CreateFrom(
NameObjectCollectionBase noc
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.CreateFrom Overload List


MDataTable.CreateFrom Method (Object)

public static MDataTable CreateFrom(
Object entityList
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.CreateFrom Overload List


MDataTable.CreateFrom Method (Object, BreakOp)

从List列表里加载成MDataTable

public static MDataTable CreateFrom(
Object entityList,
BreakOp op
);

Parameters

Object
实体列表对象
BreakOp

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.CreateFrom Overload List


MDataTable.CreateFrom Method (String)

从Json或Xml字符串反加载成MDataTable

public static MDataTable CreateFrom(
String jsonOrXml
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.CreateFrom Overload List


MDataTable.CreateFrom Method (String, MDataColumn)

public static MDataTable CreateFrom(
String jsonOrXml,
MDataColumn mdc
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.CreateFrom Overload List


MDataTable.CreateFrom Method (String, MDataColumn, EscapeOp)

从Json或Xml字符串反加载成MDataTable

public static MDataTable CreateFrom(
String jsonOrXml,
MDataColumn mdc,
EscapeOp op
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.CreateFrom Overload List


Distinct Method

CYQ.Data API 帮助文档 For V5

MDataTable.Distinct Method

过滤掉重复的数据行（仅比较基础类型、复杂数据类型仅比较类型名称）。

Overload List

过滤掉重复的数据行（仅比较基础类型、复杂数据类型仅比较类型名称）。

public void Distinct();

过滤掉重复的数据行（仅比较基础类型、复杂数据类型仅比较类型名称）。 被过滤的数据集表

public void Distinct(out MDataTable&);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.Distinct Method ()

过滤掉重复的数据行（仅比较基础类型、复杂数据类型仅比较类型名称）。

public void Distinct();

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Distinct Overload List


MDataTable.Distinct Method (MDataTable@)

过滤掉重复的数据行（仅比较基础类型、复杂数据类型仅比较类型名称）。 被过滤的数据集表

public void Distinct(
out MDataTable& filterRows
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Distinct Overload List


MDataTable.FindAll Method

使用本查询，得到原数据的引用。

public MDataRowCollection FindAll(
Object where
);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.FindRow Method

使用本查询，得到原数据的引用。

public MDataRow FindRow(
Object where
);

See Also

MDataTable Class | CYQ.Data.Table Namespace


GetChanges Method

CYQ.Data API 帮助文档 For V5

MDataTable.GetChanges Method

获取修改过的数据

Overload List

获取修改过的数据

public MDataTable GetChanges();

获取修改过的数据(若无修改，则返回Null）

public MDataTable GetChanges(RowOp);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.GetChanges Method ()

获取修改过的数据

public MDataTable GetChanges();

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.GetChanges Overload List


MDataTable.GetChanges Method (RowOp)

获取修改过的数据(若无修改，则返回Null）

public MDataTable GetChanges(
RowOp rowOp
);

Parameters

RowOp
仅Insert和Update选项可用

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.GetChanges Overload List


GetColumnItems Method

CYQ.Data API 帮助文档 For V5

MDataTable.GetColumnItems Method

返回某列的集合

Overload List

返回某列的集合

public List<T> GetColumnItems<T>(Int32);

返回某列的集合

public List<T> GetColumnItems<T>(Int32,BreakOp);

返回某列的集合

public List<T> GetColumnItems<T>(Int32,BreakOp,Boolean);

返回某列的集合 列名

public List<T> GetColumnItems<T>(String);

返回某列的集合 列名参数选项

public List<T> GetColumnItems<T>(String,BreakOp);

返回某列的集合

public List<T> GetColumnItems<T>(String,BreakOp,Boolean);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.GetColumnItems Method (Int32)

返回某列的集合

public List<T> <T>GetColumnItems(
Int32 columnIndex
);

Parameters

Int32
第N列

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.GetColumnItems Overload List


MDataTable.GetColumnItems Method (Int32, BreakOp)

返回某列的集合

public List<T> <T>GetColumnItems(
Int32 columnIndex,
BreakOp op
);

Parameters

Int32
第N列
BreakOp
过滤选项

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.GetColumnItems Overload List


MDataTable.GetColumnItems Method (Int32, BreakOp, Boolean)

返回某列的集合

public List<T> <T>GetColumnItems(
Int32 columnIndex,
BreakOp op,
Boolean isDistinct
);

Parameters

Int32
第N列
BreakOp
过滤选项
Boolean
是否去掉重复数据

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.GetColumnItems Overload List


MDataTable.GetColumnItems Method (String)

返回某列的集合 列名

public List<T> <T>GetColumnItems(
String columnName
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.GetColumnItems Overload List


MDataTable.GetColumnItems Method (String, BreakOp)

返回某列的集合 列名参数选项

public List<T> <T>GetColumnItems(
String columnName,
BreakOp op
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.GetColumnItems Overload List


MDataTable.GetColumnItems Method (String, BreakOp, Boolean)

返回某列的集合

public List<T> <T>GetColumnItems(
String columnName,
BreakOp op,
Boolean isDistinct
);

Parameters

String
BreakOp
过滤选项
Boolean
是否去掉重复数据

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.GetColumnItems Overload List


MDataTable.GetCount Method

统计满足条件的行数

public int GetCount(
Object where
);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.GetIndex Method

统计满足条件的行所在的索引

public int GetIndex(
Object where
);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.GetSchema Method

复制表的结构

public MDataTable GetSchema(
Boolean clone
);

Parameters

Boolean
是否克隆表结构

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace


Join Method

CYQ.Data API 帮助文档 For V5

MDataTable.Join Method

两表LeftJoin关联

Overload List

两表LeftJoin关联

public MDataTable Join(MDataTable,params String[]);

两表LeftJoin关联

public MDataTable Join(Object,String,params String[]);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.Join Method (MDataTable, String[])

两表LeftJoin关联

public MDataTable Join(
MDataTable dt,
params String[] appendColumns
);

Parameters

MDataTable
关联表
String[]
追加显示的列，没有指定则追加关联表的所有列

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Join Overload List


MDataTable.Join Method (Object, String, String[])

两表LeftJoin关联

public MDataTable Join(
Object tableName,
String joinOnName,
params String[] appendColumns
);

Parameters

Object
关联表名
String
关联的字段名，设置Null则自动取表主键为关联名
String[]
追加显示的列，没有指定则追加关联表的所有列

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Join Overload List


Max Method

CYQ.Data API 帮助文档 For V5

MDataTable.Max Method

获取列的最大值

Overload List

获取列的最大值

public T Max<T>(Int32);

获取列的最大值

public T Max<T>(String);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.Max Method (Int32)

获取列的最大值

public T <T>Max(
Int32 index
);

Parameters

Int32
列索引

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Max Overload List


MDataTable.Max Method (String)

获取列的最大值

public T <T>Max(
String columnName
);

Parameters

String
列名

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Max Overload List


MDataTable.Merge Method

将新表的行放到原表的下面。

public void Merge(
MDataTable newTable
);

Parameters

MDataTable

See Also

MDataTable Class | CYQ.Data.Table Namespace


Min Method

CYQ.Data API 帮助文档 For V5

MDataTable.Min Method

获取列的最小值

Overload List

获取列的最小值

public T Min<T>(Int32);

获取列的最小值

public T Min<T>(String);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.Min Method (Int32)

获取列的最小值

public T <T>Min(
Int32 index
);

Parameters

Int32
列索引

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Min Overload List


MDataTable.Min Method (String)

获取列的最小值

public T <T>Min(
String columnName
);

Parameters

String
列名

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Min Overload List


NewRow Method

CYQ.Data API 帮助文档 For V5

MDataTable.NewRow Method

新建一行

Overload List

新建一行

public MDataRow NewRow();

新建一行

public MDataRow NewRow(Boolean);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.NewRow Method ()

新建一行

public MDataRow NewRow();

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.NewRow Overload List


MDataTable.NewRow Method (Boolean)

新建一行

public MDataRow NewRow(
Boolean isAddToTable
);

Parameters

Boolean
是否顺带添加到表中

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.NewRow Overload List


Pivot Method

CYQ.Data API 帮助文档 For V5

MDataTable.Pivot Method

行转换列（不指定时，默认取最后三列处理）

Overload List

行转换列（不指定时，默认取最后三列处理）

public MDataTable Pivot();

行转换列

public MDataTable Pivot(String,String,String);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.Pivot Method ()

行转换列（不指定时，默认取最后三列处理）

public MDataTable Pivot();

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Pivot Overload List


MDataTable.Pivot Method (String, String, String)

行转换列

public MDataTable Pivot(
String rowName,
String colName,
String valueName
);

Parameters

String
用于指定行的列名
String
用于分拆成列的列名
String
用于显示值的列名

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Pivot Overload List


Select Method

CYQ.Data API 帮助文档 For V5

MDataTable.Select Method

使用本查询，得到克隆后的数据

Overload List

使用本查询，得到克隆后的数据

public MDataTable Select(Int32,Int32,Object,params Object[]);

使用本查询，得到克隆后的数据

public MDataTable Select(Int32,Object);

使用本查询，得到克隆后的数据

public MDataTable Select(Object);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.Select Method (Int32, Int32, Object, Object[])

使用本查询，得到克隆后的数据

public MDataTable Select(
Int32 pageIndex,
Int32 pageSize,
Object where,
params Object[] selectColumns
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Select Overload List


MDataTable.Select Method (Int32, Object)

使用本查询，得到克隆后的数据

public MDataTable Select(
Int32 topN,
Object where
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Select Overload List


MDataTable.Select Method (Object)

使用本查询，得到克隆后的数据

public MDataTable Select(
Object where
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Select Overload List


SetState Method

CYQ.Data API 帮助文档 For V5

MDataTable.SetState Method

将表里所有行的数据行的状态全部重置

Overload List

将表里所有行的数据行的状态全部重置

public MDataTable SetState(Int32);

将表里所有行的数据行的状态全部重置

public MDataTable SetState(Int32,BreakOp);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.SetState Method (Int32)

将表里所有行的数据行的状态全部重置

public MDataTable SetState(
Int32 state
);

Parameters

Int32
状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.SetState Overload List


MDataTable.SetState Method (Int32, BreakOp)

将表里所有行的数据行的状态全部重置

public MDataTable SetState(
Int32 state,
BreakOp op
);

Parameters

Int32
状态[0:未更改；1:已赋值,值相同[可插入]；2:已赋值,值不同[可更新]]
BreakOp
状态设置选项

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.SetState Overload List


MDataTable.Split Method

根据条件分拆成两个表【满足条件，和非满足条件的】，分出来的数据行和原始表仍是同一个引用

public MDataTable[] Split(
Object where
);

See Also

MDataTable Class | CYQ.Data.Table Namespace


Sum Method

CYQ.Data API 帮助文档 For V5

MDataTable.Sum Method

汇总某列的值

Overload List

汇总某列的值

public T Sum<T>(Int32);

汇总某列的值

public T Sum<T>(String);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.Sum Method (Int32)

汇总某列的值

public T <T>Sum(
Int32 index
);

Parameters

Int32
列索引

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Sum Overload List


MDataTable.Sum Method (String)

汇总某列的值

public T <T>Sum(
String columnName
);

Parameters

String
列名

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.Sum Overload List


MDataTable.ToDataTable Method

转换成DataTable

public DataTable ToDataTable();

See Also

MDataTable Class | CYQ.Data.Table Namespace


ToJson Method

CYQ.Data API 帮助文档 For V5

MDataTable.ToJson Method

输出Json

Overload List

输出Json

public string ToJson();

public string ToJson(Boolean);

public string ToJson(Boolean,Boolean);

public string ToJson(Boolean,Boolean,RowOp);

public string ToJson(Boolean,Boolean,RowOp,Boolean);

public string ToJson(Boolean,Boolean,RowOp,Boolean,EscapeOp);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.ToJson Method ()

输出Json

public string ToJson();

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.ToJson Overload List


MDataTable.ToJson Method (Boolean)

public string ToJson(
Boolean addHead
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.ToJson Overload List


MDataTable.ToJson Method (Boolean, Boolean)

public string ToJson(
Boolean addHead,
Boolean addSchema
);

Parameters

Boolean
输出头部信息[带count、Success、ErrorMsg](默认true)
Boolean
首行输出表架构信息,反接收时可还原架构(默认false)

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.ToJson Overload List


MDataTable.ToJson Method (Boolean, Boolean, RowOp)

public string ToJson(
Boolean addHead,
Boolean addSchema,
RowOp rowOp
);

Parameters

Boolean
Boolean
RowOp
过滤选项

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.ToJson Overload List


MDataTable.ToJson Method (Boolean, Boolean, RowOp, Boolean)

public string ToJson(
Boolean addHead,
Boolean addSchema,
RowOp rowOp,
Boolean isConvertNameToLower
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.ToJson Overload List


MDataTable.ToJson Method (Boolean, Boolean, RowOp, Boolean, EscapeOp)

public string ToJson(
Boolean addHead,
Boolean addSchema,
RowOp rowOp,
Boolean isConvertNameToLower,
EscapeOp escapeOp
);

Parameters

Boolean
Boolean
RowOp
Boolean
EscapeOp

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.ToJson Overload List


MDataTable.ToList Method

转实体列表

public List<T> <T>ToList(
params Boolean[] useEmit
);

Parameters

Boolean[]
是否使用Emit方式转换[数据越多[大于500条]性能越高],不写默认自适应判断

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.ToString Method

public override string ToString();

See Also

MDataTable Class | CYQ.Data.Table Namespace


ToXml Method

CYQ.Data API 帮助文档 For V5

MDataTable.ToXml Method

输出Xml文档

Overload List

输出Xml文档

public string ToXml();

public string ToXml(Boolean);

输出Xml文档

public string ToXml(Boolean,Boolean,Boolean);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.ToXml Method ()

输出Xml文档

public string ToXml();

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.ToXml Overload List


MDataTable.ToXml Method (Boolean)

public string ToXml(
Boolean isConvertNameToLower
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.ToXml Overload List


MDataTable.ToXml Method (Boolean, Boolean, Boolean)

输出Xml文档

public string ToXml(
Boolean isConvertNameToLower,
Boolean needHeader,
Boolean needRootNode
);

Parameters

Boolean
名称转小写
Boolean
Boolean

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.ToXml Overload List


MDataTable.WriteJson Method

输出Json[可指定保存路径]

public bool WriteJson(
Boolean addHead,
Boolean addSchema,
String fileName
);

See Also

MDataTable Class | CYQ.Data.Table Namespace


WriteXml Method

CYQ.Data API 帮助文档 For V5

MDataTable.WriteXml Method

Overload List

public bool WriteXml(String);

保存Xml

public bool WriteXml(String,Boolean);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable.WriteXml Method (String)

public bool WriteXml(
String fileName
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.WriteXml Overload List


MDataTable.WriteXml Method (String, Boolean)

保存Xml

public bool WriteXml(
String fileName,
Boolean isConvertNameToLower
);

See Also

MDataTable Class | CYQ.Data.Table Namespace | MDataTable.WriteXml Overload List


MDataTable Type Conversions

The type conversions of the MDataTable class are listed below. For a complete list of MDataTable class members, see the MDataTable Members topic.

Public Static Type Conversions

Implicit MDataRow to MDataTable Conversion | 将一行数据装载成一个表。
Implicit MDataRowCollection to MDataTable Conversion | 将一行数据装载成一个表。
Implicit List<T> to MDataTable Conversion | 从行集合隐式转换成MDataTable
Implicit DbDataReader to MDataTable Conversion | 从DataReader隐式转换成MDataTable
Implicit DataTable to MDataTable Conversion | 从DataTable隐式转换成MDataTable

See Also

MDataTable Class | MDataTable Members | CYQ.Data.Table Namespace


MDataTable Implicit MDataRow to MDataTable Conversion

将一行数据装载成一个表。

public static implicit operator MDataTable(
MDataRow row
);

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable Implicit MDataRowCollection to MDataTable Conversion

将一行数据装载成一个表。

public static implicit operator MDataTable(
MDataRowCollection rows
);

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable Implicit List<T> to MDataTable Conversion

从行集合隐式转换成MDataTable

public static implicit operator MDataTable(
List<T> rows
);

Parameters

List<T>

Return Value

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable Implicit DbDataReader to MDataTable Conversion

从DataReader隐式转换成MDataTable

public static implicit operator MDataTable(
DbDataReader sdr
);

See Also

MDataTable Class | CYQ.Data.Table Namespace


MDataTable Implicit DataTable to MDataTable Conversion

从DataTable隐式转换成MDataTable

public static implicit operator MDataTable(
DataTable dt
);

See Also

MDataTable Class | CYQ.Data.Table Namespace


RowOp Enumeration

MDataRow 与 JsonHelper 行数据的过滤选项

public enum RowOp

Members

Member Name | Description
None | 未设置，输出所有，包括Null值的列
IgnoreNull | 输出所有，但不包括Null值的列
Insert | 输出具有插入状态的值
Update | 输出具有更新状态的值

Requirements

Namespace: CYQ.Data.Table

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Table Namespace


CYQ.Data.Tool

CYQ.Data API 帮助文档 For V5

CYQ.Data.Tool Namespace

Namespace hierarchy

Classes

Class | Description
ConvertTool | 类型转换（支持json转实体）
DBTool | 数据库工具类[都是静态方法]
EncryptHelper | 密码加密类
IOHelper | 文件读取类（能自动识别文件编码）
JsonHelper | Json class for you easy to operate json 功能全面的json帮助类
MDictionary<K,V> | 线程安全字典类
ReflectTool | 反射工具（带缓存）
ThreadBreak | 在ASP.NET中使用多线程时，为了避开升级dll时产生多个线程互相影响，使用此类可以通过外置文件进行跳出。

Enumerations

Enumeration | Description
EscapeOp | Escape json char options JsonHelper 的符号转义选项
SysType | 转实体所用参数


ConvertTool Class

类型转换（支持json转实体）

For a list of all members of this type, see ConvertTool Members.

System.Object
ConvertTool

public static class ConvertTool

Requirements

Namespace: CYQ.Data.Tool

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

ConvertTool Members | CYQ.Data.Tool Namespace


ConvertTool Members

ConvertTool overview

Public Static Methods

ChangeType 类型转换(精准强大)

See Also

ConvertTool Class | CYQ.Data.Tool Namespace


ConvertTool Methods

The methods of the ConvertTool class are listed below. For a complete list of ConvertTool class members, see the ConvertTool Members topic.

Public Static Methods

ChangeType 类型转换(精准强大)

See Also

ConvertTool Class | CYQ.Data.Tool Namespace


ConvertTool.ChangeType Method

类型转换(精准强大)

public static object ChangeType(
Object value,
Type t
);

Parameters

Object
值处理
Type
类型

Return Value

See Also

ConvertTool Class | CYQ.Data.Tool Namespace


DBTool Class

数据库工具类[都是静态方法]

For a list of all members of this type, see DBTool Members.

System.Object
DBTool

public static class DBTool

Requirements

Namespace: CYQ.Data.Tool

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

DBTool Members | CYQ.Data.Tool Namespace


DBTool Members

DBTool overview

Public Static Properties

ErrorMsg 获取异常的信息

Public Static Methods

AlterTable | Overloaded. 修改表的列结构
CreateTable | Overloaded. 为指定的表架构生成SQL(Create Table)语句
DropTable | Overloaded. 移除一张表
ExistsTable | Overloaded. 是否存在表
FormatDefaultValue | 将各数据库默认值格式化成标准值，将标准值还原成各数据库默认值
GetAlterTableSql | Overloaded. 获取指定的表架构生成的SQL(Alter Table)的说明语句
GetColumns | Overloaded. 获取表列架构
GetCreateTableDescriptionSql | 获取指定的表架构生成的SQL(Create Table)的说明语句
GetCreateTableSql | 获取指定的表架构生成的SQL(Create Table)的说明语句
GetDalType | 获取数据库链接的数据库类型
GetDataType | 获取指定数据库的数据类型
GetSchema | 获取表架构
GetTables | Overloaded. 获取数据库表
Keyword | 为字段或表名添加关键字标签：如[],''等符号
NotKeyword | 取消字段或表名添加关键字标签：如[],''等符号
TestConn | Overloaded. 测试数据库链接语句

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool Properties

The properties of the DBTool class are listed below. For a complete list of DBTool class members, see the DBTool Members topic.

Public Static Properties

ErrorMsg 获取异常的信息

See Also

DBTool Class | CYQ.Data.Tool Namespace


ErrorMsg Property

CYQ.Data API 帮助文档 For V5

DBTool.ErrorMsg Property

获取异常的信息

public static ErrorMsg {get; set;}

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool Methods

The methods of the DBTool class are listed below. For a complete list of DBTool class members, see the DBTool Members topic.

Public Static Methods

AlterTable | Overloaded. 修改表的列结构
CreateTable | Overloaded. 为指定的表架构生成SQL(Create Table)语句
DropTable | Overloaded. 移除一张表
ExistsTable | Overloaded. 是否存在表
FormatDefaultValue | 将各数据库默认值格式化成标准值，将标准值还原成各数据库默认值
GetAlterTableSql | Overloaded. 获取指定的表架构生成的SQL(Alter Table)的说明语句
GetColumns | Overloaded. 获取表列架构
GetCreateTableDescriptionSql | 获取指定的表架构生成的SQL(Create Table)的说明语句
GetCreateTableSql | 获取指定的表架构生成的SQL(Create Table)的说明语句
GetDalType | 获取数据库链接的数据库类型
GetDataType | 获取指定数据库的数据类型
GetSchema | 获取表架构
GetTables | Overloaded. 获取数据库表
Keyword | 为字段或表名添加关键字标签：如[],''等符号
NotKeyword | 取消字段或表名添加关键字标签：如[],''等符号
TestConn | Overloaded. 测试数据库链接语句

See Also

DBTool Class | CYQ.Data.Tool Namespace


AlterTable Method

CYQ.Data API 帮助文档 For V5

DBTool.AlterTable Method

修改表的列结构

Overload List

修改表的列结构

public static bool AlterTable(String,MDataColumn);

修改表的列结构

public static bool AlterTable(String,MDataColumn,String);

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.AlterTable Method (String, MDataColumn)

修改表的列结构

public static bool AlterTable(
String tableName,
MDataColumn columns
);

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.AlterTable Overload List


DBTool.AlterTable Method (String, MDataColumn, String)

修改表的列结构

public static bool AlterTable(
String tableName,
MDataColumn columns,
String conn
);

Parameters

String
表名
MDataColumn
列结构
String
数据库链接

Return Value

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.AlterTable Overload List


CreateTable Method

CYQ.Data API 帮助文档 For V5

DBTool.CreateTable Method

为指定的表架构生成SQL(Create Table)语句

Overload List

为指定的表架构生成SQL(Create Table)语句

public static bool CreateTable(String,MDataColumn);

为指定的表架构生成SQL(Create Table)语句

public static bool CreateTable(String,MDataColumn,String);

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.CreateTable Method (String, MDataColumn)

为指定的表架构生成SQL(Create Table)语句

public static bool CreateTable(
String tableName,
MDataColumn columns
);

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.CreateTable Overload List


DBTool.CreateTable Method (String, MDataColumn, String)

为指定的表架构生成SQL(Create Table)语句

public static bool CreateTable(
String tableName,
MDataColumn columns,
String conn
);

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.CreateTable Overload List


DropTable Method

CYQ.Data API 帮助文档 For V5

DBTool.DropTable Method

移除一张表

Overload List

移除一张表

public static bool DropTable(String);

移除一张表 数据库链接

public static bool DropTable(String,String);

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.DropTable Method (String)

移除一张表

public static bool DropTable(
String tableName
);

Return Value

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.DropTable Overload List


DBTool.DropTable Method (String, String)

移除一张表 数据库链接

public static bool DropTable(
String tableName,
String conn
);

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.DropTable Overload List


ExistsTable Method

CYQ.Data API 帮助文档 For V5

DBTool.ExistsTable Method

是否存在表

Overload List

是否存在表

public static bool ExistsTable(String);

是否存在指定的表

public static bool ExistsTable(String,String);

检测表是否存在

public static bool ExistsTable(String,String,out DalType&);

检测表是否存在

public static bool ExistsTable(String,String,out DalType&,out String&);

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.ExistsTable Method (String)

是否存在表

public static bool ExistsTable(
String tableName
);

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.ExistsTable Overload List


DBTool.ExistsTable Method (String, String)

是否存在指定的表

public static bool ExistsTable(
String tableName,
String conn
);

Parameters

String
表名[或文件名]
String
数据库链接

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.ExistsTable Overload List


DBTool.ExistsTable Method (String, String, DalType@)

检测表是否存在

public static bool ExistsTable(
String tableName,
String conn,
out DalType& dalType
);

Parameters

String
表名
String
数据库链接
DalType&
数据库类型

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.ExistsTable Overload List


DBTool.ExistsTable Method (String, String, DalType@, String@)

检测表是否存在

public static bool ExistsTable(
String tableName,
String conn,
out DalType& dalType,
out String& database
);

Parameters

String
表名
String
数据库链接
DalType&
数据库类型
String&

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.ExistsTable Overload List


DBTool.FormatDefaultValue Method

将各数据库默认值格式化成标准值，将标准值还原成各数据库默认值

public static string FormatDefaultValue(
DalType dalType,
Object value,
Int32 flag,
SqlDbType sqlDbType
);

Parameters

DalType
Object
Int32
[0:转成标准值],[1:转成各数据库值]
SqlDbType

Return Value

See Also

DBTool Class | CYQ.Data.Tool Namespace


GetAlterTableSql Method

CYQ.Data API 帮助文档 For V5

DBTool.GetAlterTableSql Method

获取指定的表架构生成的SQL(Alter Table)的说明语句

Overload List

获取指定的表架构生成的SQL(Alter Table)的说明语句

public static string GetAlterTableSql(String,MDataColumn);

获取指定的表架构生成的SQL(Alter Table)的说明语句

public static string GetAlterTableSql(String,MDataColumn,String);

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.GetAlterTableSql Method (String, MDataColumn)

获取指定的表架构生成的SQL(Alter Table)的说明语句

public static string GetAlterTableSql(
String tableName,
MDataColumn columns
);

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.GetAlterTableSql Overload List


DBTool.GetAlterTableSql Method (String, MDataColumn, String)

获取指定的表架构生成的SQL(Alter Table)的说明语句

public static string GetAlterTableSql(
String tableName,
MDataColumn columns,
String conn
);

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.GetAlterTableSql Overload List


GetColumns Method

CYQ.Data API 帮助文档 For V5

DBTool.GetColumns Method

获取表列架构

Overload List

获取表列架构

public static MDataColumn GetColumns(Object);

获取表列架构

public static MDataColumn GetColumns(String,String);

获取表列架构（链接错误时，抛异常）

public static MDataColumn GetColumns(String,String,out String&);

获取表列架构

public static MDataColumn GetColumns(Type);

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.GetColumns Method (Object)

获取表列架构

public static MDataColumn GetColumns(
Object tableName
);

Parameters

Object
表名

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.GetColumns Overload List


DBTool.GetColumns Method (String, String)

获取表列架构

public static MDataColumn GetColumns(
String tableName,
String conn
);

Parameters

String
表名
String
数据库链接

Return Value

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.GetColumns Overload List


DBTool.GetColumns Method (String, String, String@)

获取表列架构（链接错误时，抛异常）

public static MDataColumn GetColumns(
String tableName,
String conn,
out String& errInfo
);

Parameters

String
表名
String
数据库链接
String&
出错时的错误信息

Return Value

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.GetColumns Overload List


DBTool.GetColumns Method (Type)

获取表列架构

public static MDataColumn GetColumns(
Type typeInfo
);

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.GetColumns Overload List


DBTool.GetCreateTableDescriptionSql Method

获取指定的表架构生成的SQL(Create Table)的说明语句

public static string GetCreateTableDescriptionSql(
String tableName,
MDataColumn columns,
DalType dalType
);

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.GetCreateTableSql Method

获取指定的表架构生成的SQL(Create Table)的说明语句

public static string GetCreateTableSql(
String tableName,
MDataColumn columns,
DalType dalType,
String version
);

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.GetDalType Method

获取数据库链接的数据库类型

public static DalType GetDalType(
String conn
);

Parameters

String
链接配置Key或数据库链接语句

Return Value

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.GetDataType Method

获取指定数据库的数据类型

public static string GetDataType(
MCellStruct ms,
DalType dalType,
String version
);

Parameters

MCellStruct
单元格结构
DalType
数据库类型
String
数据库版本号

Return Value

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.GetSchema Method

获取表架构

public static DataTable GetSchema(
String conn,
String connectionName,
String[] restrictionValues
);

Parameters

String
数据库链接
String
指定要返回架构的名称
String[]
为指定的架构返回一组限制值

See Also

DBTool Class | CYQ.Data.Tool Namespace


GetTables Method

CYQ.Data API 帮助文档 For V5

DBTool.GetTables Method

获取数据库表

Overload List

获取数据库表

public static Dictionary<TKey,TValue> GetTables(String);

获取数据库表

public static Dictionary<TKey,TValue> GetTables(String,out String&);

获取所有表（表名+表说明）【链接错误时，抛异常】

public static Dictionary<TKey,TValue> GetTables(String,out String&,out String&);

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.GetTables Method (String)

获取数据库表

public static Dictionary<TKey,TValue> GetTables(
String conn
);

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.GetTables Overload List


DBTool.GetTables Method (String, String@)

获取数据库表

public static Dictionary<TKey,TValue> GetTables(
String conn,
out String& dbName
);

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.GetTables Overload List


DBTool.GetTables Method (String, String@, String@)

获取所有表（表名+表说明）【链接错误时，抛异常】

public static Dictionary<TKey,TValue> GetTables(
String conn,
out String& dbName,
out String& errInfo
);

Parameters

String
数据库链接
String&
返回指定链接的数据库名称
String&
链接错误时的信息信息

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.GetTables Overload List


DBTool.Keyword Method

为字段或表名添加关键字标签：如[],''等符号

public static string Keyword(
String name,
DalType dalType
);

Parameters

String
表名或字段名
DalType
数据类型

Return Value

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.NotKeyword Method

取消字段或表名添加关键字标签：如[],''等符号

public static string NotKeyword(
String name
);

Parameters

String
表名或字段名

See Also

DBTool Class | CYQ.Data.Tool Namespace


TestConn Method

CYQ.Data API 帮助文档 For V5

DBTool.TestConn Method

测试数据库链接语句

Overload List

测试数据库链接语句

public static bool TestConn(String);

public static bool TestConn(String,out String&);

See Also

DBTool Class | CYQ.Data.Tool Namespace


DBTool.TestConn Method (String)

测试数据库链接语句

public static bool TestConn(
String conn
);

Parameters

String
链接配置Key或数据库链接语句

Return Value

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.TestConn Overload List


DBTool.TestConn Method (String, String@)

public static bool TestConn(
String conn,
out String& msg
);

See Also

DBTool Class | CYQ.Data.Tool Namespace | DBTool.TestConn Overload List


EncryptHelper Class

密码加密类

For a list of all members of this type, see EncryptHelper Members.

System.Object
EncryptHelper

public static class EncryptHelper

Requirements

Namespace: CYQ.Data.Tool

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

EncryptHelper Members | CYQ.Data.Tool Namespace


EncryptHelper Members

EncryptHelper overview

Public Static Methods

Decrypt | Overloaded. 解密
Encrypt | Overloaded. 加密

See Also

EncryptHelper Class | CYQ.Data.Tool Namespace


EncryptHelper Methods

The methods of the EncryptHelper class are listed below. For a complete list of EncryptHelper class members, see the EncryptHelper Members topic.

Public Static Methods

Decrypt | Overloaded. 解密
Encrypt | Overloaded. 加密

See Also

EncryptHelper Class | CYQ.Data.Tool Namespace


Decrypt Method

CYQ.Data API 帮助文档 For V5

EncryptHelper.Decrypt Method

解密

Overload List

解密

public static string Decrypt(String);

public static string Decrypt(String,String);

See Also

EncryptHelper Class | CYQ.Data.Tool Namespace


EncryptHelper.Decrypt Method (String)

解密

public static string Decrypt(
String text
);

Parameters

String
要解密的字符串

Return Value

解密后的字符串

See Also

EncryptHelper Class | CYQ.Data.Tool Namespace | EncryptHelper.Decrypt Overload List


EncryptHelper.Decrypt Method (String, String)

public static string Decrypt(
String text,
String key
);

Parameters

String
String
指定加密的key

See Also

EncryptHelper Class | CYQ.Data.Tool Namespace | EncryptHelper.Decrypt Overload List


Encrypt Method

CYQ.Data API 帮助文档 For V5

EncryptHelper.Encrypt Method

加密

Overload List

加密

public static string Encrypt(String);

public static string Encrypt(String,String);

See Also

EncryptHelper Class | CYQ.Data.Tool Namespace


EncryptHelper.Encrypt Method (String)

加密

public static string Encrypt(
String text
);

Parameters

String
加密的内容

Return Value

See Also

EncryptHelper Class | CYQ.Data.Tool Namespace | EncryptHelper.Encrypt Overload List


EncryptHelper.Encrypt Method (String, String)

public static string Encrypt(
String text,
String key
);

Parameters

String
String
指定加密的key

See Also

EncryptHelper Class | CYQ.Data.Tool Namespace | EncryptHelper.Encrypt Overload List


EscapeOp Enumeration

Escape json char options

JsonHelper 的符号转义选项

public enum EscapeOp

Members

Member Name | Description
Default | 过滤ascii小于32的特殊值、并对\n "（双引号）进行转义，对\转义符 （仅\\"或\\n时不转义，其它情况转义）
No | 不进行任何转义，只用于保留原如数据（注意：存在双引号时，[或ascii小于32的值都会破坏json格式]，从而json数据无法被解析）
Yes | 过滤ascii小于32的特殊值、并对 ：\r \n \t "（双引号） \(转义符号) 直接进行转义
Encode | 系统内部使用： ascii小于32（包括\n \t \r）、"(双引号)，\(转义符号) 进行编码（规则为：@#{0}#@ {0}为asciii值，系统转的时候会自动解码）

Requirements

Namespace: CYQ.Data.Tool

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Tool Namespace


IOHelper Class

文件读取类（能自动识别文件编码）

For a list of all members of this type, see IOHelper Members.

System.Object
IOHelper

public static class IOHelper

Requirements

Namespace: CYQ.Data.Tool

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

IOHelper Members | CYQ.Data.Tool Namespace


IOHelper Members

IOHelper overview

Public Static Methods

Append | Overloaded. 往文件里追加数据(文件存在则追加，不存在则更新)，并自动识别文件编码
Delete | 删除文件
ReadAllLines | Overloaded. 读取文件内容，并自动识别编码
ReadAllText | Overloaded. 读取文件内容，并自动识别编码
Write | Overloaded. 往文件里写入数据(文件存在则复盖，不存在则更新)

See Also

IOHelper Class | CYQ.Data.Tool Namespace


IOHelper Methods

The methods of the IOHelper class are listed below. For a complete list of IOHelper class members, see the IOHelper Members topic.

Public Static Methods

Append | Overloaded. 往文件里追加数据(文件存在则追加，不存在则更新)，并自动识别文件编码
Delete | 删除文件
ReadAllLines | Overloaded. 读取文件内容，并自动识别编码
ReadAllText | Overloaded. 读取文件内容，并自动识别编码
Write | Overloaded. 往文件里写入数据(文件存在则复盖，不存在则更新)

See Also

IOHelper Class | CYQ.Data.Tool Namespace


Append Method

CYQ.Data API 帮助文档 For V5

IOHelper.Append Method

往文件里追加数据(文件存在则追加，不存在则更新)，并自动识别文件编码

Overload List

往文件里追加数据(文件存在则追加，不存在则更新)，并自动识别文件编码

public static bool Append(String,String);

public static bool Append(String,String,Encoding);

See Also

IOHelper Class | CYQ.Data.Tool Namespace


IOHelper.Append Method (String, String)

往文件里追加数据(文件存在则追加，不存在则更新)，并自动识别文件编码

public static bool Append(
String fileName,
String text
);

Parameters

String
String

Return Value

See Also

IOHelper Class | CYQ.Data.Tool Namespace | IOHelper.Append Overload List


IOHelper.Append Method (String, String, Encoding)

public static bool Append(
String fileName,
String text,
Encoding encode
);

See Also

IOHelper Class | CYQ.Data.Tool Namespace | IOHelper.Append Overload List


IOHelper.Delete Method

删除文件

public static bool Delete(
String fileName
);

See Also

IOHelper Class | CYQ.Data.Tool Namespace


ReadAllLines Method

CYQ.Data API 帮助文档 For V5

IOHelper.ReadAllLines Method

读取文件内容，并自动识别编码

Overload List

读取文件内容，并自动识别编码

public static string[] ReadAllLines(String);

public static string[] ReadAllLines(String,Int32);

public static string[] ReadAllLines(String,Int32,Encoding);

See Also

IOHelper Class | CYQ.Data.Tool Namespace


IOHelper.ReadAllLines Method (String)

读取文件内容，并自动识别编码

public static string[] ReadAllLines(
String fileName
);

See Also

IOHelper Class | CYQ.Data.Tool Namespace | IOHelper.ReadAllLines Overload List


IOHelper.ReadAllLines Method (String, Int32)

public static string[] ReadAllLines(
String fileName,
Int32 cacheMinutes
);

See Also

IOHelper Class | CYQ.Data.Tool Namespace | IOHelper.ReadAllLines Overload List


IOHelper.ReadAllLines Method (String, Int32, Encoding)

public static string[] ReadAllLines(
String fileName,
Int32 cacheMinutes,
Encoding encoding
);

See Also

IOHelper Class | CYQ.Data.Tool Namespace | IOHelper.ReadAllLines Overload List


ReadAllText Method

CYQ.Data API 帮助文档 For V5

IOHelper.ReadAllText Method

读取文件内容，并自动识别编码

Overload List

读取文件内容，并自动识别编码

public static string ReadAllText(String);

public static string ReadAllText(String,Int32);

读取文件内容

public static string ReadAllText(String,Int32,Encoding);

See Also

IOHelper Class | CYQ.Data.Tool Namespace


IOHelper.ReadAllText Method (String)

读取文件内容，并自动识别编码

public static string ReadAllText(
String fileName
);

Parameters

String
完整路径

Return Value

See Also

IOHelper Class | CYQ.Data.Tool Namespace | IOHelper.ReadAllText Overload List


IOHelper.ReadAllText Method (String, Int32)

public static string ReadAllText(
String fileName,
Int32 cacheMinutes
);

Parameters

String
Int32
缓存分钟数（为0则不缓存）

Return Value

See Also

IOHelper Class | CYQ.Data.Tool Namespace | IOHelper.ReadAllText Overload List


IOHelper.ReadAllText Method (String, Int32, Encoding)

读取文件内容

public static string ReadAllText(
String fileName,
Int32 cacheMinutes,
Encoding encoding
);

Parameters

String
Int32
Encoding
指定编码时（会跳过编码自动检测）

Return Value

See Also

IOHelper Class | CYQ.Data.Tool Namespace | IOHelper.ReadAllText Overload List


Write Method

CYQ.Data API 帮助文档 For V5

IOHelper.Write Method

往文件里写入数据(文件存在则复盖，不存在则更新)

Overload List

往文件里写入数据(文件存在则复盖，不存在则更新)

public static bool Write(String,String);

public static bool Write(String,String,Encoding);

See Also

IOHelper Class | CYQ.Data.Tool Namespace


IOHelper.Write Method (String, String)

往文件里写入数据(文件存在则复盖，不存在则更新)

public static bool Write(
String fileName,
String text
);

Parameters

String
String

Return Value

See Also

IOHelper Class | CYQ.Data.Tool Namespace | IOHelper.Write Overload List


IOHelper.Write Method (String, String, Encoding)

public static bool Write(
String fileName,
String text,
Encoding encode
);

See Also

IOHelper Class | CYQ.Data.Tool Namespace | IOHelper.Write Overload List


JsonHelper Class

Json class for you easy to operate json

功能全面的json帮助类

For a list of all members of this type, see JsonHelper Members.

System.Object
JsonHelper

public class JsonHelper

Requirements

Namespace: CYQ.Data.Tool

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

JsonHelper Members | CYQ.Data.Tool Namespace


JsonHelper Members

JsonHelper overview

Public Static Methods

GetValue | Overloaded.
IsJson | Overloaded. check string is json 检测是否Json格式的字符串
OutResult | Overloaded. a easy method for you to return a json 返回Json格式的结果信息
Split | split json to dicationary 将Json分隔成键值对。
SplitArray | split json to dicationary array 将Json 数组分隔成多个键值对。
ToEntity | Overloaded.
ToJson | Overloaded. Convert object to json 将一个对象（实体，泛型List，字典Dictionary）转成Json
ToList | Overloaded.
ToXml | Overloaded. Convert json to Xml 将一个Json转成Xml
UnEscape | 解码替换数据转义符

Public Instance Constructors

JsonHelper Overloaded. Initializes a new instance of the JsonHelper class.

Public Instance Fields

DateTimeFormatter | formate datetime 日期的格式化（默认：yyyy-MM-dd HH:mm:ss）
Escape | Escape options 转义符号
IsConvertNameToLower | convert filed to lower 是否将名称转为小写

Public Instance Properties

ErrorMsg | Error message 错误提示信息
RowCount | data rows count 当前返回的行数
RowOp | filter json data Json输出行数据的过滤选项
Success | is success 是否成功
Total | totla count 所有记录的总数（多数用于分页的记录总数）。

Public Instance Methods

Add | Overloaded. add json key value 添加一个字段的值
AddBr | flag a json is end and start a new json 添加完一个Json数据后调用此方法换行
AddFoot | Overloaded. attach json data (AddHead must be true) 添加底部数据（只有AddHead为true情况才能添加数据）
Fill | Overloaded. Fill obj and get json from ToString() method 从数据表中取数据填充,最终可输出json字符串
ToString | Overloaded. out json result 输出Json字符串

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper Constructor

Overload List

public JsonHelper();

public JsonHelper(Boolean);

public JsonHelper(Boolean,Boolean);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper Constructor ()

public JsonHelper();

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper Constructor Overload List


JsonHelper Constructor (Boolean)

public JsonHelper(
Boolean addHead
);

Parameters

Boolean
with easyui header ?

是否带输出头

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper Constructor Overload List


JsonHelper Constructor (Boolean, Boolean)

public JsonHelper(
Boolean addHead,
Boolean addSchema
);

Parameters

Boolean
Boolean
first row with table schema ?

是否首行带表结构[MDataTable.LoadFromJson可以还原表的数据类型]

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper Constructor Overload List


JsonHelper Fields

The fields of the JsonHelper class are listed below. For a complete list of JsonHelper class members, see the JsonHelper Members topic.

Public Instance Fields

DateTimeFormatter | formate datetime 日期的格式化（默认：yyyy-MM-dd HH:mm:ss）
Escape | Escape options 转义符号
IsConvertNameToLower | convert filed to lower 是否将名称转为小写

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.DateTimeFormatter Field

formate datetime

日期的格式化（默认：yyyy-MM-dd HH:mm:ss）

public String DateTimeFormatter;

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.Escape Field

Escape options

转义符号

public EscapeOp Escape;

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.IsConvertNameToLower Field

convert filed to lower

是否将名称转为小写

public Boolean IsConvertNameToLower;

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper Properties

The properties of the JsonHelper class are listed below. For a complete list of JsonHelper class members, see the JsonHelper Members topic.

Public Instance Properties

ErrorMsg | Error message 错误提示信息
RowCount | data rows count 当前返回的行数
RowOp | filter json data Json输出行数据的过滤选项
Success | is success 是否成功
Total | totla count 所有记录的总数（多数用于分页的记录总数）。

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


ErrorMsg Property

CYQ.Data API 帮助文档 For V5

JsonHelper.ErrorMsg Property

Error message

错误提示信息

public ErrorMsg {get; set;}

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


RowCount Property

CYQ.Data API 帮助文档 For V5

JsonHelper.RowCount Property

data rows count

当前返回的行数

public RowCount {get; set;}

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


RowOp Property

CYQ.Data API 帮助文档 For V5

JsonHelper.RowOp Property

filter json data

Json输出行数据的过滤选项

public RowOp {get; set;}

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


Success Property

CYQ.Data API 帮助文档 For V5

JsonHelper.Success Property

is success

是否成功

public Success {get;}

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


Total Property

CYQ.Data API 帮助文档 For V5

JsonHelper.Total Property

totla count

所有记录的总数（多数用于分页的记录总数）。

public Total {get; set;}

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper Methods

The methods of the JsonHelper class are listed below. For a complete list of JsonHelper class members, see the JsonHelper Members topic.

Public Static Methods

GetValue | Overloaded.
IsJson | Overloaded. check string is json 检测是否Json格式的字符串
OutResult | Overloaded. a easy method for you to return a json 返回Json格式的结果信息
Split | split json to dicationary 将Json分隔成键值对。
SplitArray | split json to dicationary array 将Json 数组分隔成多个键值对。
ToEntity | Overloaded.
ToJson | Overloaded. Convert object to json 将一个对象（实体，泛型List，字典Dictionary）转成Json
ToList | Overloaded.
ToXml | Overloaded. Convert json to Xml 将一个Json转成Xml
UnEscape | 解码替换数据转义符

Public Instance Methods

Add | Overloaded. add json key value 添加一个字段的值
AddBr | flag a json is end and start a new json 添加完一个Json数据后调用此方法换行
AddFoot | Overloaded. attach json data (AddHead must be true) 添加底部数据（只有AddHead为true情况才能添加数据）
Fill | Overloaded. Fill obj and get json from ToString() method 从数据表中取数据填充,最终可输出json字符串
ToString | Overloaded. out json result 输出Json字符串

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


Add Method

CYQ.Data API 帮助文档 For V5

JsonHelper.Add Method

add json key value

添加一个字段的值

Overload List

add json key value 添加一个字段的值

public void Add(String,String);

public void Add(String,String,Boolean);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.Add Method (String, String)

add json key value

添加一个字段的值

public void Add(
String name,
String value
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.Add Overload List


JsonHelper.Add Method (String, String, Boolean)

public void Add(
String name,
String value,
Boolean noQuotes
);

Parameters

String
String
Boolean
value is no quotes

值不带引号

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.Add Overload List


JsonHelper.AddBr Method

flag a json is end and start a new json

添加完一个Json数据后调用此方法换行

public void AddBr();

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


AddFoot Method

CYQ.Data API 帮助文档 For V5

JsonHelper.AddFoot Method

attach json data (AddHead must be true)

添加底部数据（只有AddHead为true情况才能添加数据）

Overload List

attach json data (AddHead must be true) 添加底部数据（只有AddHead为true情况才能添加数据）

public void AddFoot(String,String);

public void AddFoot(String,String,Boolean);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.AddFoot Method (String, String)

attach json data (AddHead must be true)

添加底部数据（只有AddHead为true情况才能添加数据）

public void AddFoot(
String name,
String value
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.AddFoot Overload List


JsonHelper.AddFoot Method (String, String, Boolean)

public void AddFoot(
String name,
String value,
Boolean noQuotes
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.AddFoot Overload List


Fill Method

CYQ.Data API 帮助文档 For V5

JsonHelper.Fill Method

从数据结构填充，最终可输出json字符串。

Overload List

从数据结构填充，最终可输出json字符串。

public void Fill(MDataColumn,Boolean);

Fill obj and get json from ToString() method 从数据行中取数据填充,最终可输出json字符串

public void Fill(MDataRow);

Fill obj and get json from ToString() method 从数据表中取数据填充,最终可输出json字符串

public void Fill(MDataTable);

Fill obj and get json from ToString() method 可从类(对象,泛型List、泛型Dictionary）中填充，最终可输出json字符串。

public void Fill(Object);

public void Fill(String);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.Fill Method (MDataColumn, Boolean)

从数据结构填充，最终可输出json字符串。

public void Fill(
MDataColumn column,
Boolean isFullSchema
);

Parameters

MDataColumn
数据结构
Boolean
false：输出单行的[列名：数据类型]；true：输出多行的完整的数据结构

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.Fill Overload List


JsonHelper.Fill Method (MDataRow)

Fill obj and get json from ToString() method

从数据行中取数据填充,最终可输出json字符串

public void Fill(
MDataRow row
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.Fill Overload List


JsonHelper.Fill Method (MDataTable)

Fill obj and get json from ToString() method

从数据表中取数据填充,最终可输出json字符串

public void Fill(
MDataTable table
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.Fill Overload List


JsonHelper.Fill Method (Object)

Fill obj and get json from ToString() method

可从类(对象,泛型List、泛型Dictionary）中填充，最终可输出json字符串。

public void Fill(
Object obj
);

Parameters

Object
实体类对象

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.Fill Overload List


JsonHelper.Fill Method (String)

public void Fill(
String query
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.Fill Overload List


GetValue Method

CYQ.Data API 帮助文档 For V5

JsonHelper.GetValue Method

Overload List

public static string GetValue(String,String);

Get json value 获取Json字符串的值

public static string GetValue(String,String,EscapeOp);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.GetValue Method (String, String)

public static string GetValue(
String json,
String key
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.GetValue Overload List


JsonHelper.GetValue Method (String, String, EscapeOp)

Get json value

获取Json字符串的值

public static string GetValue(
String json,
String key,
EscapeOp op
);

Parameters

String
String
the name or key of json

键值(有层级时用：XXX.YYY.ZZZ)

EscapeOp

Return Value

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.GetValue Overload List


IsJson Method

CYQ.Data API 帮助文档 For V5

JsonHelper.IsJson Method

check string is json

检测是否Json格式的字符串

Overload List

check string is json 检测是否Json格式的字符串

public static bool IsJson(String);

public static bool IsJson(String,out Int32&);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.IsJson Method (String)

check string is json

检测是否Json格式的字符串

public static bool IsJson(
String json
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.IsJson Overload List


JsonHelper.IsJson Method (String, Int32@)

public static bool IsJson(
String json,
out Int32& errIndex
);

Parameters

String
Int32&
the index of the error char

错误的字符索引

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.IsJson Overload List


OutResult Method

CYQ.Data API 帮助文档 For V5

JsonHelper.OutResult Method

Overload List

public static string OutResult(Boolean,Object);

a easy method for you to return a json 返回Json格式的结果信息

public static string OutResult(Boolean,String);

public static string OutResult(Boolean,String,Boolean);

public static string OutResult(String,Object,params Object[]);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.OutResult Method (Boolean, Object)

public static string OutResult(
Boolean result,
Object msgObj
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.OutResult Overload List


JsonHelper.OutResult Method (Boolean, String)

a easy method for you to return a json

返回Json格式的结果信息

public static string OutResult(
Boolean result,
String msg
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.OutResult Overload List


JsonHelper.OutResult Method (Boolean, String, Boolean)

public static string OutResult(
Boolean result,
String msg,
Boolean noQuates
);

Parameters

Boolean
String
Boolean
no ""

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.OutResult Overload List


JsonHelper.OutResult Method (String, Object, Object[])

public static string OutResult(
String name,
Object value,
params Object[] nameValues
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.OutResult Overload List


JsonHelper.Split Method

split json to dicationary

将Json分隔成键值对。

public static Dictionary<TKey,TValue> Split(
String json
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.SplitArray Method

split json to dicationary array

将Json 数组分隔成多个键值对。

public static List<T> SplitArray(
String jsonArray
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


ToEntity Method

CYQ.Data API 帮助文档 For V5

JsonHelper.ToEntity Method

Overload List

public static T ToEntity<T>(String); where T: class

Convert json to Entity 将Json转换为实体

public static T ToEntity<T>(String,EscapeOp); where T: class

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.ToEntity Method (String)

public static T <T>ToEntity(
String json
); where T: class

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToEntity Overload List


JsonHelper.ToEntity Method (String, EscapeOp)

Convert json to Entity

将Json转换为实体

public static T <T>ToEntity(
String json,
EscapeOp op
); where T: class

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToEntity Overload List


ToJson Method

CYQ.Data API 帮助文档 For V5

JsonHelper.ToJson Method

Convert object to json

将一个对象（实体，泛型List，字典Dictionary）转成Json

Overload List

Convert object to json 将一个对象（实体，泛型List，字典Dictionary）转成Json

public static string ToJson(Object);

public static string ToJson(Object,Boolean);

public static string ToJson(Object,Boolean,RowOp);

public static string ToJson(Object,Boolean,RowOp,EscapeOp);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.ToJson Method (Object)

Convert object to json

将一个对象（实体，泛型List，字典Dictionary）转成Json

public static string ToJson(
Object obj
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToJson Overload List


JsonHelper.ToJson Method (Object, Boolean)

public static string ToJson(
Object obj,
Boolean isConvertNameToLower
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToJson Overload List


JsonHelper.ToJson Method (Object, Boolean, RowOp)

public static string ToJson(
Object obj,
Boolean isConvertNameToLower,
RowOp rowOp
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToJson Overload List


JsonHelper.ToJson Method (Object, Boolean, RowOp, EscapeOp)

public static string ToJson(
Object obj,
Boolean isConvertNameToLower,
RowOp rowOp,
EscapeOp escapeOp
);

Parameters

Object
Boolean
RowOp
EscapeOp

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToJson Overload List


ToList Method

CYQ.Data API 帮助文档 For V5

JsonHelper.ToList Method

Overload List

public static List<T> ToList<T>(String); where T: class

Convert json to Entity List 将Json转换为实体列表

public static List<T> ToList<T>(String,EscapeOp); where T: class

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.ToList Method (String)

public static List<T> <T>ToList(
String json
); where T: class

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToList Overload List


JsonHelper.ToList Method (String, EscapeOp)

Convert json to Entity List

将Json转换为实体列表

public static List<T> <T>ToList(
String json,
EscapeOp op
); where T: class

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToList Overload List


ToString Method

CYQ.Data API 帮助文档 For V5

JsonHelper.ToString Method

out json result

输出Json字符串

Overload List

out json result 输出Json字符串

public override string ToString();

public string ToString(Boolean);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.ToString Method ()

out json result

输出Json字符串

public override string ToString();

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToString Overload List


JsonHelper.ToString Method (Boolean)

public string ToString(
Boolean arrayEnd
);

Parameters

Boolean
end with [] ?

Return Value

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToString Overload List


ToXml Method

CYQ.Data API 帮助文档 For V5

JsonHelper.ToXml Method

Convert json to Xml

将一个Json转成Xml

Overload List

Convert json to Xml 将一个Json转成Xml

public static string ToXml(String);

public static string ToXml(String,Boolean);

public static string ToXml(String,Boolean,EscapeOp);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


JsonHelper.ToXml Method (String)

Convert json to Xml

将一个Json转成Xml

public static string ToXml(
String json
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToXml Overload List


JsonHelper.ToXml Method (String, Boolean)

public static string ToXml(
String json,
Boolean isWithAttr
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToXml Overload List


JsonHelper.ToXml Method (String, Boolean, EscapeOp)

public static string ToXml(
String json,
Boolean isWithAttr,
EscapeOp op
);

Parameters

String
Boolean
default value is true

是否转成属性，默认true

EscapeOp

See Also

JsonHelper Class | CYQ.Data.Tool Namespace | JsonHelper.ToXml Overload List


JsonHelper.UnEscape Method

解码替换数据转义符

public static string UnEscape(
String result,
EscapeOp op
);

See Also

JsonHelper Class | CYQ.Data.Tool Namespace


MDictionary<K,V> Class

线程安全字典类

For a list of all members of this type, see MDictionary<K,V> Members.

System.Object
Dictionary<K,V>
MDictionary<K,V>

public class MDictionary<K,V> : Dictionary<K,V>

Requirements

Namespace: CYQ.Data.Tool

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

MDictionary<K,V> Members | CYQ.Data.Tool Namespace


MDictionary<K,V> Members

MDictionary<K,V> overview

Public Instance Constructors

MDictionary<K,V> Overloaded. Initializes a new instance of the MDictionary<K,V> class.

Public Instance Properties

Item Overloaded. 索引取值

Public Instance Methods

Add |
Clear |
ContainsKey |
Get | 当Key为int时，通过此方法取值
Remove |
Set | 当Key为int时，通过此方法取值

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace


MDictionary<K,V> Constructor

Overload List

public MDictionary<K,V>();

public MDictionary<K,V>(IEqualityComparer<K>);

public MDictionary<K,V>(Int32);

public MDictionary<K,V>(Int32,IEqualityComparer<K>);

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace


MDictionary<K,V> Constructor ()

public MDictionary<K,V>();

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace | MDictionary<K,V> Constructor Overload List


MDictionary<K,V> Constructor (IEqualityComparer`1)

public MDictionary<K,V>(
IEqualityComparer<K> comparer
);

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace | MDictionary<K,V> Constructor Overload List


MDictionary<K,V> Constructor (Int32)

public MDictionary<K,V>(
Int32 capacity
);

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace | MDictionary<K,V> Constructor Overload List


MDictionary<K,V> Constructor (Int32, IEqualityComparer`1)

public MDictionary<K,V>(
Int32 capacity,
IEqualityComparer<K> comparer
);

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace | MDictionary<K,V> Constructor Overload List


MDictionary<K,V> Properties

The properties of the MDictionary<K,V> class are listed below. For a complete list of MDictionary<K,V> class members, see the MDictionary<K,V> Members topic.

Public Instance Properties

Item Overloaded. 索引取值

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace


MDictionary<K,V>.V Property

CYQ.Data API 帮助文档 For V5

MDictionary<K,V>.MDictionary<K,V>.V Property

索引取值

Overload List

索引取值

new public this[MDictionary<K,V>.K] {get; set;}

通过index索引取值

public this[Int32] {get; set;}

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace


Item Property (`0)

CYQ.Data API 帮助文档 For V5

MDictionary<K,V>.Item Property (`0)

索引取值

new public this[
MDictionary<K,V>.K key
] {get; set;}

Parameters

MDictionary<K,V>.K

Implements

IReadOnlyDictionary`2.

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace | MDictionary<K,V>.MDictionary<K,V>.V Overload List


Item Property (Int32)

CYQ.Data API 帮助文档 For V5

MDictionary<K,V>.Item Property (Int32)

通过index索引取值

public this[
Int32 index
] {get; set;}

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace | MDictionary<K,V>.MDictionary<K,V>.V Overload List


MDictionary<K,V> Methods

The methods of the MDictionary<K,V> class are listed below. For a complete list of MDictionary<K,V> class members, see the MDictionary<K,V> Members topic.

Public Instance Methods

Add |
Clear |
ContainsKey |
Get | 当Key为int时，通过此方法取值
Remove |
Set | 当Key为int时，通过此方法取值

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace


MDictionary<K,V>.Add Method

new public void Add(
MDictionary<K,V>.K key,
MDictionary<K,V>.V value
);

Implements

IDictionary<K,V>.

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace


MDictionary<K,V>.Clear Method

new public void Clear();

Implements

IDictionary.

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace


MDictionary<K,V>.ContainsKey Method

new public bool ContainsKey(
MDictionary<K,V>.K key
);

Implements

IReadOnlyDictionary<K,V>.

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace


MDictionary<K,V>.Get Method

当Key为int时，通过此方法取值

public V Get(
MDictionary<K,V>.K key
);

Parameters

MDictionary<K,V>.K

Return Value

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace


MDictionary<K,V>.Remove Method

new public bool Remove(
MDictionary<K,V>.K key
);

Implements

IDictionary<K,V>.

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace


MDictionary<K,V>.Set Method

当Key为int时，通过此方法取值

public void Set(
MDictionary<K,V>.K key,
MDictionary<K,V>.V value
);

See Also

MDictionary<K,V> Class | CYQ.Data.Tool Namespace


ReflectTool Class

反射工具（带缓存）

For a list of all members of this type, see ReflectTool Members.

System.Object
ReflectTool

public static class ReflectTool

Requirements

Namespace: CYQ.Data.Tool

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

ReflectTool Members | CYQ.Data.Tool Namespace


ReflectTool Members

ReflectTool overview

Public Static Methods

GetGenericArgumentLength | Overloaded. 获取泛型参数的长度
GetPropertys | 获得反射属性（内部有缓存）
GetSystemType | 获取系统类型，若是Nullable类型，则转为基础类型。

See Also

ReflectTool Class | CYQ.Data.Tool Namespace


ReflectTool Methods

The methods of the ReflectTool class are listed below. For a complete list of ReflectTool class members, see the ReflectTool Members topic.

Public Static Methods

GetGenericArgumentLength | Overloaded. 获取泛型参数的长度
GetPropertys | 获得反射属性（内部有缓存）
GetSystemType | 获取系统类型，若是Nullable类型，则转为基础类型。

See Also

ReflectTool Class | CYQ.Data.Tool Namespace


GetGenericArgumentLength Method

CYQ.Data API 帮助文档 For V5

ReflectTool.GetGenericArgumentLength Method

获取泛型参数的长度

Overload List

获取泛型参数的长度

public static int GetGenericArgumentLength(ref Type&);

获取泛型参数的长度（和类型）

public static int GetGenericArgumentLength(ref Type&,out Type[]&);

See Also

ReflectTool Class | CYQ.Data.Tool Namespace


ReflectTool.GetGenericArgumentLength Method (Type@)

获取泛型参数的长度

public static int GetGenericArgumentLength(
ref Type& t
);

See Also

ReflectTool Class | CYQ.Data.Tool Namespace | ReflectTool.GetGenericArgumentLength Overload List


ReflectTool.GetGenericArgumentLength Method (Type@, Type[]@)

获取泛型参数的长度（和类型）

public static int GetGenericArgumentLength(
ref Type& t,
out Type[]& argTypes
);

See Also

ReflectTool Class | CYQ.Data.Tool Namespace | ReflectTool.GetGenericArgumentLength Overload List


ReflectTool.GetPropertys Method

获得反射属性（内部有缓存）

public static List<T> GetPropertys(
Type t
);

See Also

ReflectTool Class | CYQ.Data.Tool Namespace


ReflectTool.GetSystemType Method

获取系统类型，若是Nullable类型，则转为基础类型。

public static SysType GetSystemType(
ref Type& t
);

See Also

ReflectTool Class | CYQ.Data.Tool Namespace


SysType Enumeration

转实体所用参数

public enum SysType

Members

Member Name | Description
Base | 基础类型
Enum | 枚举类型
Array | 数组
Collection | 集合类型
Generic | 泛型
Custom | 自定义类

Requirements

Namespace: CYQ.Data.Tool

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Tool Namespace


ThreadBreak Class

在ASP.NET中使用多线程时，为了避开升级dll时产生多个线程互相影响，使用此类可以通过外置文件进行跳出。

For a list of all members of this type, see ThreadBreak Members.

System.Object
ThreadBreak

public class ThreadBreak

Requirements

Namespace: CYQ.Data.Tool

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

ThreadBreak Members | CYQ.Data.Tool Namespace


ThreadBreak Members

ThreadBreak overview

Public Static Methods

AddGlobalThread Overloaded. 添加全局线程[通常该线程是个死循环，定时处理事情]

Public Instance Constructors

ThreadBreak Constructor 提示：AppConfig中需要配置ThreadBreakPath项的路径

Public Instance Methods

NeedToBreak 是否需要退出。

See Also

ThreadBreak Class | CYQ.Data.Tool Namespace


ThreadBreak Constructor

提示：AppConfig中需要配置ThreadBreakPath项的路径

public ThreadBreak(
String threadName,
Object threadID
);

Parameters

String
Object

See Also

ThreadBreak Class | CYQ.Data.Tool Namespace


ThreadBreak Methods

The methods of the ThreadBreak class are listed below. For a complete list of ThreadBreak class members, see the ThreadBreak Members topic.

Public Static Methods

AddGlobalThread Overloaded. 添加全局线程[通常该线程是个死循环，定时处理事情]

Public Instance Methods

NeedToBreak 是否需要退出。

See Also

ThreadBreak Class | CYQ.Data.Tool Namespace


AddGlobalThread Method

CYQ.Data API 帮助文档 For V5

ThreadBreak.AddGlobalThread Method

添加全局线程[通常该线程是个死循环，定时处理事情]

Overload List

添加全局线程[通常该线程是个死循环，定时处理事情]

public static void AddGlobalThread(ParameterizedThreadStart);

public static void AddGlobalThread(ParameterizedThreadStart,Object);

See Also

ThreadBreak Class | CYQ.Data.Tool Namespace


ThreadBreak.AddGlobalThread Method (ParameterizedThreadStart)

添加全局线程[通常该线程是个死循环，定时处理事情]

public static void AddGlobalThread(
ParameterizedThreadStart start
);

See Also

ThreadBreak Class | CYQ.Data.Tool Namespace | ThreadBreak.AddGlobalThread Overload List


ThreadBreak.AddGlobalThread Method (ParameterizedThreadStart, Object)

public static void AddGlobalThread(
ParameterizedThreadStart start,
Object para
);

See Also

ThreadBreak Class | CYQ.Data.Tool Namespace | ThreadBreak.AddGlobalThread Overload List


ThreadBreak.NeedToBreak Method

是否需要退出。

public bool NeedToBreak();

Return Value

See Also

ThreadBreak Class | CYQ.Data.Tool Namespace


CYQ.Data.UI

CYQ.Data API 帮助文档 For V5

CYQ.Data.UI Namespace

Namespace hierarchy

Classes

Class | Description
MActionUI | UI 对外接口
RegisterUI | 第三方控件UI注册

Interfaces

Interface | Description
IUIValue | 对于自定义控件，只要继承此接口，即可以使用GetFrom与SetTo方法


IUIValue Interface

对于自定义控件，只要继承此接口，即可以使用GetFrom与SetTo方法

For a list of all members of this type, see IUIValue Members.

public interface IUIValue

Requirements

Namespace: CYQ.Data.UI

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

IUIValue Members | CYQ.Data.UI Namespace


IUIValue Members

IUIValue overview

Public Instance Properties

MEnabled | 控件的启用状态
MID | 控件的名称（Name）或ID
MValue | 控件的值

See Also

IUIValue Interface | CYQ.Data.UI Namespace


IUIValue Properties

The properties of the IUIValue interface are listed below. For a complete list of IUIValue interface members, see the IUIValue Members topic.

Public Instance Properties

MEnabled | 控件的启用状态
MID | 控件的名称（Name）或ID
MValue | 控件的值

See Also

IUIValue Interface | CYQ.Data.UI Namespace


MEnabled Property

CYQ.Data API 帮助文档 For V5

IUIValue.MEnabled Property

控件的启用状态

MEnabled {get; set;}

See Also

IUIValue Interface | CYQ.Data.UI Namespace


MID Property

CYQ.Data API 帮助文档 For V5

IUIValue.MID Property

控件的名称（Name）或ID

MID {get;}

See Also

IUIValue Interface | CYQ.Data.UI Namespace


MValue Property

CYQ.Data API 帮助文档 For V5

IUIValue.MValue Property

控件的值

MValue {get; set;}

See Also

IUIValue Interface | CYQ.Data.UI Namespace


MActionUI Class

UI 对外接口

For a list of all members of this type, see MActionUI Members.

System.Object
MActionUI

public class MActionUI :

Requirements

Namespace: CYQ.Data.UI

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

MActionUI Members | CYQ.Data.UI Namespace


MActionUI Members

MActionUI overview

Public Instance Methods

Bind | Overloaded. 绑定DrowDownList等列表控件
Dispose |
GetFrom | Overloaded. 从控件中取值
SetAutoParentControl | （Win或WPF）自动获取值父控件设置,可传多个父控件[至少1个]
SetAutoPrefix | 自动获取值前缀设置,可传多个前缀[至少1个]
SetTo | Overloaded. 将值赋给控件
SetToAll | 批量对所有控件自动赋值【默认前缀为（txt,ddl,chb）,可通过调用SetAutoPrefix调整】

See Also

MActionUI Class | CYQ.Data.UI Namespace


MActionUI Methods

The methods of the MActionUI class are listed below. For a complete list of MActionUI class members, see the MActionUI Members topic.

Public Instance Methods

Bind | Overloaded. 绑定DrowDownList等列表控件
Dispose |
GetFrom | Overloaded. 从控件中取值
SetAutoParentControl | （Win或WPF）自动获取值父控件设置,可传多个父控件[至少1个]
SetAutoPrefix | 自动获取值前缀设置,可传多个前缀[至少1个]
SetTo | Overloaded. 将值赋给控件
SetToAll | 批量对所有控件自动赋值【默认前缀为（txt,ddl,chb）,可通过调用SetAutoPrefix调整】

See Also

MActionUI Class | CYQ.Data.UI Namespace


Bind Method

CYQ.Data API 帮助文档 For V5

MActionUI.Bind Method

绑定DrowDownList等列表控件

Overload List

绑定DrowDownList等列表控件

public void Bind(Object);

绑定下拉等列表,控件需要继承自：ListControl。

public void Bind(Object,Object,Object,Object);

绑定DrowDownList等列表控件

public void Bind(Object,String);

See Also

MActionUI Class | CYQ.Data.UI Namespace


MActionUI.Bind Method (Object)

绑定DrowDownList等列表控件

public void Bind(
Object control
);

Parameters

Object
（下拉）列表控件

Return Value

See Also

MActionUI Class | CYQ.Data.UI Namespace | MActionUI.Bind Overload List


MActionUI.Bind Method (Object, Object, Object, Object)

绑定下拉等列表,控件需要继承自：ListControl。

public void Bind(
Object control,
Object where,
Object text,
Object value
);

Parameters

Object
DropDown/CheckBoxList/RadioButtonList等
Object
对表的数据进行过滤如:"ID>15 and Url='cyqdata.com'"
Object
绑定时显示的字段名[默认字段名取自控件的ID(去掉前三个字母前缀)]
Object
绑定时显示字段对应的值[默认值的字段名为:ID]

See Also

MActionUI Class | CYQ.Data.UI Namespace | MActionUI.Bind Overload List


MActionUI.Bind Method (Object, String)

绑定DrowDownList等列表控件

public void Bind(
Object control,
String where
);

See Also

MActionUI Class | CYQ.Data.UI Namespace | MActionUI.Bind Overload List


MActionUI.Dispose Method

public void Dispose();

Implements

IDisposable.

See Also

MActionUI Class | CYQ.Data.UI Namespace


GetFrom Method

CYQ.Data API 帮助文档 For V5

MActionUI.GetFrom Method

从控件中取值

Overload List

从控件中取值

public void GetFrom(Object);

public void GetFrom(Object,String);

public void GetFrom(Object,String,Object);

See Also

MActionUI Class | CYQ.Data.UI Namespace


MActionUI.GetFrom Method (Object)

从控件中取值

public void GetFrom(
Object control
);

Parameters

Object
控件对象

Example

示例：action.UI.GetFrom(txtUserName);//获取TextBox默认Text属性的值

See Also

MActionUI Class | CYQ.Data.UI Namespace | MActionUI.GetFrom Overload List


MActionUI.GetFrom Method (Object, String)

public void GetFrom(
Object control,
String controlPropName
);

Parameters

Object
String
从指定的属性里取值

See Also

MActionUI Class | CYQ.Data.UI Namespace | MActionUI.GetFrom Overload List


MActionUI.GetFrom Method (Object, String, Object)

public void GetFrom(
Object control,
String controlPropName,
Object defaultValue
);

Parameters

Object
String
Object
若控件无值，则取此默认值

See Also

MActionUI Class | CYQ.Data.UI Namespace | MActionUI.GetFrom Overload List


MActionUI.SetAutoParentControl Method

（Win或WPF）自动获取值父控件设置,可传多个父控件[至少1个]

public void SetAutoParentControl(
Object parent,
params Object[] otherParent
);

Parameters

Object
第一个父控件名称[必须，可传：this]
Object[]
后面N个[可选]

See Also

MActionUI Class | CYQ.Data.UI Namespace


MActionUI.SetAutoPrefix Method

自动获取值前缀设置,可传多个前缀[至少1个]

public void SetAutoPrefix(
String autoPrefix,
params String[] otherPrefix
);

Parameters

String
第一个前缀[必须]
String[]
后面N个前缀[可选]

See Also

MActionUI Class | CYQ.Data.UI Namespace


SetTo Method

CYQ.Data API 帮助文档 For V5

MActionUI.SetTo Method

将值赋给控件

Overload List

将值赋给控件

public void SetTo(Object);

public void SetTo(Object,String);

public void SetTo(Object,String,Boolean);

See Also

MActionUI Class | CYQ.Data.UI Namespace


MActionUI.SetTo Method (Object)

将值赋给控件

public void SetTo(
Object control
);

Parameters

Object
控件对象

Example

示例：action.UI.SetTo(txtUserName);//同于：txtUserName.Text=action.Get<string>(Users.UserName);

See Also

MActionUI Class | CYQ.Data.UI Namespace | MActionUI.SetTo Overload List


MActionUI.SetTo Method (Object, String)

public void SetTo(
Object control,
String controlPropName
);

Parameters

Object
String
指定对某个属性赋值

See Also

MActionUI Class | CYQ.Data.UI Namespace | MActionUI.SetTo Overload List


MActionUI.SetTo Method (Object, String, Boolean)

public void SetTo(
Object control,
String controlPropName,
Boolean isControlEnabled
);

Parameters

Object
String
Boolean
设置控件是否可用

See Also

MActionUI Class | CYQ.Data.UI Namespace | MActionUI.SetTo Overload List


MActionUI.SetToAll Method

批量对所有控件自动赋值【默认前缀为（txt,ddl,chb）,可通过调用SetAutoPrefix调整】

public void SetToAll(
Object parentControl,
params Object[] otherParentControls
);

Parameters

Object
父控件（可设置：this）
Object[]
可选（其它的父控件）

Example

action.SetAutoPrefix("txt","ddl");//设置控件的前缀
action.UI.SetToAll(this);

See Also

MActionUI Class | CYQ.Data.UI Namespace


RegisterUI Class

第三方控件UI注册

For a list of all members of this type, see RegisterUI Members.

System.Object
RegisterUI

public static class RegisterUI

Requirements

Namespace: CYQ.Data.UI

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

RegisterUI Members | CYQ.Data.UI Namespace


RegisterUI Members

RegisterUI overview

Public Static Methods

Add | 添加要注册的第三方控件名称。
Clear | 清除UI注册

See Also

RegisterUI Class | CYQ.Data.UI Namespace


RegisterUI Methods

The methods of the RegisterUI class are listed below. For a complete list of RegisterUI class members, see the RegisterUI Members topic.

Public Static Methods

Add | 添加要注册的第三方控件名称。
Clear | 清除UI注册

See Also

RegisterUI Class | CYQ.Data.UI Namespace


RegisterUI.Add Method

添加要注册的第三方控件名称。

public static void Add(
String controlClassName,
String propertyName
);

Parameters

String
控件类名，如：TextBox
String
控件的自动取值或赋值属性名称，如：Text

See Also

RegisterUI Class | CYQ.Data.UI Namespace


RegisterUI.Clear Method

清除UI注册

public static void Clear();

See Also

RegisterUI Class | CYQ.Data.UI Namespace


CYQ.Data.Xml

CYQ.Data API 帮助文档 For V5

CYQ.Data.Xml Namespace

Namespace hierarchy

Classes

Class | Description
MutilLanguage | 多语言操作类
Rss | Rss操作类
RssChannel | RSS 频道
RssImage | 图片项
RssItem | RSS项
ValueReplace | XHtmlAction 使用时的值替换
XHtmlAction | Xml/Html操作类
XHtmlBase | 操作Xml及XHtml的基类

Delegates

Delegate | Description
Rss.SetForeachEventHandler |
XHtmlAction.SetForeachEventHandler |

Enumerations

Enumeration | Description
LanguageKey | 语言种类
RssItemName | RSS 项枚举
SetType | 设置操作的节点属性类型
XmlCacheLevel | Xml|XHtml 加载后缓存级别


LanguageKey Enumeration

语言种类

public enum LanguageKey

Members

Member Name | Description
None | 未设置状态
Chinese | 中文
English | 英文
French | 法语
German | 德语
Korean | 韩语
Japanese | 日语
Hindi | 印地语
Russian | 俄语
Italian | 意大利语
Custom | 自定义语言

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Xml Namespace


MutilLanguage Class

多语言操作类

For a list of all members of this type, see MutilLanguage Members.

System.Object
MutilLanguage

public class MutilLanguage :

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

MutilLanguage Members | CYQ.Data.Xml Namespace


MutilLanguage Members

MutilLanguage overview

Public Static Methods

GetKey | 获取LanguageKey数字对应的枚举名称
GetValue | 获取LanguageKey枚举对应的数字
SetLanguageCookie |

Public Instance Constructors

MutilLanguage Overloaded. Initializes a new instance of the MutilLanguage class.

Public Instance Properties

DefaultLanKey | 获取系统默认的语言（取值顺序：AppConfig.XHtml.SysLangKey - > 浏览器语言 -》 默认中文）
FilePath | 获取加载的Xml语言文件的完整（路径）名称
LanKey | 获取或设置当前语言类型（如果有设置语言Cookie，则初始化时从Cookie恢复）

Public Instance Methods

Dispose |
Get | Overloaded. 获取多语言节点值
SetToCookie | Overloaded. 设置语言类型到Cookie中

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


MutilLanguage Constructor

实例化

Overload List

实例化

public MutilLanguage(String);

实例化

public MutilLanguage(String,Boolean);

实例化

public MutilLanguage(String,Boolean,Boolean);

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


MutilLanguage Constructor (String, Boolean, Boolean)

实例化

public MutilLanguage(
String filePath,
Boolean isForHtml,
Boolean isInitValueFromCookie
);

Parameters

String
xml文件路径
Boolean
是否Html文件
Boolean
是获从Cookie初始化默认语言

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace | MutilLanguage Constructor Overload List


MutilLanguage Constructor (String, Boolean)

实例化

public MutilLanguage(
String filePath,
Boolean isForHtml
);

Parameters

String
xml文件路径
Boolean
是否Html文件

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace | MutilLanguage Constructor Overload List


MutilLanguage Constructor (String)

实例化

public MutilLanguage(
String filePath
);

Parameters

String
xml文件路径

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace | MutilLanguage Constructor Overload List


MutilLanguage Properties

The properties of the MutilLanguage class are listed below. For a complete list of MutilLanguage class members, see the MutilLanguage Members topic.

Public Instance Properties

DefaultLanKey | 获取系统默认的语言（取值顺序：AppConfig.XHtml.SysLangKey - > 浏览器语言 -》 默认中文）
FilePath | 获取加载的Xml语言文件的完整（路径）名称
LanKey | 获取或设置当前语言类型（如果有设置语言Cookie，则初始化时从Cookie恢复）

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


DefaultLanKey Property

CYQ.Data API 帮助文档 For V5

MutilLanguage.DefaultLanKey Property

获取系统默认的语言（取值顺序：AppConfig.XHtml.SysLangKey - > 浏览器语言 -》 默认中文）

public DefaultLanKey {get;}

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


FilePath Property

CYQ.Data API 帮助文档 For V5

MutilLanguage.FilePath Property

获取加载的Xml语言文件的完整（路径）名称

public FilePath {get;}

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


LanKey Property

CYQ.Data API 帮助文档 For V5

MutilLanguage.LanKey Property

获取或设置当前语言类型（如果有设置语言Cookie，则初始化时从Cookie恢复）

public LanKey {get; set;}

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


MutilLanguage Methods

The methods of the MutilLanguage class are listed below. For a complete list of MutilLanguage class members, see the MutilLanguage Members topic.

Public Static Methods

GetKey | 获取LanguageKey数字对应的枚举名称
GetValue | 获取LanguageKey枚举对应的数字
SetLanguageCookie |

Public Instance Methods

Dispose |
Get | Overloaded. 获取多语言节点值
SetToCookie | Overloaded. 设置语言类型到Cookie中

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


MutilLanguage.Dispose Method

public void Dispose();

Implements

IDisposable.

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


Get Method

CYQ.Data API 帮助文档 For V5

MutilLanguage.Get Method

获取多语言节点值

Overload List

获取多语言节点值

public string Get(Object);

获取多语言节点值

public string Get(Object,LanguageKey);

获取多语言节点值

public string Get(Object,Int32);

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


MutilLanguage.Get Method (Object)

获取多语言节点值

public string Get(
Object lanID
);

Parameters

Object
Xml节点ID

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace | MutilLanguage.Get Overload List


MutilLanguage.Get Method (Object, LanguageKey)

获取多语言节点值

public string Get(
Object lanID,
LanguageKey lanEnum
);

Parameters

Object
Xml节点ID
LanguageKey
获取的语言

Return Value

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace | MutilLanguage.Get Overload List


MutilLanguage.Get Method (Object, Int32)

获取多语言节点值

public string Get(
Object lanID,
Int32 lanKeyID
);

Parameters

Object
Xml节点ID
Int32
LanguageKey对应的数字

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace | MutilLanguage.Get Overload List


MutilLanguage.GetKey Method

获取LanguageKey数字对应的枚举名称

public static string GetKey(
Int32 value
);

Return Value

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


MutilLanguage.GetValue Method

获取LanguageKey枚举对应的数字

public static int GetValue(
String langKey
);

Parameters

String
LanguageKey枚举名称

Return Value

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


MutilLanguage.SetLanguageCookie Method

public static void SetLanguageCookie(
String lanKey
);

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


SetToCookie Method

CYQ.Data API 帮助文档 For V5

MutilLanguage.SetToCookie Method

设置语言类型到Cookie中

Overload List

设置语言类型到Cookie中

public void SetToCookie(LanguageKey);

设置语言类型到Cookie中

public void SetToCookie(String);

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace


MutilLanguage.SetToCookie Method (LanguageKey)

设置语言类型到Cookie中

public void SetToCookie(
LanguageKey lanKey
);

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace | MutilLanguage.SetToCookie Overload List


MutilLanguage.SetToCookie Method (String)

设置语言类型到Cookie中

public void SetToCookie(
String lanKey
);

See Also

MutilLanguage Class | CYQ.Data.Xml Namespace | MutilLanguage.SetToCookie Overload List


Rss Class

Rss操作类

For a list of all members of this type, see Rss Members.

System.Object
Rss

public class Rss

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

Rss Members | CYQ.Data.Xml Namespace


Rss Members

Rss overview

Public Instance Constructors

Rss Constructor

Public Instance Properties

Channel | RSS 频道（默认）
OutXml | 获取输出的RSS内容。

Public Instance Methods

AddItem | 添加RSS项（文章）
LoadData | 加载MDataTable,之后可调用SetMap进行字段映射
Set | 设置网站标题
SetImg | 设置图片（网站Logo）
SetMap | 设置与MDataTable间的字段映射

Public Instance Events

OnForeach LoadData（MDataTable）进行映射后，在格式化每一行数据时触发事件

See Also

Rss Class | CYQ.Data.Xml Namespace


Rss Constructor

public Rss();

See Also

Rss Class | CYQ.Data.Xml Namespace


Rss Properties

The properties of the Rss class are listed below. For a complete list of Rss class members, see the Rss Members topic.

Public Instance Properties

Channel | RSS 频道（默认）
OutXml | 获取输出的RSS内容。

See Also

Rss Class | CYQ.Data.Xml Namespace


Channel Property

CYQ.Data API 帮助文档 For V5

Rss.Channel Property

RSS 频道（默认）

public Channel {get;}

See Also

Rss Class | CYQ.Data.Xml Namespace


OutXml Property

CYQ.Data API 帮助文档 For V5

Rss.OutXml Property

获取输出的RSS内容。

public OutXml {get;}

See Also

Rss Class | CYQ.Data.Xml Namespace


Rss Methods

The methods of the Rss class are listed below. For a complete list of Rss class members, see the Rss Members topic.

Public Instance Methods

AddItem | 添加RSS项（文章）
LoadData | 加载MDataTable,之后可调用SetMap进行字段映射
Set | 设置网站标题
SetImg | 设置图片（网站Logo）
SetMap | 设置与MDataTable间的字段映射

See Also

Rss Class | CYQ.Data.Xml Namespace


Rss.AddItem Method

添加RSS项（文章）

public void AddItem(
String title,
String link,
String author,
String pubDate,
String description
);

Parameters

String
标题
String
链接
String
作者
String
发布日期
String
内容或摘要

See Also

Rss Class | CYQ.Data.Xml Namespace


Rss.LoadData Method

加载MDataTable,之后可调用SetMap进行字段映射

public void LoadData(
MDataTable table
);

Parameters

MDataTable

See Also

Rss Class | CYQ.Data.Xml Namespace


Rss.Set Method

设置网站标题

public void Set(
String title,
String link,
String description
);

Parameters

String
网站名称
String
网址
String
网站描述

See Also

Rss Class | CYQ.Data.Xml Namespace


Rss.SetImg Method

设置图片（网站Logo）

public void SetImg(
String url,
String title,
String link
);

Parameters

String
Logo网址
String
Logo标题
String
Logo点击时跳转链接

See Also

Rss Class | CYQ.Data.Xml Namespace


Rss.SetMap Method

设置与MDataTable间的字段映射

public void SetMap(
RssItemName itemName,
String formatText,
params Object[] tableColumnNames
);

Parameters

RssItemName
Rss名称
String
格式化，如“{0}.Name”，若无需要格式化，直接赋Null值
Object[]
同DataTable的字段名称

See Also

Rss Class | CYQ.Data.Xml Namespace


Rss Events

The events of the Rss class are listed below. For a complete list of Rss class members, see the Rss Members topic.

Public Instance Events

OnForeach LoadData（MDataTable）进行映射后，在格式化每一行数据时触发事件

See Also

Rss Class | CYQ.Data.Xml Namespace


Rss.Rss.SetForeachEventHandler Event

LoadData（MDataTable）进行映射后，在格式化每一行数据时触发事件

public event OnForeach;

See Also

Rss Class | CYQ.Data.Xml Namespace


Rss.SetForeachEventHandler Delegate

public delegate string Rss.SetForeachEventHandler(
String text,
MDictionary<K,V> values,
Int32 rowIndex
);

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Xml Namespace


RssChannel Class

RSS 频道

For a list of all members of this type, see RssChannel Members.

System.Object
RssChannel

public class RssChannel

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

RssChannel Members | CYQ.Data.Xml Namespace


RssChannel Members

RssChannel overview

Public Instance Constructors

RssChannel Constructor

Public Instance Properties

Category | 为 feed 定义所属的一个或多个种类
Cloud | 注册进程，以获得 feed 更新的立即通知
Copyright | 告知版权资料
Description | 描述频道
Docs | 规定指向当前 RSS 文件所用格式说明的 URL
Generator | 规定指向当前 RSS 文件所用格式说明的 URL
Items | 频道项
Language | 规定编写 feed 所用的语言
LastBuildDate | 定义 feed 内容的最后修改日期
Link | 定义指向频道的超链接
ManagingEditor | 定义 feed 内容编辑的电子邮件地址
PubDate | 为 feed 的内容定义最后发布日期
Rating | feed 的 PICS 级别
RssImage | 定义此 feed 的 图片Logo
SkipDays | 规定忽略 feed 更新的天
SkipHours | 规定忽略 feed 更新的小时
TextInput | 规定应当与 feed 一同显示的文本输入域
Title | 定义频道的标题
Ttl | 指定从 feed 源更新此 feed 之前，feed 可被缓存的分钟数
WebMaster | 定义此 feed 的 web 管理员的电子邮件地址

See Also

RssChannel Class | CYQ.Data.Xml Namespace


RssChannel Constructor

public RssChannel();

See Also

RssChannel Class | CYQ.Data.Xml Namespace


RssChannel Properties

The properties of the RssChannel class are listed below. For a complete list of RssChannel class members, see the RssChannel Members topic.

Public Instance Properties

Category | 为 feed 定义所属的一个或多个种类
Cloud | 注册进程，以获得 feed 更新的立即通知
Copyright | 告知版权资料
Description | 描述频道
Docs | 规定指向当前 RSS 文件所用格式说明的 URL
Generator | 规定指向当前 RSS 文件所用格式说明的 URL
Items | 频道项
Language | 规定编写 feed 所用的语言
LastBuildDate | 定义 feed 内容的最后修改日期
Link | 定义指向频道的超链接
ManagingEditor | 定义 feed 内容编辑的电子邮件地址
PubDate | 为 feed 的内容定义最后发布日期
Rating | feed 的 PICS 级别
RssImage | 定义此 feed 的 图片Logo
SkipDays | 规定忽略 feed 更新的天
SkipHours | 规定忽略 feed 更新的小时
TextInput | 规定应当与 feed 一同显示的文本输入域
Title | 定义频道的标题
Ttl | 指定从 feed 源更新此 feed 之前，feed 可被缓存的分钟数
WebMaster | 定义此 feed 的 web 管理员的电子邮件地址

See Also

RssChannel Class | CYQ.Data.Xml Namespace


Category Property

CYQ.Data API 帮助文档 For V5

RssChannel.Category Property

为 feed 定义所属的一个或多个种类

public Category {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


Cloud Property

CYQ.Data API 帮助文档 For V5

RssChannel.Cloud Property

注册进程，以获得 feed 更新的立即通知

public Cloud {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


Copyright Property

CYQ.Data API 帮助文档 For V5

RssChannel.Copyright Property

告知版权资料

public Copyright {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


Description Property

CYQ.Data API 帮助文档 For V5

RssChannel.Description Property

描述频道

public Description {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


Docs Property

CYQ.Data API 帮助文档 For V5

RssChannel.Docs Property

规定指向当前 RSS 文件所用格式说明的 URL

public Docs {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


Generator Property

CYQ.Data API 帮助文档 For V5

RssChannel.Generator Property

规定指向当前 RSS 文件所用格式说明的 URL

public Generator {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


Items Property

CYQ.Data API 帮助文档 For V5

RssChannel.Items Property

频道项

public Items {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


Language Property

CYQ.Data API 帮助文档 For V5

RssChannel.Language Property

规定编写 feed 所用的语言

public Language {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


LastBuildDate Property

CYQ.Data API 帮助文档 For V5

RssChannel.LastBuildDate Property

定义 feed 内容的最后修改日期

public LastBuildDate {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


Link Property

CYQ.Data API 帮助文档 For V5

RssChannel.Link Property

定义指向频道的超链接

public Link {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


ManagingEditor Property

CYQ.Data API 帮助文档 For V5

RssChannel.ManagingEditor Property

定义 feed 内容编辑的电子邮件地址

public ManagingEditor {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


PubDate Property

CYQ.Data API 帮助文档 For V5

RssChannel.PubDate Property

为 feed 的内容定义最后发布日期

public PubDate {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


Rating Property

CYQ.Data API 帮助文档 For V5

RssChannel.Rating Property

feed 的 PICS 级别

public Rating {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


RssImage Property

CYQ.Data API 帮助文档 For V5

RssChannel.RssImage Property

定义此 feed 的 图片Logo

public RssImage {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


SkipDays Property

CYQ.Data API 帮助文档 For V5

RssChannel.SkipDays Property

规定忽略 feed 更新的天

public SkipDays {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


SkipHours Property

CYQ.Data API 帮助文档 For V5

RssChannel.SkipHours Property

规定忽略 feed 更新的小时

public SkipHours {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


TextInput Property

CYQ.Data API 帮助文档 For V5

RssChannel.TextInput Property

规定应当与 feed 一同显示的文本输入域

public TextInput {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


Title Property

CYQ.Data API 帮助文档 For V5

RssChannel.Title Property

定义频道的标题

public Title {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


Ttl Property

CYQ.Data API 帮助文档 For V5

RssChannel.Ttl Property

指定从 feed 源更新此 feed 之前，feed 可被缓存的分钟数

public Ttl {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


WebMaster Property

CYQ.Data API 帮助文档 For V5

RssChannel.WebMaster Property

定义此 feed 的 web 管理员的电子邮件地址

public WebMaster {get; set;}

See Also

RssChannel Class | CYQ.Data.Xml Namespace


RssImage Class

图片项

For a list of all members of this type, see RssImage Members.

System.Object
RssImage

public class RssImage

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

RssImage Members | CYQ.Data.Xml Namespace


RssImage Members

RssImage overview

Public Instance Constructors

RssImage Constructor

Public Instance Properties

Description | 描述频道
Link | 提供图片的站点链接
Title | 图片标题
Url | 图片地址

See Also

RssImage Class | CYQ.Data.Xml Namespace


RssImage Constructor

public RssImage();

See Also

RssImage Class | CYQ.Data.Xml Namespace


RssImage Properties

The properties of the RssImage class are listed below. For a complete list of RssImage class members, see the RssImage Members topic.

Public Instance Properties

Description | 描述频道
Link | 提供图片的站点链接
Title | 图片标题
Url | 图片地址

See Also

RssImage Class | CYQ.Data.Xml Namespace


Description Property

CYQ.Data API 帮助文档 For V5

RssImage.Description Property

描述频道

public Description {get; set;}

See Also

RssImage Class | CYQ.Data.Xml Namespace


Link Property

CYQ.Data API 帮助文档 For V5

RssImage.Link Property

提供图片的站点链接

public Link {get; set;}

See Also

RssImage Class | CYQ.Data.Xml Namespace


Title Property

CYQ.Data API 帮助文档 For V5

RssImage.Title Property

图片标题

public Title {get; set;}

See Also

RssImage Class | CYQ.Data.Xml Namespace


Url Property

CYQ.Data API 帮助文档 For V5

RssImage.Url Property

图片地址

public Url {get; set;}

See Also

RssImage Class | CYQ.Data.Xml Namespace


RssItem Class

RSS项

For a list of all members of this type, see RssItem Members.

System.Object
RssItem

public class RssItem

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

RssItem Members | CYQ.Data.Xml Namespace


RssItem Members

RssItem overview

Public Instance Constructors

RssItem Constructor

Public Instance Properties

Author | 规定项目作者的电子邮件地址
Category | 为 feed 定义所属的一个或多个种类
Comments | 允许项目连接到有关此项目的注释（文件）
Description | 描述频道
Enclosure | 允许将一个媒体文件导入一个项中
Guid | 为 项目定义一个唯一的标识符
Link | 定义指向频道的超链接
PubDate | 定义此项目的最后发布日期
Source | 为此项目指定一个第三方来源
Title | 定义频道的标题

See Also

RssItem Class | CYQ.Data.Xml Namespace


RssItem Constructor

public RssItem();

See Also

RssItem Class | CYQ.Data.Xml Namespace


RssItem Properties

The properties of the RssItem class are listed below. For a complete list of RssItem class members, see the RssItem Members topic.

Public Instance Properties

Author | 规定项目作者的电子邮件地址
Category | 为 feed 定义所属的一个或多个种类
Comments | 允许项目连接到有关此项目的注释（文件）
Description | 描述频道
Enclosure | 允许将一个媒体文件导入一个项中
Guid | 为 项目定义一个唯一的标识符
Link | 定义指向频道的超链接
PubDate | 定义此项目的最后发布日期
Source | 为此项目指定一个第三方来源
Title | 定义频道的标题

See Also

RssItem Class | CYQ.Data.Xml Namespace


Author Property

CYQ.Data API 帮助文档 For V5

RssItem.Author Property

规定项目作者的电子邮件地址

public Author {get; set;}

See Also

RssItem Class | CYQ.Data.Xml Namespace


Category Property

CYQ.Data API 帮助文档 For V5

RssItem.Category Property

为 feed 定义所属的一个或多个种类

public Category {get; set;}

See Also

RssItem Class | CYQ.Data.Xml Namespace


Comments Property

CYQ.Data API 帮助文档 For V5

RssItem.Comments Property

允许项目连接到有关此项目的注释（文件）

public Comments {get; set;}

See Also

RssItem Class | CYQ.Data.Xml Namespace


Description Property

CYQ.Data API 帮助文档 For V5

RssItem.Description Property

描述频道

public Description {get; set;}

See Also

RssItem Class | CYQ.Data.Xml Namespace


Enclosure Property

CYQ.Data API 帮助文档 For V5

RssItem.Enclosure Property

允许将一个媒体文件导入一个项中

public Enclosure {get; set;}

See Also

RssItem Class | CYQ.Data.Xml Namespace


Guid Property

CYQ.Data API 帮助文档 For V5

RssItem.Guid Property

为 项目定义一个唯一的标识符

public Guid {get; set;}

See Also

RssItem Class | CYQ.Data.Xml Namespace


Link Property

CYQ.Data API 帮助文档 For V5

RssItem.Link Property

定义指向频道的超链接

public Link {get; set;}

See Also

RssItem Class | CYQ.Data.Xml Namespace


PubDate Property

CYQ.Data API 帮助文档 For V5

RssItem.PubDate Property

定义此项目的最后发布日期

public PubDate {get; set;}

See Also

RssItem Class | CYQ.Data.Xml Namespace


Source Property

CYQ.Data API 帮助文档 For V5

RssItem.Source Property

为此项目指定一个第三方来源

public Source {get; set;}

See Also

RssItem Class | CYQ.Data.Xml Namespace


Title Property

CYQ.Data API 帮助文档 For V5

RssItem.Title Property

定义频道的标题

public Title {get; set;}

See Also

RssItem Class | CYQ.Data.Xml Namespace


RssItemName Enumeration

RSS 项枚举

public enum RssItemName

Members

Member Name | Description
Title |
Link |
Description |
Category |
Author |
Comments |
Enclosure |
Guid |
PubDate |
Source |

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Xml Namespace


SetType Enumeration

设置操作的节点属性类型

public enum SetType

Members

Member Name | Description
InnerXml |
InnerText |
Value |
Href |
Src |
Class |
A | A链接标识，最多可赋4个值为:InnerXml,href,title,target
Img |
Input |
Select |
Checked |
Disabled |
ID |
Name |
Visible |
Script |
Meta |
Title |
Link |
Style |
Custom | 自定义，以“属性,值,属性,值”这样的对应设置，无个数限制。

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Xml Namespace


ValueReplace Class

XHtmlAction 使用时的值替换

For a list of all members of this type, see ValueReplace Members.

System.Object
ValueReplace

public class ValueReplace

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

ValueReplace Members | CYQ.Data.Xml Namespace


ValueReplace Members

ValueReplace overview

Public Static Fields

LangSplit | MutilLanguage 类 Get方法取到值后，按[#langsplit]分隔并按当前语言返回分隔符前面或后面值
New | LoadData加载数据后，数据的值 ：[#new]
Source | Set 方法中 原节点的值 ：[#source]

Public Instance Constructors

ValueReplace Constructor

See Also

ValueReplace Class | CYQ.Data.Xml Namespace


ValueReplace Constructor

public ValueReplace();

See Also

ValueReplace Class | CYQ.Data.Xml Namespace


ValueReplace Fields

The fields of the ValueReplace class are listed below. For a complete list of ValueReplace class members, see the ValueReplace Members topic.

Public Static Fields

LangSplit | MutilLanguage 类 Get方法取到值后，按[#langsplit]分隔并按当前语言返回分隔符前面或后面值
New | LoadData加载数据后，数据的值 ：[#new]
Source | Set 方法中 原节点的值 ：[#source]

See Also

ValueReplace Class | CYQ.Data.Xml Namespace


ValueReplace.LangSplit Field

MutilLanguage 类 Get方法取到值后，按[#langsplit]分隔并按当前语言返回分隔符前面或后面值

public const String LangSplit = "[#langsplit]";

See Also

ValueReplace Class | CYQ.Data.Xml Namespace


ValueReplace.New Field

LoadData加载数据后，数据的值 ：[#new]

public const String New = "[#new]";

See Also

ValueReplace Class | CYQ.Data.Xml Namespace


ValueReplace.Source Field

Set 方法中 原节点的值 ：[#source]

public const String Source = "[#source]";

See Also

ValueReplace Class | CYQ.Data.Xml Namespace


XHtmlAction Class

Xml/Html操作类

For a list of all members of this type, see XHtmlAction Members.

System.Object
XHtmlBase
XHtmlAction

public class XHtmlAction : XHtmlBase

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

XHtmlAction Members | CYQ.Data.Xml Namespace


XHtmlAction Members

XHtmlAction overview

Public Instance Constructors

XHtmlAction Overloaded. Initializes a new instance of the XHtmlAction class.

Public Instance Fields

IsUseLangSplit | 是否开始自定义语言分隔(分隔符号为：[#langsplit])
KeyValue | 用于替换占位符的数据。

Public Instance Properties

IsCurrentLang | 当前请求是否用户当前设置的语言
OutXml |

Public Instance Methods

AppendNode | Overloaded.
Clear | 保留节点,但清除节点所内容/属性
Contains | Overloaded.
CreateNode |
CreateNodeTo |
Dispose |
Get | Overloaded. GetByID or GetByName
GetAttrValue | Overloaded.
GetByID | Overloaded.
GetByName | Overloaded.
GetList | Overloaded.
HasAttr | Overloaded.
InsertAfter | 节点之后插入[支持两文档之间的插入]
InsertBefore | 节点之前插入[支持两文档之间的插入]
InterChange | 两个节点交换位置
LoadData | Overloaded. 加载MDataTable的多行数据
Remove | Overloaded.
RemoveAllChild | Overloaded.
RemoveAttr | Overloaded.
RemoveAttrList | Overloaded. 移除多个属性
RemoveChild | Overloaded. 移除子节点
RemoveCommentNode | Overloaded. 移除注释节点
ReplaceNode | Overloaded.
Set | Overloaded. 为节点赋值[通常值是在values中赋值]
SetFor | Overloaded. 为节点设置值，通常在LoadData后使用。
SetForeach | Overloaded.
ToJson | Overloaded. 转Json

Public Instance Events

OnForeach 对于SetForeach函数调用的格式化事件

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction Constructor

默认构造函数[操作无名称空间的Xml]

Overload List

默认构造函数[操作无名称空间的Xml]

public XHtmlAction();

构造函数

public XHtmlAction(Boolean);

构造函数

public XHtmlAction(Boolean,Boolean);

构造函数

public XHtmlAction(String);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction Constructor ()

默认构造函数[操作无名称空间的Xml]

public XHtmlAction();

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction Constructor Overload List


XHtmlAction Constructor (Boolean)

构造函数

public XHtmlAction(
Boolean isForHtml
);

Parameters

Boolean
true时，将自动载入html的名称空间(http://www.w3.org/1999/xhtml)

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction Constructor Overload List


XHtmlAction Constructor (Boolean, Boolean)

构造函数

public XHtmlAction(
Boolean isForHtml,
Boolean isNoClone
);

Parameters

Boolean
true时，将自动载入html的名称空间(http://www.w3.org/1999/xhtml)
Boolean
true时文档应为只读，所获取是同一份文档引用；false时文档可写，每次获取会克隆一份文档返回。

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction Constructor Overload List


XHtmlAction Constructor (String)

构造函数

public XHtmlAction(
String nameSpaceUrl
);

Parameters

String
当Xml的名称空间[若有]

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction Constructor Overload List


XHtmlAction Fields

The fields of the XHtmlAction class are listed below. For a complete list of XHtmlAction class members, see the XHtmlAction Members topic.

Public Instance Fields

IsUseLangSplit | 是否开始自定义语言分隔(分隔符号为：[#langsplit])
KeyValue | 用于替换占位符的数据。

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.IsUseLangSplit Field

是否开始自定义语言分隔(分隔符号为：[#langsplit])

public Boolean IsUseLangSplit;

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.KeyValue Field

用于替换占位符的数据。

public MDictionary<K,V> KeyValue;

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction Properties

The properties of the XHtmlAction class are listed below. For a complete list of XHtmlAction class members, see the XHtmlAction Members topic.

Public Instance Properties

IsCurrentLang | 当前请求是否用户当前设置的语言
OutXml |

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


IsCurrentLang Property

CYQ.Data API 帮助文档 For V5

XHtmlAction.IsCurrentLang Property

当前请求是否用户当前设置的语言

public IsCurrentLang {get; set;}

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


OutXml Property

CYQ.Data API 帮助文档 For V5

XHtmlAction.OutXml Property

public override OutXml {get;}

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction Methods

The methods of the XHtmlAction class are listed below. For a complete list of XHtmlAction class members, see the XHtmlAction Members topic.

Public Instance Methods

AppendNode | Overloaded.
Clear | 保留节点,但清除节点所内容/属性
Contains | Overloaded.
CreateNode |
CreateNodeTo |
Dispose |
Get | Overloaded. GetByID or GetByName
GetAttrValue | Overloaded.
GetByID | Overloaded.
GetByName | Overloaded.
GetList | Overloaded.
HasAttr | Overloaded.
InsertAfter | 节点之后插入[支持两文档之间的插入]
InsertBefore | 节点之前插入[支持两文档之间的插入]
InterChange | 两个节点交换位置
LoadData | Overloaded. 加载MDataTable的多行数据
Remove | Overloaded.
RemoveAllChild | Overloaded.
RemoveAttr | Overloaded.
RemoveAttrList | Overloaded. 移除多个属性
RemoveChild | Overloaded. 移除子节点
RemoveCommentNode | Overloaded. 移除注释节点
ReplaceNode | Overloaded.
Set | Overloaded. 为节点赋值[通常值是在values中赋值]
SetFor | Overloaded. 为节点设置值，通常在LoadData后使用。
SetForeach | Overloaded.
ToJson | Overloaded. 转Json

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


AppendNode Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.AppendNode Method

Overload List

public void AppendNode(XmlNode,XmlNode);

添加节点

public void AppendNode(XmlNode,XmlNode,Int32);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.AppendNode Method (XmlNode, XmlNode)

public void AppendNode(
XmlNode parentNode,
XmlNode childNode
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.AppendNode Overload List


XHtmlAction.AppendNode Method (XmlNode, XmlNode, Int32)

添加节点

public void AppendNode(
XmlNode parentNode,
XmlNode childNode,
Int32 position
);

Parameters

XmlNode
XmlNode
Int32
parentNode的第N个子节点之后

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.AppendNode Overload List


XHtmlAction.Clear Method

保留节点,但清除节点所内容/属性

public void Clear(
XmlNode node
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


Contains Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.Contains Method

Overload List

public bool Contains(String);

public bool Contains(String,XmlNode);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.Contains Method (String)

public bool Contains(
String idOrName
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.Contains Overload List


XHtmlAction.Contains Method (String, XmlNode)

public bool Contains(
String idOrName,
XmlNode parentNode
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.Contains Overload List


XHtmlAction.CreateNode Method

public XmlNode CreateNode(
String tag,
String text,
params String[] attrAndValue
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.CreateNodeTo Method

public void CreateNodeTo(
XmlNode parentNode,
String tag,
String text,
params String[] attrAndValue
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.Dispose Method

public override void Dispose();

Implements

IDisposable.

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


Get Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.Get Method

GetByID or GetByName

Overload List

GetByID or GetByName

public XmlNode Get(String);

public XmlNode Get(String,String,String,XmlNode);

public XmlNode Get(String,XmlNode);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.Get Method (String)

GetByID or GetByName

public XmlNode Get(
String idOrName
);

Parameters

String
id or name

Return Value

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.Get Overload List


XHtmlAction.Get Method (String, String, String, XmlNode)

public XmlNode Get(
String tag,
String attr,
String value,
XmlNode parentNode
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.Get Overload List


XHtmlAction.Get Method (String, XmlNode)

public XmlNode Get(
String idOrName,
XmlNode parentNode
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.Get Overload List


GetAttrValue Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.GetAttrValue Method

Overload List

public string GetAttrValue(String,String,params String[]);

public string GetAttrValue(XmlNode,String,params String[]);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.GetAttrValue Method (String, String, String[])

public string GetAttrValue(
String idOrName,
String attrName,
params String[] defaultValue
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.GetAttrValue Overload List


XHtmlAction.GetAttrValue Method (XmlNode, String, String[])

public string GetAttrValue(
XmlNode node,
String attrName,
params String[] defaultValue
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.GetAttrValue Overload List


GetByID Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.GetByID Method

Overload List

public XmlNode GetByID(String);

public XmlNode GetByID(String,XmlNode);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.GetByID Method (String)

public XmlNode GetByID(
String id
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.GetByID Overload List


XHtmlAction.GetByID Method (String, XmlNode)

public XmlNode GetByID(
String id,
XmlNode parentNode
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.GetByID Overload List


GetByName Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.GetByName Method

Overload List

public XmlNode GetByName(String);

public XmlNode GetByName(String,XmlNode);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.GetByName Method (String)

public XmlNode GetByName(
String name
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.GetByName Overload List


XHtmlAction.GetByName Method (String, XmlNode)

public XmlNode GetByName(
String name,
XmlNode parentNode
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.GetByName Overload List


GetList Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.GetList Method

Overload List

public XmlNodeList GetList(String);

public XmlNodeList GetList(String,String);

public XmlNodeList GetList(String,String,String);

public XmlNodeList GetList(String,String,String,XmlNode);

public XmlNodeList GetList(String,String,XmlNode);

public XmlNodeList GetList(String,XmlNode);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.GetList Method (String)

public XmlNodeList GetList(
String tag
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.GetList Overload List


XHtmlAction.GetList Method (String, String)

public XmlNodeList GetList(
String tag,
String attr
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.GetList Overload List


XHtmlAction.GetList Method (String, String, String)

public XmlNodeList GetList(
String tag,
String attr,
String value
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.GetList Overload List


XHtmlAction.GetList Method (String, String, String, XmlNode)

public XmlNodeList GetList(
String tag,
String attr,
String value,
XmlNode parentNode
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.GetList Overload List


XHtmlAction.GetList Method (String, String, XmlNode)

public XmlNodeList GetList(
String tag,
String attr,
XmlNode parentNode
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.GetList Overload List


XHtmlAction.GetList Method (String, XmlNode)

public XmlNodeList GetList(
String tag,
XmlNode parentNode
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.GetList Overload List


HasAttr Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.HasAttr Method

Overload List

public bool HasAttr(String,String);

public bool HasAttr(XmlNode,String);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.HasAttr Method (String, String)

public bool HasAttr(
String idOrName,
String attrName
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.HasAttr Overload List


XHtmlAction.HasAttr Method (XmlNode, String)

public bool HasAttr(
XmlNode node,
String attrName
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.HasAttr Overload List


XHtmlAction.InsertAfter Method

节点之后插入[支持两文档之间的插入]

public void InsertAfter(
XmlNode newNode,
XmlNode refNode
);

Parameters

XmlNode
XmlNode

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.InsertBefore Method

节点之前插入[支持两文档之间的插入]

public void InsertBefore(
XmlNode newNode,
XmlNode refNode
);

Parameters

XmlNode
XmlNode

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.InterChange Method

两个节点交换位置

public void InterChange(
XmlNode xNodeFirst,
XmlNode xNodeLast
);

Parameters

XmlNode
XmlNode

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


LoadData Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.LoadData Method

装载行数据 （一般后续配合SetFor方法使用）

Overload List

装载行数据 （一般后续配合SetFor方法使用）

public void LoadData(MDataRow);

装载数据行 （一般后续配合SetFor方法使用或CMS替换）

public void LoadData(MDataRow,String);

装载数据行 （一般后续配合SetForeach方法使用）

public void LoadData(MDataTable);

加载MDataTable的多行数据

public void LoadData(Object);

加载MDatarow行数据（CMS替换）

public void LoadData(Object,String);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.LoadData Method (MDataRow)

装载行数据 （一般后续配合SetFor方法使用）

public void LoadData(
MDataRow row
);

Parameters

MDataRow
数据行

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.LoadData Overload List


XHtmlAction.LoadData Method (MDataRow, String)

装载数据行 （一般后续配合SetFor方法使用或CMS替换）

public void LoadData(
MDataRow row,
String pre
);

Parameters

MDataRow
String
为所有字段名指定前缀（如："a.",或空前缀：""）

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.LoadData Overload List


XHtmlAction.LoadData Method (MDataTable)

装载数据行 （一般后续配合SetForeach方法使用）

public void LoadData(
MDataTable table
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.LoadData Overload List


XHtmlAction.LoadData Method (Object)

加载MDataTable的多行数据

public void LoadData(
Object anyObjToTable
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.LoadData Overload List


XHtmlAction.LoadData Method (Object, String)

加载MDatarow行数据（CMS替换）

public void LoadData(
Object anyObjToRow,
String pre
);

Parameters

Object
String
为所有字段名指定前缀（如："a.",或空前缀：""

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.LoadData Overload List


Remove Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.Remove Method

Overload List

public void Remove(String);

public void Remove(XmlNode);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.Remove Method (String)

public void Remove(
String idOrName
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.Remove Overload List


XHtmlAction.Remove Method (XmlNode)

public void Remove(
XmlNode node
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.Remove Overload List


RemoveAllChild Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.RemoveAllChild Method

Overload List

public void RemoveAllChild(String);

public void RemoveAllChild(XmlNode);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.RemoveAllChild Method (String)

public void RemoveAllChild(
String idOrName
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.RemoveAllChild Overload List


XHtmlAction.RemoveAllChild Method (XmlNode)

public void RemoveAllChild(
XmlNode node
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.RemoveAllChild Overload List


RemoveAttr Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.RemoveAttr Method

Overload List

public void RemoveAttr(String,params String[]);

public void RemoveAttr(XmlNode,params String[]);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.RemoveAttr Method (String, String[])

public void RemoveAttr(
String idOrName,
params String[] attrNames
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.RemoveAttr Overload List


XHtmlAction.RemoveAttr Method (XmlNode, String[])

public void RemoveAttr(
XmlNode node,
params String[] attrNames
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.RemoveAttr Overload List


RemoveAttrList Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.RemoveAttrList Method

属性移除

Overload List

属性移除

public void RemoveAttrList(String,SetType);

移除多个属性

public void RemoveAttrList(params String[]);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.RemoveAttrList Method (String, SetType)

属性移除

public void RemoveAttrList(
String attrName,
SetType excludeSetType
);

Parameters

String
属性名称
SetType
排除的节点类型

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.RemoveAttrList Overload List


XHtmlAction.RemoveAttrList Method (String[])

移除多个属性

public void RemoveAttrList(
params String[] attrNames
);

Parameters

String[]

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.RemoveAttrList Overload List


RemoveChild Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.RemoveChild Method

移除子节点

Overload List

移除子节点

public void RemoveChild(String,Int32);

移除子节点

public void RemoveChild(XmlNode,Int32);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.RemoveChild Method (String, Int32)

移除子节点

public void RemoveChild(
String idOrName,
Int32 start
);

Parameters

String
Int32
从第几个子节点开始删除[索引从0开始]

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.RemoveChild Overload List


XHtmlAction.RemoveChild Method (XmlNode, Int32)

移除子节点

public void RemoveChild(
XmlNode node,
Int32 start
);

Parameters

XmlNode
节点
Int32
从第几个子节点开始删除[索引从0开始]

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.RemoveChild Overload List


RemoveCommentNode Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.RemoveCommentNode Method

移除注释节点

Overload List

移除注释节点

public override void RemoveCommentNode();

移除注释节点

public void RemoveCommentNode(XmlNode);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.RemoveCommentNode Method ()

移除注释节点

public override void RemoveCommentNode();

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.RemoveCommentNode Overload List


XHtmlAction.RemoveCommentNode Method (XmlNode)

移除注释节点

public void RemoveCommentNode(
XmlNode node
);

Parameters

XmlNode
移除此节点的注释文本

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.RemoveCommentNode Overload List


ReplaceNode Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.ReplaceNode Method

Overload List

public void ReplaceNode(XmlNode,String);

节点替换[支持两个的文档间替换]

public void ReplaceNode(XmlNode,XmlNode);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.ReplaceNode Method (XmlNode, String)

public void ReplaceNode(
XmlNode newNode,
String oldNodeIDorName
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.ReplaceNode Overload List


XHtmlAction.ReplaceNode Method (XmlNode, XmlNode)

节点替换[支持两个的文档间替换]

public void ReplaceNode(
XmlNode newNode,
XmlNode oldNode
);

Parameters

XmlNode
XmlNode

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.ReplaceNode Overload List


Set Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.Set Method

Overload List

public void Set(String,SetType,params String[]);

public void Set(String,String);

为节点赋值[通常值是在values中赋值]

public void Set(XmlNode,SetType,params String[]);

public void Set(XmlNode,String,SetType,params String[]);

对节点赋值（此方法会忽略hidden隐藏域，隐藏节点赋值请用其它重载方法）

public void Set(XmlNode,String,String);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.Set Method (String, SetType, String[])

public void Set(
String idOrName,
SetType setType,
params String[] values
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.Set Overload List


XHtmlAction.Set Method (String, String)

public void Set(
String idOrName,
String value
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.Set Overload List


XHtmlAction.Set Method (XmlNode, SetType, String[])

为节点赋值[通常值是在values中赋值]

public void Set(
XmlNode node,
SetType setType,
params String[] values
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.Set Overload List


XHtmlAction.Set Method (XmlNode, String, SetType, String[])

public void Set(
XmlNode parentNode,
String idOrName,
SetType setType,
params String[] values
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.Set Overload List


XHtmlAction.Set Method (XmlNode, String, String)

对节点赋值（此方法会忽略hidden隐藏域，隐藏节点赋值请用其它重载方法）

public void Set(
XmlNode parentNode,
String idOrName,
String value
);

Parameters

XmlNode
String
String

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.Set Overload List


SetFor Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.SetFor Method

为节点设置值，通常在LoadData后使用。

Overload List

为节点设置值，通常在LoadData后使用。

public void SetFor(String);

为节点设置值，通常在LoadData后使用。

public void SetFor(String,SetType);

为节点设置值，通常在LoadData后使用。

public void SetFor(String,SetType,params String[]);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.SetFor Method (String)

为节点设置值，通常在LoadData后使用。

public void SetFor(
String idOrName
);

Parameters

String

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.SetFor Overload List


XHtmlAction.SetFor Method (String, SetType)

为节点设置值，通常在LoadData后使用。

public void SetFor(
String idOrName,
SetType setType
);

Parameters

String
SetType
节点的类型

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.SetFor Overload List


XHtmlAction.SetFor Method (String, SetType, String[])

为节点设置值，通常在LoadData后使用。

public void SetFor(
String idOrName,
SetType setType,
params String[] values
);

Parameters

String
SetType
String[]
setType为Custom时，可自定义值，如“"href","http://www.cyqdata.com","target","_blank"”

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.SetFor Overload List


SetForeach Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.SetForeach Method

Overload List

public void SetForeach();

public void SetForeach(String,SetType,params Object[]);

public void SetForeach(String,String,params Object[]);

public void SetForeach(XmlNode,String,params Object[]);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.SetForeach Method ()

public void SetForeach();

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.SetForeach Overload List


XHtmlAction.SetForeach Method (String, SetType, Object[])

public void SetForeach(
String idOrName,
SetType setType,
params Object[] formatValues
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.SetForeach Overload List


XHtmlAction.SetForeach Method (String, String, Object[])

public void SetForeach(
String idOrName,
String text,
params Object[] formatValues
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.SetForeach Overload List


XHtmlAction.SetForeach Method (XmlNode, String, Object[])

public void SetForeach(
XmlNode node,
String text,
params Object[] formatValues
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.SetForeach Overload List


ToJson Method

CYQ.Data API 帮助文档 For V5

XHtmlAction.ToJson Method

转Json

Overload List

转Json

public string ToJson();

转Json 可设置一个节点（默认根节点）是否将属性值也输出

public string ToJson(XmlNode,Boolean);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.ToJson Method ()

转Json

public string ToJson();

Return Value

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.ToJson Overload List


XHtmlAction.ToJson Method (XmlNode, Boolean)

转Json 可设置一个节点（默认根节点）是否将属性值也输出

public string ToJson(
XmlNode parent,
Boolean isWithAttr
);

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace | XHtmlAction.ToJson Overload List


XHtmlAction Events

The events of the XHtmlAction class are listed below. For a complete list of XHtmlAction class members, see the XHtmlAction Members topic.

Public Instance Events

OnForeach 对于SetForeach函数调用的格式化事件

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.XHtmlAction.SetForeachEventHandler Event

对于SetForeach函数调用的格式化事件

public event OnForeach;

See Also

XHtmlAction Class | CYQ.Data.Xml Namespace


XHtmlAction.SetForeachEventHandler Delegate

public delegate string XHtmlAction.SetForeachEventHandler(
String text,
MDictionary<K,V> values,
Int32 rowIndex
);

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Xml Namespace


XHtmlBase Class

操作Xml及XHtml的基类

For a list of all members of this type, see XHtmlBase Members.

System.Object
XHtmlBase
XHtmlAction

public class XHtmlBase :

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

XHtmlBase Members | CYQ.Data.Xml Namespace


XHtmlBase Members

XHtmlBase overview

Public Instance Constructors

XHtmlBase Constructor

Public Instance Fields

XmlCacheKey xml缓存的key

Public Instance Properties

CacheMinutes | 缓存分钟数(ReadOnly)
Encoding | 文件编码
FileName | 加载的Xml文件的完整（路径）名称（ReadOnly）
IsLoadFromCache | 文档是否取自缓存
IsNoClone | 存取档不克隆（此时XHtml应是只读模式)
IsXHtmlChanged | 加载的Html是否已改变（ReadOnly）
OutXml | 返回最终格式化后的XHtml内容（ReadOnly）
XmlDoc | 内部XmlDocument对象（ReadOnly）

Public Instance Methods

ClearCDATA | 清除CDATA
Dispose | 释放资源
Load | Overloaded. 从文件中加载Xml
LoadFromCache | 从缓存中加载html
LoadXml | 从xml字符串加载
RemoveCommentNode | 移除所有注释节点
Save | Overloaded. 文件保存
SaveToCache | Overloaded. 将文档缓存到全局Cache中
SetCDATA | 给指定的字符加上CDATA

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XHtmlBase Constructor

public XHtmlBase();

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XHtmlBase Fields

The fields of the XHtmlBase class are listed below. For a complete list of XHtmlBase class members, see the XHtmlBase Members topic.

Public Instance Fields

XmlCacheKey xml缓存的key

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XHtmlBase.XmlCacheKey Field

xml缓存的key

public String XmlCacheKey;

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XHtmlBase Properties

The properties of the XHtmlBase class are listed below. For a complete list of XHtmlBase class members, see the XHtmlBase Members topic.

Public Instance Properties

CacheMinutes | 缓存分钟数(ReadOnly)
Encoding | 文件编码
FileName | 加载的Xml文件的完整（路径）名称（ReadOnly）
IsLoadFromCache | 文档是否取自缓存
IsNoClone | 存取档不克隆（此时XHtml应是只读模式)
IsXHtmlChanged | 加载的Html是否已改变（ReadOnly）
OutXml | 返回最终格式化后的XHtml内容（ReadOnly）
XmlDoc | 内部XmlDocument对象（ReadOnly）

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


CacheMinutes Property

CYQ.Data API 帮助文档 For V5

XHtmlBase.CacheMinutes Property

缓存分钟数(ReadOnly)

public CacheMinutes {get;}

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


Encoding Property

CYQ.Data API 帮助文档 For V5

XHtmlBase.Encoding Property

文件编码

public Encoding {get; set;}

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


FileName Property

CYQ.Data API 帮助文档 For V5

XHtmlBase.FileName Property

加载的Xml文件的完整（路径）名称（ReadOnly）

public FileName {get;}

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


IsLoadFromCache Property

CYQ.Data API 帮助文档 For V5

XHtmlBase.IsLoadFromCache Property

文档是否取自缓存

public IsLoadFromCache {get; set;}

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


IsNoClone Property

CYQ.Data API 帮助文档 For V5

XHtmlBase.IsNoClone Property

存取档不克隆（此时XHtml应是只读模式)

public IsNoClone {get; set;}

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


IsXHtmlChanged Property

CYQ.Data API 帮助文档 For V5

XHtmlBase.IsXHtmlChanged Property

加载的Html是否已改变（ReadOnly）

public IsXHtmlChanged {get;}

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


OutXml Property

CYQ.Data API 帮助文档 For V5

XHtmlBase.OutXml Property

返回最终格式化后的XHtml内容（ReadOnly）

public virtual OutXml {get;}

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XmlDoc Property

CYQ.Data API 帮助文档 For V5

XHtmlBase.XmlDoc Property

内部XmlDocument对象（ReadOnly）

public XmlDoc {get;}

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XHtmlBase Methods

The methods of the XHtmlBase class are listed below. For a complete list of XHtmlBase class members, see the XHtmlBase Members topic.

Public Instance Methods

ClearCDATA | 清除CDATA
Dispose | 释放资源
Load | Overloaded. 从文件中加载Xml
LoadFromCache | 从缓存中加载html
LoadXml | 从xml字符串加载
RemoveCommentNode | 移除所有注释节点
Save | Overloaded. 文件保存
SaveToCache | Overloaded. 将文档缓存到全局Cache中
SetCDATA | 给指定的字符加上CDATA

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XHtmlBase.ClearCDATA Method

清除CDATA

public string ClearCDATA(
String text
);

Parameters

String
对象字符

Return Value

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XHtmlBase.Dispose Method

释放资源

public virtual void Dispose();

Implements

IDisposable.

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


Load Method

CYQ.Data API 帮助文档 For V5

XHtmlBase.Load Method

从文件中加载Xml

Overload List

从文件中加载Xml

public bool Load(String);

加载XML

public bool Load(String,XmlCacheLevel);

加载Xml文件

public bool Load(String,XmlCacheLevel,Boolean);

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XHtmlBase.Load Method (String)

从文件中加载Xml

public bool Load(
String fileName
);

Parameters

String

Return Value

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace | XHtmlBase.Load Overload List


XHtmlBase.Load Method (String, XmlCacheLevel)

加载XML

public bool Load(
String fileName,
XmlCacheLevel level
);

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace | XHtmlBase.Load Overload List


XHtmlBase.Load Method (String, XmlCacheLevel, Boolean)

加载Xml文件

public bool Load(
String fileName,
XmlCacheLevel level,
Boolean clearCommentNode
);

Parameters

String
文件名
XmlCacheLevel
文件缓存级别
Boolean
加载后是否清除注释节点

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace | XHtmlBase.Load Overload List


XHtmlBase.LoadFromCache Method

从缓存中加载html

public bool LoadFromCache(
String key
);

Parameters

String

Return Value

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XHtmlBase.LoadXml Method

从xml字符串加载

public void LoadXml(
String xml
);

Parameters

String
xml字符串

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XHtmlBase.RemoveCommentNode Method

移除所有注释节点

public virtual void RemoveCommentNode();

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


Save Method

CYQ.Data API 帮助文档 For V5

XHtmlBase.Save Method

文件保存

Overload List

文件保存

public bool Save();

public bool Save(String);

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XHtmlBase.Save Method ()

文件保存

public bool Save();

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace | XHtmlBase.Save Overload List


XHtmlBase.Save Method (String)

public bool Save(
String fileName
);

Parameters

String
指定保存路径

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace | XHtmlBase.Save Overload List


SaveToCache Method

CYQ.Data API 帮助文档 For V5

XHtmlBase.SaveToCache Method

将文档缓存到全局Cache中

Overload List

将文档缓存到全局Cache中

public void SaveToCache(String,Boolean);

将文档缓存到全局Cache中

public void SaveToCache(String,Boolean,Double);

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XHtmlBase.SaveToCache Method (String, Boolean)

将文档缓存到全局Cache中

public void SaveToCache(
String key,
Boolean isClone
);

Parameters

String
缓存的Key名称
Boolean
是否克隆副本存档

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace | XHtmlBase.SaveToCache Overload List


XHtmlBase.SaveToCache Method (String, Boolean, Double)

将文档缓存到全局Cache中

public void SaveToCache(
String key,
Boolean isClone,
Double cacheTimeMinutes
);

Parameters

String
缓存的Key名称
Boolean
是否克隆副本存档
Double
存档的分钟数

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace | XHtmlBase.SaveToCache Overload List


XHtmlBase.SetCDATA Method

给指定的字符加上CDATA

public string SetCDATA(
String text
);

Parameters

String
对象字符

Return Value

See Also

XHtmlBase Class | CYQ.Data.Xml Namespace


XmlCacheLevel Enumeration

Xml|XHtml 加载后缓存级别

public enum XmlCacheLevel

Members

Member Name | Description
NoCache | 无缓存
Lower | 低缓存,5分钟
Default | 默认取自配置项CacheTime时间,
Minute | 1分钟
Hour | 1小时
Day | 1天时间
Week | 一周时间

Requirements

Namespace: CYQ.Data.Xml

Assembly: CYQ.Data (in CYQ.Data.dll)

See Also

CYQ.Data.Xml Namespace


Hierarchy

System.Object
CYQ.Data.Aop.AopCustomDbPara
CYQ.Data.Aop.AopInfo
CYQ.Data.Aop.IAop
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
CYQ.Data.Aop.AopEnum
CYQ.Data.Aop.AopOp
CYQ.Data.Aop.AopResult

See Also

CYQ.Data.Aop Namespace


Hierarchy

System.Object
CYQ.Data.Cache.CacheManage
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
CYQ.Data.Cache.CacheKeyType
CYQ.Data.Cache.CacheType

See Also

CYQ.Data.Cache Namespace


Hierarchy

System.Object
CYQ.Data.Extension.IField

See Also

CYQ.Data.Extension Namespace


Hierarchy

System.Object
CYQ.Data.Orm.DBFast
CYQ.Data.Orm.SimpleOrmBase ---- System.IDisposable
System.Attribute
CYQ.Data.Orm.DefaultValueAttribute
CYQ.Data.Orm.DescriptionAttribute
CYQ.Data.Orm.KeyAttribute
CYQ.Data.Orm.LengthAttribute
System.MarshalByRefObject
System.ContextBoundObject
CYQ.Data.Orm.OrmBase ---- System.IDisposable
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
CYQ.Data.Orm.FieldSource

See Also

CYQ.Data.Orm Namespace


Hierarchy

System.Object
CYQ.Data.SQL.DataType
CYQ.Data.SQL.SqlValue

See Also

CYQ.Data.SQL Namespace


Hierarchy

System.Object
CYQ.Data.Table.MCellStruct
CYQ.Data.Table.MDataCell
CYQ.Data.Table.MDataColumn ---- System.Collections.Generic.ICollection`1, System.Collections.Generic.IEnumerable`1, System.Collections.Generic.IList`1, System.Collections.IEnumerable
CYQ.Data.Table.MDataRow ---- System.Collections.Generic.ICollection`1, System.Collections.Generic.IEnumerable`1, System.Collections.Generic.IList`1, System.Collections.IEnumerable, System.ComponentModel.ICustomTypeDescriptor, System.Data.IDataRecord
CYQ.Data.Table.MDataRowCollection ---- System.Collections.Generic.ICollection`1, System.Collections.Generic.IComparer`1, System.Collections.Generic.IEnumerable`1, System.Collections.Generic.IList`1, System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList, System.ComponentModel.IBindingList
CYQ.Data.Table.MDataTable ---- System.Collections.IEnumerable, System.Data.IDataReader, System.Data.IDataRecord, System.IDisposable
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
CYQ.Data.Table.AcceptOp
CYQ.Data.Table.AlterOp
CYQ.Data.Table.BreakOp
CYQ.Data.Table.RowOp

See Also

CYQ.Data.Table Namespace


Hierarchy

System.Object
CYQ.Data.Tool.ConvertTool
CYQ.Data.Tool.DBTool
CYQ.Data.Tool.EncryptHelper
CYQ.Data.Tool.IOHelper
CYQ.Data.Tool.JsonHelper
CYQ.Data.Tool.ReflectTool
CYQ.Data.Tool.ThreadBreak
System.Collections.Generic.Dictionary`2 ---- System.Collections.Generic.ICollection`1, System.Collections.Generic.IDictionary`2, System.Collections.Generic.IEnumerable`1, System.Collections.Generic.IReadOnlyCollection`1, System.Collections.Generic.IReadOnlyDictionary`2, System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable, System.Runtime.Serialization.IDeserializationCallback, System.Runtime.Serialization.ISerializable
CYQ.Data.Tool.MDictionary`2
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
CYQ.Data.Tool.EscapeOp
CYQ.Data.Tool.SysType

See Also

CYQ.Data.Tool Namespace


Hierarchy

System.Object
CYQ.Data.UI.IUIValue
CYQ.Data.UI.MActionUI ---- System.IDisposable
CYQ.Data.UI.RegisterUI

See Also

CYQ.Data.UI Namespace


Hierarchy

System.Object
CYQ.Data.Xml.MutilLanguage ---- System.IDisposable
CYQ.Data.Xml.Rss
CYQ.Data.Xml.RssChannel
CYQ.Data.Xml.RssImage
CYQ.Data.Xml.RssItem
CYQ.Data.Xml.ValueReplace
CYQ.Data.Xml.XHtmlBase ---- System.IDisposable
CYQ.Data.Xml.XHtmlAction
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
CYQ.Data.Xml.Rss.SetForeachEventHandler
CYQ.Data.Xml.XHtmlAction.SetForeachEventHandler
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
CYQ.Data.Xml.LanguageKey
CYQ.Data.Xml.RssItemName
CYQ.Data.Xml.SetType
CYQ.Data.Xml.XmlCacheLevel

See Also

CYQ.Data.Xml Namespace


Hierarchy

System.Object
CYQ.Data.AppConfig
CYQ.Data.AppConfig.Cache
CYQ.Data.AppConfig.DB
CYQ.Data.AppConfig.Debug
CYQ.Data.AppConfig.Log
CYQ.Data.AppConfig.UI
CYQ.Data.AppConfig.XHtml
CYQ.Data.AppDebug
CYQ.Data.Log
CYQ.Data.LogType
CYQ.Data.MAction ---- System.IDisposable
CYQ.Data.MProc ---- System.IDisposable
CYQ.Data.Orm.SimpleOrmBase ---- System.IDisposable
CYQ.Data.SysLogs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
CYQ.Data.DalType
CYQ.Data.InsertOp
CYQ.Data.ParaType

See Also

CYQ.Data Namespace